Linux-Bluetooth Archive on lore.kernel.org
 help / Atom feed
* [Bug 202203] New: Bluetooth mouse doesn't move until sending a pair request
@ 2019-01-09 21:03 bugzilla-daemon
  2019-01-09 21:04 ` [Bug 202203] " bugzilla-daemon
  0 siblings, 1 reply; 2+ messages in thread
From: bugzilla-daemon @ 2019-01-09 21:03 UTC (permalink / raw)
  To: linux-bluetooth

https://bugzilla.kernel.org/show_bug.cgi?id=202203

            Bug ID: 202203
           Summary: Bluetooth mouse doesn't move until sending a pair
                    request
           Product: Drivers
           Version: 2.5
    Kernel Version: 4.20
          Hardware: All
                OS: Linux
              Tree: Mainline
            Status: NEW
          Severity: normal
          Priority: P1
         Component: Bluetooth
          Assignee: linux-bluetooth@vger.kernel.org
          Reporter: felixonmars@gmail.com
        Regression: No

Created attachment 280363
  --> https://bugzilla.kernel.org/attachment.cgi?id=280363&action=edit
btmon output when the mouse "connects" but not moving

My Bluetooth LE mouse (Rapoo MT750) doesn't move when it's turned off and on
again. The problem is that it's shown as connected but the pointer won't move.
The mouse itself (reading from LED) doesn't think it's connected.

The mouse works if I disable/re-enable bluetooth (using laptop's key binding),
or simply send a "pair" command in bluetoothctl. The pair operation here will
always timeout, but the mouse correctly moves right after sending the command.
The pair command will succeed after a second try (after the first timeout), but
it doesn't fix the problem (shown as unpaired after reconnecting).

-- 
You are receiving this mail because:
You are the assignee for the bug.

^ permalink raw reply	[flat|nested] 2+ messages in thread

* [Bug 202203] Bluetooth mouse doesn't move until sending a pair request
  2019-01-09 21:03 [Bug 202203] New: Bluetooth mouse doesn't move until sending a pair request bugzilla-daemon
@ 2019-01-09 21:04 ` " bugzilla-daemon
  0 siblings, 0 replies; 2+ messages in thread
From: bugzilla-daemon @ 2019-01-09 21:04 UTC (permalink / raw)
  To: linux-bluetooth

https://bugzilla.kernel.org/show_bug.cgi?id=202203

--- Comment #1 from Felix Yan (felixonmars@gmail.com) ---
Created attachment 280365
  --> https://bugzilla.kernel.org/attachment.cgi?id=280365&action=edit
btmon output when sending "pair" command, which finally makes the mouse move
correctly

-- 
You are receiving this mail because:
You are the assignee for the bug.

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, back to index

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-01-09 21:03 [Bug 202203] New: Bluetooth mouse doesn't move until sending a pair request bugzilla-daemon
2019-01-09 21:04 ` [Bug 202203] " bugzilla-daemon

Linux-Bluetooth Archive on lore.kernel.org

Archives are clonable:
	git clone --mirror https://lore.kernel.org/linux-bluetooth/0 linux-bluetooth/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 linux-bluetooth linux-bluetooth/ https://lore.kernel.org/linux-bluetooth \
		linux-bluetooth@vger.kernel.org linux-bluetooth@archiver.kernel.org
	public-inbox-index linux-bluetooth


Newsgroup available over NNTP:
	nntp://nntp.lore.kernel.org/org.kernel.vger.linux-bluetooth


AGPL code for this site: git clone https://public-inbox.org/ public-inbox