Linux-Bluetooth Archive on lore.kernel.org
 help / color / Atom feed
* [Bug 209717] New: Bluetooth mouse Logitech M720 doesn't work
@ 2020-10-16 14:39 bugzilla-daemon
  2020-10-18 17:18 ` [Bug 209717] " bugzilla-daemon
                   ` (4 more replies)
  0 siblings, 5 replies; 6+ messages in thread
From: bugzilla-daemon @ 2020-10-16 14:39 UTC (permalink / raw)
  To: linux-bluetooth

https://bugzilla.kernel.org/show_bug.cgi?id=209717

            Bug ID: 209717
           Summary: Bluetooth mouse Logitech M720 doesn't work
           Product: Drivers
           Version: 2.5
    Kernel Version: 5.9.0
          Hardware: All
                OS: Linux
              Tree: Mainline
            Status: NEW
          Severity: normal
          Priority: P1
         Component: Bluetooth
          Assignee: linux-bluetooth@vger.kernel.org
          Reporter: mathieu.ahtec@gmail.com
        Regression: No

My bluetooth mouse stopped working when I moved from the kernel 5.8 to 5.9.

When I tried to pair the mouse without touching it, it didn't work. 

But if I keep on moving the mouse while pairing it, it works.

If I shutdown the computer or the mouse, I have to pair it again.


My Hardware :
Laptop : ASUS Zephyrus G14
CPU : AMD Ryzen 9 4900HS
Mouse : Logitech M720 Triathlon

-- 
You are receiving this mail because:
You are the assignee for the bug.

^ permalink raw reply	[flat|nested] 6+ messages in thread

* [Bug 209717] Bluetooth mouse Logitech M720 doesn't work
  2020-10-16 14:39 [Bug 209717] New: Bluetooth mouse Logitech M720 doesn't work bugzilla-daemon
@ 2020-10-18 17:18 ` bugzilla-daemon
  2020-10-18 17:24 ` bugzilla-daemon
                   ` (3 subsequent siblings)
  4 siblings, 0 replies; 6+ messages in thread
From: bugzilla-daemon @ 2020-10-18 17:18 UTC (permalink / raw)
  To: linux-bluetooth

https://bugzilla.kernel.org/show_bug.cgi?id=209717

Leho Kraav (leho@kraav.com) changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |leho@kraav.com

--- Comment #1 from Leho Kraav (leho@kraav.com) ---
Yes, something is wrong with 5.9 bluetooth stack.

My DELL keyboard and MX Ergo mouse both stop connecting after upgrading from
5.8.

I managed to somehow reconnect them once, but after they disconnect in idle,
they fail to reconnect on their own and no amount of bluetooth toggling gets
them back.

BT toggling shows "[13543.597906] Bluetooth: hci0: HCI reset during shutdown
failed" in demsg.

-- 
You are receiving this mail because:
You are the assignee for the bug.

^ permalink raw reply	[flat|nested] 6+ messages in thread

* [Bug 209717] Bluetooth mouse Logitech M720 doesn't work
  2020-10-16 14:39 [Bug 209717] New: Bluetooth mouse Logitech M720 doesn't work bugzilla-daemon
  2020-10-18 17:18 ` [Bug 209717] " bugzilla-daemon
@ 2020-10-18 17:24 ` bugzilla-daemon
  2020-10-19 11:44 ` bugzilla-daemon
                   ` (2 subsequent siblings)
  4 siblings, 0 replies; 6+ messages in thread
From: bugzilla-daemon @ 2020-10-18 17:24 UTC (permalink / raw)
  To: linux-bluetooth

https://bugzilla.kernel.org/show_bug.cgi?id=209717

--- Comment #2 from Leho Kraav (leho@kraav.com) ---
(In reply to Leho Kraav from comment #1)
> Yes, something is wrong with 5.9 bluetooth stack.

PS I went straight to 5.9.1.

00:14.3 Network controller: Intel Corporation Killer Wi-Fi 6 AX1650i 160MHz
Wireless Network Adapter (201NGW) (rev 30) on XPS 7390 2-in-1 Ice Lake.

-- 
You are receiving this mail because:
You are the assignee for the bug.

^ permalink raw reply	[flat|nested] 6+ messages in thread

* [Bug 209717] Bluetooth mouse Logitech M720 doesn't work
  2020-10-16 14:39 [Bug 209717] New: Bluetooth mouse Logitech M720 doesn't work bugzilla-daemon
  2020-10-18 17:18 ` [Bug 209717] " bugzilla-daemon
  2020-10-18 17:24 ` bugzilla-daemon
@ 2020-10-19 11:44 ` bugzilla-daemon
  2020-10-19 11:51 ` bugzilla-daemon
  2020-10-21  9:44 ` bugzilla-daemon
  4 siblings, 0 replies; 6+ messages in thread
From: bugzilla-daemon @ 2020-10-19 11:44 UTC (permalink / raw)
  To: linux-bluetooth

https://bugzilla.kernel.org/show_bug.cgi?id=209717

mskmsk (lithium@live.com) changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |lithium@live.com

--- Comment #3 from mskmsk (lithium@live.com) ---
(In reply to Leho Kraav from comment #2)
> (In reply to Leho Kraav from comment #1)
> > Yes, something is wrong with 5.9 bluetooth stack.
> 
> PS I went straight to 5.9.1.
> 
> 00:14.3 Network controller: Intel Corporation Killer Wi-Fi 6 AX1650i 160MHz
> Wireless Network Adapter (201NGW) (rev 30) on XPS 7390 2-in-1 Ice Lake.

Same issue persists on 5.9.1 

03:00.0 Network controller: Intel Corporation Wi-Fi 6 AX200 (rev 1a)
ThinkPad T14 Gen 1 w/ Logitech MX Master 2S

-- 
You are receiving this mail because:
You are the assignee for the bug.

^ permalink raw reply	[flat|nested] 6+ messages in thread

* [Bug 209717] Bluetooth mouse Logitech M720 doesn't work
  2020-10-16 14:39 [Bug 209717] New: Bluetooth mouse Logitech M720 doesn't work bugzilla-daemon
                   ` (2 preceding siblings ...)
  2020-10-19 11:44 ` bugzilla-daemon
@ 2020-10-19 11:51 ` bugzilla-daemon
  2020-10-21  9:44 ` bugzilla-daemon
  4 siblings, 0 replies; 6+ messages in thread
From: bugzilla-daemon @ 2020-10-19 11:51 UTC (permalink / raw)
  To: linux-bluetooth

https://bugzilla.kernel.org/show_bug.cgi?id=209717

--- Comment #4 from Leho Kraav (leho@kraav.com) ---
I downgraded to 5.8.16 and everything seems to be working fine again across my
home / work locations.

So this does not seem to be about BleedingTooth patches, but something deeper
changed during 5.8 -> 5.9 cycle. Unfortunately I don't have to bandwidth to
bisect.

-- 
You are receiving this mail because:
You are the assignee for the bug.

^ permalink raw reply	[flat|nested] 6+ messages in thread

* [Bug 209717] Bluetooth mouse Logitech M720 doesn't work
  2020-10-16 14:39 [Bug 209717] New: Bluetooth mouse Logitech M720 doesn't work bugzilla-daemon
                   ` (3 preceding siblings ...)
  2020-10-19 11:51 ` bugzilla-daemon
@ 2020-10-21  9:44 ` bugzilla-daemon
  4 siblings, 0 replies; 6+ messages in thread
From: bugzilla-daemon @ 2020-10-21  9:44 UTC (permalink / raw)
  To: linux-bluetooth

https://bugzilla.kernel.org/show_bug.cgi?id=209717

Mat (mathieu.ahtec@gmail.com) changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
         Regression|No                          |Yes

-- 
You are receiving this mail because:
You are the assignee for the bug.

^ permalink raw reply	[flat|nested] 6+ messages in thread

end of thread, back to index

Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-10-16 14:39 [Bug 209717] New: Bluetooth mouse Logitech M720 doesn't work bugzilla-daemon
2020-10-18 17:18 ` [Bug 209717] " bugzilla-daemon
2020-10-18 17:24 ` bugzilla-daemon
2020-10-19 11:44 ` bugzilla-daemon
2020-10-19 11:51 ` bugzilla-daemon
2020-10-21  9:44 ` bugzilla-daemon

Linux-Bluetooth Archive on lore.kernel.org

Archives are clonable:
	git clone --mirror https://lore.kernel.org/linux-bluetooth/0 linux-bluetooth/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 linux-bluetooth linux-bluetooth/ https://lore.kernel.org/linux-bluetooth \
		linux-bluetooth@vger.kernel.org
	public-inbox-index linux-bluetooth

Example config snippet for mirrors

Newsgroup available over NNTP:
	nntp://nntp.lore.kernel.org/org.kernel.vger.linux-bluetooth


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git