Linux-Bluetooth Archive on
 help / color / Atom feed
* first keystroke of BT-keyboards is missed
@ 2019-01-30 19:45 Andrey Butirsky
  0 siblings, 0 replies; only message in thread
From: Andrey Butirsky @ 2019-01-30 19:45 UTC (permalink / raw)
  To: linux-bluetooth

On Tue, 21 Jan 2014 12:32:45 +0100, Alexander Holler 
<holler@xxxxxxxxxxxxx <mailto:holler@DOMAIN.HIDDEN>> wrote:
> Hello,
> I can't remember since when I'm seeing the kernel message "unknown 
> main item tag 0x0" for many Bluetooth input devices, but it is since 
> quiet some time.
> Has someone already tried to find out where that does come from?
> My first guess would be that bluez misses one or more bytes a 
> connection startup, which is based on the fact that, since ever, it 
> misses the first keystroke of BT-keyboards too (the keystroke which 
> wakes up the keyboard and initiates the connection). And I'm pretty 
> sure my keyboard does transmit that initiating keystroke, because 
> Windows receives it. ;) Besides that, that guess isn't based on 
> anything. I neither have tried to search through the source nor did I 
> run some tests. But because I'm curious I can't completely ignore that 
> kernel message, even if I haven't experienced any obvious problems. So 
> here is the question if someone else has a pointer or has already 
> searched what the reason for that message is. I don't think it's a 
> fault of the used device(s), as I see this message for multiple 
> bt-input-devices. 

Hi, I have the same described problem - after BT-keyboard idle(10 min), 
the first keystroke is missed, with "unknown main item tag 0x0" message 
in log.
On the same system, Windows 10 doesn't have the problem - the keystroke 
shows up successfully after reconnect.

Also, the same BT keyboard doesn't miss the keystroke with my Android 
phone (it re-connects still).

This bug is very annoying, as I can't use my keyboard properly.

Any suggestion on problem resolving? I'm ready to assist in debug it 

^ permalink raw reply	[flat|nested] only message in thread

only message in thread, back to index

Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-01-30 19:45 first keystroke of BT-keyboards is missed Andrey Butirsky

Linux-Bluetooth Archive on

Archives are clonable:
	git clone --mirror linux-bluetooth/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 linux-bluetooth linux-bluetooth/ \
	public-inbox-index linux-bluetooth

Newsgroup available over NNTP:

AGPL code for this site: git clone public-inbox