linux-btrfs.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Anand Jain <anand.jain@oracle.com>
To: dsterba@suse.cz, linux-btrfs@vger.kernel.org
Subject: Re: [PATCH v3 1/3] btrfs: kill __btrfs_set_prop()
Date: Thu, 21 Feb 2019 17:03:37 +0800	[thread overview]
Message-ID: <01e83b68-cd54-26ae-f4d1-3702ae13bbca@oracle.com> (raw)
In-Reply-To: <20190220190020.GA9874@twin.jikos.cz>



On 2/21/19 3:00 AM, David Sterba wrote:
> On Tue, Feb 12, 2019 at 10:18:49AM +0800, Anand Jain wrote:
>> btrfs_set_prop() is a redirect to __btrfs_set_prop() with the
>> transaction handler equal to NULL. And __btrfs_set_prop() inturn diectly
>> uses trans to do_setxattr() which when trans is NULL creates a transaction.
> 
> That's right and I think that some of the callsites could actually pass
> the existing transaction to btrfs_set_prop instead of relying on the
> fallback behaviour.
> 
> Also, the potential NULL as transaction handle is not a good thing from
> the API point of view and I'd like to reduce that to minimum (there are
> some justified cases).
> 
>> diff --git a/fs/btrfs/ioctl.c b/fs/btrfs/ioctl.c
>> index 3f9d7be30bf4..5a4ed2f66e09 100644
>> --- a/fs/btrfs/ioctl.c
>> +++ b/fs/btrfs/ioctl.c
>> @@ -284,7 +284,8 @@ static int btrfs_ioctl_setflags(struct file *file, void __user *arg)
>>   		binode->flags &= ~BTRFS_INODE_COMPRESS;
>>   		binode->flags |= BTRFS_INODE_NOCOMPRESS;
>>   
>> -		ret = btrfs_set_prop(inode, "btrfs.compression", NULL, 0, 0);
>> +		ret = btrfs_set_prop(NULL, inode, "btrfs.compression", NULL, 0,
>> +				     0);
>>   		if (ret && ret != -ENODATA)
>>   			goto out_drop;
>>   	} else if (fsflags & FS_COMPR_FL) {
>> @@ -302,13 +303,14 @@ static int btrfs_ioctl_setflags(struct file *file, void __user *arg)
>>   		if (!comp || comp[0] == 0)
>>   			comp = btrfs_compress_type2str(BTRFS_COMPRESS_ZLIB);
>>   
>> -		ret = btrfs_set_prop(inode, "btrfs.compression",
>> -				     comp, strlen(comp), 0);
>> +		ret = btrfs_set_prop(NULL, inode, "btrfs.compression", comp,
>> +				     strlen(comp), 0);
>>   		if (ret)
>>   			goto out_drop;
>>   
>>   	} else {
>> -		ret = btrfs_set_prop(inode, "btrfs.compression", NULL, 0, 0);
>> +		ret = btrfs_set_prop(NULL, inode, "btrfs.compression", NULL, 0,
>> +				     0);
>>   		if (ret && ret != -ENODATA)
>>   			goto out_drop;
>>   		binode->flags &= ~(BTRFS_INODE_COMPRESS | BTRFS_INODE_NOCOMPRESS);
> 
> When the if-else block ends, there's a new transaction started, this
> seems unnecessary.
> 
>> diff --git a/fs/btrfs/props.c b/fs/btrfs/props.c
>> index dc6140013ae8..4525a2a4d1cd 100644
>> --- a/fs/btrfs/props.c
>> +++ b/fs/btrfs/props.c
>> @@ -85,12 +85,9 @@ static const struct hlist_head *find_prop_handlers_by_hash(const u64 hash)
>>   	return NULL;
>>   }
>>   
>> -static int __btrfs_set_prop(struct btrfs_trans_handle *trans,
>> -			    struct inode *inode,
>> -			    const char *name,
>> -			    const char *value,
>> -			    size_t value_len,
>> -			    int flags)
>> +int btrfs_set_prop(struct btrfs_trans_handle *trans, struct inode *inode,
>> +		   const char *name, const char *value, size_t value_len,
>> +		   int flags)
>>   {
>>   	const struct prop_handler *handler;
>>   	int ret;
>> @@ -133,15 +130,6 @@ static int __btrfs_set_prop(struct btrfs_trans_handle *trans,
>>   	return 0;
>>   }
>>   
>> -int btrfs_set_prop(struct inode *inode,
>> -		   const char *name,
>> -		   const char *value,
>> -		   size_t value_len,
>> -		   int flags)
>> -{
>> -	return __btrfs_set_prop(NULL, inode, name, value, value_len, flags);
> 
> I agree that one function would be better here, with defined semantics
> of 'trans'.
> 
> There are more cleanups around the properties, also in the xattr
> handling functions. This patchset is a step in the right direction and I
> think the cleanups could be more extensive.
> 
> The idea for the xattr function:
> 
> - the VFS callbacks (like btrfs_xattr_handler_set_prop) will start the
>    transaction themselves and pass the handle to the prop function

These vfs callbacks must handle the update inode part as well, which 
btrfs_setxattr() skips if trans != NULL.

----
         inode_inc_iversion(inode);
         inode->i_ctime = current_time(inode);
         set_bit(BTRFS_INODE_COPY_EVERYTHING, 
&BTRFS_I(inode)->runtime_flags);
         ret = btrfs_update_inode(trans, root, inode);
----

Will give a try.

> - a xattr function that does not take a valid trans could be named like
>    btrfs_setxattr_notrans and will start the transaction, ie. lifting
>    that to the callers

Yep. Also btrfs_set_props_notrans() and btrfs_set_acl_notrans().

> - there's a maze of the xattr callbacks so assertions are needed

ok.

Thanks, Anand

  reply	other threads:[~2019-02-21  9:03 UTC|newest]

Thread overview: 6+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-02-12  2:18 [PATCH v3 0/3] Misc props.c cleanups Anand Jain
2019-02-12  2:18 ` [PATCH v3 1/3] btrfs: kill __btrfs_set_prop() Anand Jain
2019-02-20 19:00   ` David Sterba
2019-02-21  9:03     ` Anand Jain [this message]
2019-02-12  2:18 ` [PATCH v3 2/3] btrfs: drop redundant forward declaration in props.c Anand Jain
2019-02-12  2:18 ` [PATCH v3 3/3] btrfs: trivial, fix c coding style Anand Jain

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=01e83b68-cd54-26ae-f4d1-3702ae13bbca@oracle.com \
    --to=anand.jain@oracle.com \
    --cc=dsterba@suse.cz \
    --cc=linux-btrfs@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).