linux-btrfs.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: David Sterba <dsterba@suse.cz>
To: Anand Jain <Anand.Jain@oracle.com>
Cc: linux-btrfs@vger.kernel.org, jeffm@suse.com, clm@fb.com
Subject: Re: [PATCH 1/4] btrfs: dev delete should remove sysfs entry
Date: Fri, 30 May 2014 16:10:14 +0200	[thread overview]
Message-ID: <20140530141014.GG29992@suse.cz> (raw)
In-Reply-To: <538820D4.3010808@oracle.com>

On Fri, May 30, 2014 at 02:10:28PM +0800, Anand Jain wrote:
> >>@@ -572,6 +572,26 @@ static void init_feature_attrs(void)
> >>  	}
> >>  }
> >>
> >>+int rm_device_membership(struct btrfs_fs_info *fs_info,
> >>+		struct btrfs_device *one_device)
> >
> >The name is too generic for a non-static function, so it would be good
> >to add at least the btrfs_ prefix. Same applies to the change of
> >'add_device_membership' in the next patch.
> 
>  Yes indeed. I wanted it to change as well. But the diff became
>  unfriendly to read.  I shall do that in a separate patch.

No problem with doing the rename changes in a separate patch, but here
you introduce a new function, that should get the right name from the
beginning. If this would look inconsitent with the add_ counterpart,
then do the rename of add_ in advance.

  reply	other threads:[~2014-05-30 14:10 UTC|newest]

Thread overview: 18+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-05-26  9:30 [PATCH 0/4] update sysfs per btrfs device operations Anand Jain
2014-05-26  9:30 ` [PATCH 1/4] btrfs: dev delete should remove sysfs entry Anand Jain
2014-05-29 13:04   ` David Sterba
2014-05-30  6:10     ` Anand Jain
2014-05-30 14:10       ` David Sterba [this message]
2014-05-26  9:30 ` [PATCH 2/4] btrfs: dev add should add its " Anand Jain
2014-05-29 14:49   ` David Sterba
2014-05-26  9:30 ` [PATCH 3/4] btrfs: dev replace should replace the " Anand Jain
2014-05-29 13:29   ` David Sterba
2014-05-30  7:40     ` Anand Jain
2014-06-03  3:47       ` Anand Jain
2014-06-03 13:39         ` David Sterba
2014-05-26  9:30 ` [PATCH 4/4] btrfs: create sprout should rename fsid on the sysfs as well Anand Jain
2014-05-29 12:54   ` David Sterba
2014-06-02  8:22     ` Anand Jain
2014-06-02 15:39       ` David Sterba
2014-06-03  0:27         ` Anand Jain
2014-05-28  8:30 ` [PATCH RFC v2] btrfs: revamp /sys/fs/btrfs/<fsid>/devices Anand Jain

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20140530141014.GG29992@suse.cz \
    --to=dsterba@suse.cz \
    --cc=Anand.Jain@oracle.com \
    --cc=clm@fb.com \
    --cc=jeffm@suse.com \
    --cc=linux-btrfs@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).