linux-btrfs.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: "Darrick J. Wong" <darrick.wong@oracle.com>
To: Al Viro <viro@ZenIV.linux.org.uk>
Cc: david@fromorbit.com, sandeen@redhat.com,
	linux-nfs@vger.kernel.org, linux-cifs@vger.kernel.org,
	Amir Goldstein <amir73il@gmail.com>,
	linux-unionfs@vger.kernel.org, linux-xfs@vger.kernel.org,
	linux-mm@kvack.org, linux-btrfs@vger.kernel.org,
	linux-fsdevel@vger.kernel.org, Christoph Hellwig <hch@lst.de>,
	ocfs2-devel@oss.oracle.com
Subject: Re: [PATCH 04/29] vfs: strengthen checking of file range inputs to generic_remap_checks
Date: Wed, 17 Oct 2018 21:37:24 -0700	[thread overview]
Message-ID: <20181018043724.GS28243@magnolia> (raw)
In-Reply-To: <20181018004156.GA12386@ZenIV.linux.org.uk>

On Thu, Oct 18, 2018 at 01:41:56AM +0100, Al Viro wrote:
> On Wed, Oct 17, 2018 at 03:44:43PM -0700, Darrick J. Wong wrote:
> > +static int generic_access_check_limits(struct file *file, loff_t pos,
> > +				       loff_t *count)
> > +{
> > +	struct inode *inode = file->f_mapping->host;
> > +
> > +	/* Don't exceed the LFS limits. */
> > +	if (unlikely(pos + *count > MAX_NON_LFS &&
> > +				!(file->f_flags & O_LARGEFILE))) {
> > +		if (pos >= MAX_NON_LFS)
> > +			return -EFBIG;
> > +		*count = min(*count, (loff_t)MAX_NON_LFS - pos);
> 
> 	Can that can be different from MAX_NON_LFS - pos?
> 
> > +	}
> > +
> > +	/*
> > +	 * Don't operate on ranges the page cache doesn't support.
> > +	 *
> > +	 * If we have written data it becomes a short write.  If we have
> > +	 * exceeded without writing data we send a signal and return EFBIG.
> > +	 * Linus frestrict idea will clean these up nicely..
> > +	 */
> > +	if (unlikely(pos >= inode->i_sb->s_maxbytes))
> > +		return -EFBIG;
> > +
> > +	*count = min(*count, inode->i_sb->s_maxbytes - pos);
> > +	return 0;
> > +}
> 
> Anyway, I would rather do this here:
> 
> 	struct inode *inode = file->f_mapping->host;
> 	loff_t max_size = inode->i_sb->s_maxbytes;
> 
> 	if (!(file->f_flags & O_LARGEFILE))
> 		max_size = MAX_NON_LFS;
> 
> 	if (unlikely(pos >= max_size))
> 		return -EFBIG;
> 	*count = min(*count, max_size - pos);
> 	return 0;

Sounds much better to me. :)

--D

  reply	other threads:[~2018-10-18  4:37 UTC|newest]

Thread overview: 40+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-10-17 22:44 [PATCH v6 00/29] fs: fixes for serious clone/dedupe problems Darrick J. Wong
2018-10-17 22:44 ` [PATCH 01/29] vfs: vfs_clone_file_prep_inodes should return EINVAL for a clone from beyond EOF Darrick J. Wong
2018-10-17 22:44 ` [PATCH 02/29] vfs: check file ranges before cloning files Darrick J. Wong
2018-10-17 22:44 ` [PATCH 03/29] vfs: exit early from zero length remap operations Darrick J. Wong
2018-10-17 22:44 ` [PATCH 04/29] vfs: strengthen checking of file range inputs to generic_remap_checks Darrick J. Wong
2018-10-18  0:41   ` Al Viro
2018-10-18  4:37     ` Darrick J. Wong [this message]
2018-10-18 18:56   ` [PATCH v2 " Darrick J. Wong
2018-10-17 22:44 ` [PATCH 05/29] vfs: avoid problematic remapping requests into partial EOF block Darrick J. Wong
2018-10-17 22:44 ` [PATCH 06/29] vfs: skip zero-length dedupe requests Darrick J. Wong
2018-10-17 22:45 ` [PATCH 07/29] vfs: rename vfs_clone_file_prep to be more descriptive Darrick J. Wong
2018-10-17 22:45 ` [PATCH 08/29] vfs: rename clone_verify_area to remap_verify_area Darrick J. Wong
2018-10-17 22:45 ` [PATCH 09/29] vfs: combine the clone and dedupe into a single remap_file_range Darrick J. Wong
2018-10-18  0:48   ` Al Viro
2018-10-18  4:47     ` Darrick J. Wong
2018-10-18  4:54       ` Al Viro
2018-10-18  5:03         ` Darrick J. Wong
2018-10-18 18:57   ` [PATCH v2 " Darrick J. Wong
2018-10-17 22:45 ` [PATCH 10/29] vfs: pass remap flags to generic_remap_file_range_prep Darrick J. Wong
2018-10-17 22:45 ` [PATCH 11/29] vfs: pass remap flags to generic_remap_checks Darrick J. Wong
2018-10-17 22:45 ` [PATCH 12/29] vfs: remap helper should update destination inode metadata Darrick J. Wong
2018-10-17 22:45 ` [PATCH 13/29] vfs: make remap_file_range functions take and return bytes completed Darrick J. Wong
2018-10-18 18:57   ` [PATCH v2 " Darrick J. Wong
2018-10-17 22:45 ` [PATCH 14/29] vfs: plumb remap flags through the vfs clone functions Darrick J. Wong
2018-10-17 22:46 ` [PATCH 15/29] vfs: plumb remap flags through the vfs dedupe functions Darrick J. Wong
2018-10-17 22:46 ` [PATCH 16/29] vfs: enable remap callers that can handle short operations Darrick J. Wong
2018-10-18 18:58   ` [PATCH v2 " Darrick J. Wong
2018-10-17 22:46 ` [PATCH 17/29] vfs: hide file range comparison function Darrick J. Wong
2018-10-17 22:46 ` [PATCH 18/29] vfs: clean up generic_remap_file_range_prep return value Darrick J. Wong
2018-10-17 22:46 ` [PATCH 19/29] ocfs2: truncate page cache for clone destination file before remapping Darrick J. Wong
2018-10-17 22:46 ` [PATCH 20/29] ocfs2: fix pagecache truncation prior to reflink Darrick J. Wong
2018-10-17 22:46 ` [PATCH 21/29] ocfs2: support partial clone range and dedupe range Darrick J. Wong
2018-10-17 22:46 ` [PATCH 22/29] ocfs2: remove ocfs2_reflink_remap_range Darrick J. Wong
2018-10-17 22:46 ` [PATCH 23/29] xfs: add a per-xfs trace_printk macro Darrick J. Wong
2018-10-17 22:47 ` [PATCH 24/29] xfs: fix pagecache truncation prior to reflink Darrick J. Wong
2018-10-17 22:47 ` [PATCH 25/29] xfs: clean up xfs_reflink_remap_blocks call site Darrick J. Wong
2018-10-17 22:47 ` [PATCH 26/29] xfs: support returning partial reflink results Darrick J. Wong
2018-10-17 22:47 ` [PATCH 27/29] xfs: remove redundant remap partial EOF block checks Darrick J. Wong
2018-10-17 22:47 ` [PATCH 28/29] xfs: remove xfs_reflink_remap_range Darrick J. Wong
2018-10-17 22:47 ` [PATCH 29/29] xfs: remove [cm]time update from reflink calls Darrick J. Wong

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20181018043724.GS28243@magnolia \
    --to=darrick.wong@oracle.com \
    --cc=amir73il@gmail.com \
    --cc=david@fromorbit.com \
    --cc=hch@lst.de \
    --cc=linux-btrfs@vger.kernel.org \
    --cc=linux-cifs@vger.kernel.org \
    --cc=linux-fsdevel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=linux-nfs@vger.kernel.org \
    --cc=linux-unionfs@vger.kernel.org \
    --cc=linux-xfs@vger.kernel.org \
    --cc=ocfs2-devel@oss.oracle.com \
    --cc=sandeen@redhat.com \
    --cc=viro@ZenIV.linux.org.uk \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).