linux-btrfs.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH 0/7] More misc fixes
@ 2019-01-03  8:49 Nikolay Borisov
  2019-01-03  8:49 ` [PATCH 1/7] btrfs: Remove inode argument from async_cow_submit Nikolay Borisov
                   ` (7 more replies)
  0 siblings, 8 replies; 22+ messages in thread
From: Nikolay Borisov @ 2019-01-03  8:49 UTC (permalink / raw)
  To: linux-btrfs; +Cc: Nikolay Borisov

Here is an assortment of fixes, mainly around the async (compressed) cow path. 
Just removes some redundant arguments/local variables, makes shrink_delalloc a
bit more readable by simplifying variable usage and giving more appropriate names. 
Also documents the ->inode null check in async_cow_submit and cleans up open-coded
usage of DIV_ROUND_UP. No functional changes to any of the patches. 

Nikolay Borisov (7):
  btrfs: Remove inode argument from async_cow_submit
  btrfs: Remove isize local variable in compress_file_range
  btrfs: Use ihold instead of igrab in cow_file_range_async
  btrfs: Remove WARN_ON in btrfs_alloc_delalloc_work
  btrfs: Document logic in async_cow_submit
  btrfs: Replace open-coded maths with DIV_ROUND_UP
  btrfs: Refactor shrink_delalloc

 fs/btrfs/extent-tree.c | 33 ++++++++++++++++++++++-----------
 fs/btrfs/extent_io.c   |  7 +++----
 fs/btrfs/inode.c       | 27 +++++++++++++++------------
 3 files changed, 40 insertions(+), 27 deletions(-)

-- 
2.17.1


^ permalink raw reply	[flat|nested] 22+ messages in thread

end of thread, other threads:[~2019-01-07 17:59 UTC | newest]

Thread overview: 22+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-01-03  8:49 [PATCH 0/7] More misc fixes Nikolay Borisov
2019-01-03  8:49 ` [PATCH 1/7] btrfs: Remove inode argument from async_cow_submit Nikolay Borisov
2019-01-05  6:02   ` Anand Jain
2019-01-07 10:12   ` Johannes Thumshirn
2019-01-03  8:50 ` [PATCH 2/7] btrfs: Remove isize local variable in compress_file_range Nikolay Borisov
2019-01-05  6:17   ` Anand Jain
2019-01-07 10:17   ` Johannes Thumshirn
2019-01-07 17:41   ` David Sterba
2019-01-03  8:50 ` [PATCH 3/7] btrfs: Use ihold instead of igrab in cow_file_range_async Nikolay Borisov
2019-01-04 15:29   ` David Sterba
2019-01-03  8:50 ` [PATCH 4/7] btrfs: Remove WARN_ON in btrfs_alloc_delalloc_work Nikolay Borisov
2019-01-04 15:30   ` David Sterba
2019-01-07 10:19   ` Johannes Thumshirn
2019-01-03  8:50 ` [PATCH 5/7] btrfs: Document logic in async_cow_submit Nikolay Borisov
2019-01-03  8:50 ` [PATCH 6/7] btrfs: Replace open-coded maths with DIV_ROUND_UP Nikolay Borisov
2019-01-03 14:44   ` David Sterba
2019-01-03 15:33     ` Nikolay Borisov
2019-01-07 15:29       ` David Sterba
2019-01-03  8:50 ` [PATCH 7/7] btrfs: Refactor shrink_delalloc Nikolay Borisov
2019-01-04 15:35   ` David Sterba
2019-01-07 17:58     ` David Sterba
2019-01-07 17:59 ` [PATCH 0/7] More misc fixes David Sterba

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).