linux-btrfs.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Tom Rini <trini@konsulko.com>
To: Qu Wenruo <quwenruo.btrfs@gmx.com>
Cc: "Marek Behún" <marek.behun@nic.cz>,
	u-boot@lists.denx.de,
	"Alberto Sánchez Molero" <alsamolero@gmail.com>,
	"Marek Vasut" <marex@denx.de>,
	"Pierre Bourdon" <delroth@gmail.com>,
	"Simon Glass" <sjg@chromium.org>,
	"Yevgeny Popovych" <yevgenyp@pointgrab.com>,
	linux-btrfs@vger.kernel.org, "Qu Wenruo" <wqu@suse.com>
Subject: Re: [PATCH U-BOOT v3 25/30] fs: btrfs: Implement btrfs_file_read()
Date: Mon, 7 Sep 2020 20:56:46 -0400	[thread overview]
Message-ID: <20200908005646.GG7259@bill-the-cat> (raw)
In-Reply-To: <a88a1a38-8fce-f438-25c9-05d3edd83cf6@gmx.com>

[-- Attachment #1: Type: text/plain, Size: 2259 bytes --]

On Tue, Sep 08, 2020 at 08:26:27AM +0800, Qu Wenruo wrote:
> 
> 
> On 2020/9/8 上午6:35, Tom Rini wrote:
> > On Wed, Jun 24, 2020 at 06:03:11PM +0200, Marek Behún wrote:
> > 
> >> From: Qu Wenruo <wqu@suse.com>
> >>
> >> This version of btrfs_file_read() has the following new features:
> >> - Tries all mirrors
> >> - More handling on unaligned size
> >> - Better compressed extent handling
> >>   The old implementation doesn't handle compressed extent with offset
> >>   properly: we need to read out the whole compressed extent, then
> >>   decompress the whole extent, and only then copy the requested part.
> >>
> >> Signed-off-by: Qu Wenruo <wqu@suse.com>
> >> Reviewed-by: Marek Behún <marek.behun@nic.cz>
> > 
> > Note that this introduces a warning with LLVM-10:
> > fs/btrfs/btrfs.c:246:6: warning: variable 'real_size' is used uninitialized whenever 'if' condition is false [-Wsometimes-uninitialized]
> >         if (!len) {
> >             ^~~~
> > fs/btrfs/btrfs.c:255:12: note: uninitialized use occurs here
> >         if (len > real_size - offset)
> >                   ^~~~~~~~~
> > fs/btrfs/btrfs.c:246:2: note: remove the 'if' if its condition is always true
> >         if (!len) {
> >         ^~~~~~~~~~
> > fs/btrfs/btrfs.c:228:18: note: initialize the variable 'real_size' to silence this warning
> >         loff_t real_size;
> >                         ^
> >                          = 0
> > 1 warning generated.
> > 
> > and I have silenced as suggested.  I'm not 100% happy with that, but
> > leave fixing it here and in upstream btrfs-progs to the btrfs-experts.
> 
> My bad. The warning is correct, and since the code is U-boot specific,
> it doesn't affect kernel (using page) nor btrfs-progs (not really do
> file read with offset).
> 
> The fix is a little complex.
> 
> In fact we need to always call btrfs_size() to grab the real_size, and
> then modify @len using real_size, either using real_size directly, or do
> some basic calculation.

Ah, thanks.  I'll fold in your changes.

> 
> BTW, I didn't see the btrfs rebuild work merged upstream. Is this
> planned or you just grab from some specific branch?

Yes, I'm testing them for -next right now.

-- 
Tom

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 659 bytes --]

  reply	other threads:[~2020-09-08  0:56 UTC|newest]

Thread overview: 42+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-06-24 16:02 [PATCH U-BOOT v3 00/30] PLEASE TEST fs: btrfs: Re-implement btrfs support using code from btrfs-progs Marek Behún
2020-06-24 16:02 ` [PATCH U-BOOT v3 01/30] fs: btrfs: Sync btrfs_btree.h from kernel Marek Behún
2020-06-24 16:02 ` [PATCH U-BOOT v3 02/30] fs: btrfs: Add more checksum algorithms Marek Behún
2020-06-24 16:02 ` [PATCH U-BOOT v3 03/30] fs: btrfs: Crossport btrfs_read_dev_super() from btrfs-progs Marek Behún
2020-09-07 22:26   ` Tom Rini
2020-09-07 23:58     ` Marek Behun
2020-06-24 16:02 ` [PATCH U-BOOT v3 04/30] fs: btrfs: Crossport rbtree-utils " Marek Behún
2020-06-24 16:02 ` [PATCH U-BOOT v3 05/30] fs: btrfs: Crossport extent-cache.[ch] " Marek Behún
2020-06-24 16:02 ` [PATCH U-BOOT v3 06/30] fs: btrfs: Crossport extent-io.[ch] " Marek Behún
2020-06-24 16:02 ` [PATCH U-BOOT v3 07/30] fs: btrfs: Crossport structure accessor into ctree.h Marek Behún
2020-06-24 16:02 ` [PATCH U-BOOT v3 08/30] fs: btrfs: Crossport volumes.[ch] from btrfs-progs Marek Behún
2020-06-24 16:02 ` [PATCH U-BOOT v3 09/30] fs: btrfs: Crossport read_tree_block() " Marek Behún
2020-06-24 16:02 ` [PATCH U-BOOT v3 10/30] fs: btrfs: Rename struct btrfs_path to struct __btrfs_path Marek Behún
2020-06-24 16:02 ` [PATCH U-BOOT v3 11/30] fs: btrfs: Rename btrfs_root to __btrfs_root Marek Behún
2020-06-24 16:02 ` [PATCH U-BOOT v3 12/30] fs: btrfs: Crossport struct btrfs_root to ctree.h Marek Behún
2020-06-24 16:02 ` [PATCH U-BOOT v3 13/30] fs: btrfs: Crossport btrfs_search_slot() from btrfs-progs Marek Behún
2020-06-24 16:03 ` [PATCH U-BOOT v3 14/30] fs: btrfs: Crossport btrfs_read_sys_array() and btrfs_read_chunk_tree() Marek Behún
2020-06-24 16:03 ` [PATCH U-BOOT v3 15/30] fs: btrfs: Crossport open_ctree_fs_info() from btrfs-progs Marek Behún
2020-06-24 16:03 ` [PATCH U-BOOT v3 16/30] fs: btrfs: Rename path resolve related functions to avoid name conflicts Marek Behún
2020-06-24 16:03 ` [PATCH U-BOOT v3 17/30] fs: btrfs: Use btrfs_readlink() to implement __btrfs_readlink() Marek Behún
2020-06-24 16:03 ` [PATCH U-BOOT v3 18/30] fs: btrfs: inode: Allow next_length() to return value > BTRFS_NAME_LEN Marek Behún
2020-06-24 16:03 ` [PATCH U-BOOT v3 19/30] fs: btrfs: Implement btrfs_lookup_path() Marek Behún
2020-06-24 16:03 ` [PATCH U-BOOT v3 20/30] fs: btrfs: Use btrfs_iter_dir() to replace btrfs_readdir() Marek Behún
2020-06-24 16:03 ` [PATCH U-BOOT v3 21/30] fs: btrfs: Use btrfs_lookup_path() to implement btrfs_exists() and btrfs_size() Marek Behún
2020-06-24 16:03 ` [PATCH U-BOOT v3 22/30] fs: btrfs: Rename btrfs_file_read() and its callees to avoid name conflicts Marek Behún
2020-06-24 16:03 ` [PATCH U-BOOT v3 23/30] fs: btrfs: Introduce btrfs_read_extent_inline() and btrfs_read_extent_reg() Marek Behún
2020-06-24 16:03 ` [PATCH U-BOOT v3 24/30] fs: btrfs: Introduce lookup_data_extent() for later use Marek Behún
2020-06-24 16:03 ` [PATCH U-BOOT v3 25/30] fs: btrfs: Implement btrfs_file_read() Marek Behún
2020-09-07 22:35   ` Tom Rini
2020-09-08  0:26     ` Qu Wenruo
2020-09-08  0:56       ` Tom Rini [this message]
2020-09-08  0:59         ` Qu Wenruo
2020-06-24 16:03 ` [PATCH U-BOOT v3 26/30] fs: btrfs: Introduce function to resolve path in one subvolume Marek Behún
2020-06-24 16:03 ` [PATCH U-BOOT v3 27/30] fs: btrfs: Introduce function to resolve the path of " Marek Behún
2020-06-24 16:03 ` [PATCH U-BOOT v3 28/30] fs: btrfs: Imeplement btrfs_list_subvols() using new infrastructure Marek Behún
2020-06-24 16:03 ` [PATCH U-BOOT v3 29/30] fs: btrfs: Cleanup the old implementation Marek Behún
2020-06-24 16:03 ` [PATCH U-BOOT v3 30/30] MAINTAINERS: Add btrfs mailing list and myself as reviewer Marek Behún
2020-06-24 16:11 ` [PATCH U-BOOT v3 00/30] PLEASE TEST fs: btrfs: Re-implement btrfs support using code from btrfs-progs Marek Behún
2020-06-26  1:43 ` Simon Glass
2020-06-26 13:36   ` Tom Rini
2020-06-29 17:26     ` Simon Glass
2020-09-08 18:18 ` Tom Rini

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200908005646.GG7259@bill-the-cat \
    --to=trini@konsulko.com \
    --cc=alsamolero@gmail.com \
    --cc=delroth@gmail.com \
    --cc=linux-btrfs@vger.kernel.org \
    --cc=marek.behun@nic.cz \
    --cc=marex@denx.de \
    --cc=quwenruo.btrfs@gmx.com \
    --cc=sjg@chromium.org \
    --cc=u-boot@lists.denx.de \
    --cc=wqu@suse.com \
    --cc=yevgenyp@pointgrab.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).