linux-btrfs.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Nikolay Borisov <nborisov@suse.com>
To: linux-btrfs@vger.kernel.org
Cc: Nikolay Borisov <nborisov@suse.com>
Subject: [PATCH 13/13] lib/zstd: Convert constants to defines
Date: Tue, 19 Jan 2021 14:26:49 +0200	[thread overview]
Message-ID: <20210119122649.187778-14-nborisov@suse.com> (raw)
In-Reply-To: <20210119122649.187778-1-nborisov@suse.com>

Those constants are really used internally by zstd and including
linux/zstd.h into users results in the following warnings:

In file included from fs/btrfs/zstd.c:19:
./include/linux/zstd.h:798:21: warning: ‘ZSTD_skippableHeaderSize’ defined but not used [-Wunused-const-variable=]
  798 | static const size_t ZSTD_skippableHeaderSize = 8;
      |                     ^~~~~~~~~~~~~~~~~~~~~~~~
./include/linux/zstd.h:796:21: warning: ‘ZSTD_frameHeaderSize_max’ defined but not used [-Wunused-const-variable=]
  796 | static const size_t ZSTD_frameHeaderSize_max = ZSTD_FRAMEHEADERSIZE_MAX;
      |                     ^~~~~~~~~~~~~~~~~~~~~~~~
./include/linux/zstd.h:795:21: warning: ‘ZSTD_frameHeaderSize_min’ defined but not used [-Wunused-const-variable=]
  795 | static const size_t ZSTD_frameHeaderSize_min = ZSTD_FRAMEHEADERSIZE_MIN;
      |                     ^~~~~~~~~~~~~~~~~~~~~~~~
./include/linux/zstd.h:794:21: warning: ‘ZSTD_frameHeaderSize_prefix’ defined but not used [-Wunused-const-variable=]
  794 | static const size_t ZSTD_frameHeaderSize_prefix = 5;

So fix those warnings by turning the constants into defines.

Signed-off-by: Nikolay Borisov <nborisov@suse.com>
---
 include/linux/zstd.h | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/include/linux/zstd.h b/include/linux/zstd.h
index 249575e2485f..e87f78c9b19c 100644
--- a/include/linux/zstd.h
+++ b/include/linux/zstd.h
@@ -791,11 +791,11 @@ size_t ZSTD_DStreamOutSize(void);
 /* for static allocation */
 #define ZSTD_FRAMEHEADERSIZE_MAX 18
 #define ZSTD_FRAMEHEADERSIZE_MIN  6
-static const size_t ZSTD_frameHeaderSize_prefix = 5;
-static const size_t ZSTD_frameHeaderSize_min = ZSTD_FRAMEHEADERSIZE_MIN;
-static const size_t ZSTD_frameHeaderSize_max = ZSTD_FRAMEHEADERSIZE_MAX;
+#define ZSTD_frameHeaderSize_prefix 5
+#define ZSTD_frameHeaderSize_min ZSTD_FRAMEHEADERSIZE_MIN
+#define ZSTD_frameHeaderSize_max ZSTD_FRAMEHEADERSIZE_MAX
 /* magic number + skippable frame length */
-static const size_t ZSTD_skippableHeaderSize = 8;
+#define ZSTD_skippableHeaderSize 8
 
 
 /*-*************************************
-- 
2.25.1


  parent reply	other threads:[~2021-01-19 14:45 UTC|newest]

Thread overview: 21+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-01-19 12:26 [PATCH 00/13] Make btrfs W=1 clean Nikolay Borisov
2021-01-19 12:26 ` [PATCH 01/13] btrfs: Document modified paramater of add_extent_mapping Nikolay Borisov
2021-01-19 21:25   ` Josef Bacik
2021-01-19 21:27   ` Josef Bacik
2021-01-19 12:26 ` [PATCH 02/13] btrfs: Fix parameter description of btrfs_add_extent_mapping Nikolay Borisov
2021-01-19 12:26 ` [PATCH 03/13] btrfs: Fix function description format Nikolay Borisov
2021-01-19 22:43   ` David Sterba
2021-01-19 12:26 ` [PATCH 04/13] btrfs: Fix paramter description in delayed-ref.c functions Nikolay Borisov
2021-01-19 21:26   ` Josef Bacik
2021-01-19 12:26 ` [PATCH 05/13] btrfs: Improve parameter description for __btrfs_write_out_cache Nikolay Borisov
2021-01-19 12:26 ` [PATCH 06/13] btrfs: Document now parameter of peek_discard_list Nikolay Borisov
2021-01-19 22:46   ` David Sterba
2021-01-19 12:26 ` [PATCH 07/13] btrfs: Document fs_info in btrfs_rmap_block Nikolay Borisov
2021-01-19 22:47   ` David Sterba
2021-01-19 12:26 ` [PATCH 08/13] btrfs: Fix description format of fs_info parameter of btrfs_wait_on_delayed_iputs Nikolay Borisov
2021-01-19 12:26 ` [PATCH 09/13] btrfs: Document btrfs_check_shared parameters Nikolay Borisov
2021-01-19 12:26 ` [PATCH 10/13] btrfs: Fix parameter description of btrfs_inode_rsv_release/btrfs_delalloc_release_space Nikolay Borisov
2021-01-19 12:26 ` [PATCH 11/13] btrfs: Fix parameter description in space-info.c Nikolay Borisov
2021-01-19 12:26 ` [PATCH 12/13] btrfs: Fix parameter description for functions in extent_io.c Nikolay Borisov
2021-01-19 12:26 ` Nikolay Borisov [this message]
2021-01-19 22:39 ` [PATCH 00/13] Make btrfs W=1 clean David Sterba

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20210119122649.187778-14-nborisov@suse.com \
    --to=nborisov@suse.com \
    --cc=linux-btrfs@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).