linux-cifs.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Namjae Jeon <linkinjeon@kernel.org>
To: Amir Goldstein <amir73il@gmail.com>
Cc: viro@zeniv.linux.org.uk, linux-fsdevel@vger.kernel.org,
	linux-cifs@vger.kernel.org, smfrench@gmail.com,
	senozhatsky@chromium.org, tom@talpey.com, brauner@kernel.org
Subject: Re: [PATCH v8 0/3] ksmbd patches included vfs changes
Date: Tue, 13 Jun 2023 21:24:26 +0900	[thread overview]
Message-ID: <CAKYAXd-uL2Es_28VqMD33ogzhWX65ZMg3wTc9UxhE91G0ULwdg@mail.gmail.com> (raw)
In-Reply-To: <CAOQ4uxiSb659QB7J6S=FZWb-jDTBosYs_zM2tvJHwk4SNAh5Vw@mail.gmail.com>

2023-06-13 19:57 GMT+09:00, Amir Goldstein <amir73il@gmail.com>:
> Hi Namjae,
Hi Amir,
>
> Maybe I am missing something, but I do not see any mnt_want_write()
> in ksmbd at all. Is it well hidden somewhere?
At a quick glance, We need to add it for ksmbd_vfs_unlink and ksmbd_vfs_rename.
I'll look further into where else should I add it.

Thanks for letting me know!
>
> Thanks,
> Amir.
>
> On Thu, Mar 16, 2023 at 12:37 AM Namjae Jeon <linkinjeon@kernel.org> wrote:
>>
>> v8:
>>   - Don't call vfs_path_lookup() to avoid repeat lookup, Instead, lookup
>>     last component after locking the parent that got from
>> vfs_path_parent_lookup
>>     helper.
>> v7:
>>   - constify struct path.
>>   - recreate patch-set base on recent Al's patches.
>> v6:
>>   - rename __lookup_hash() to lookup_one_qstr_excl and export.
>>   - change dget() to dget_parent() in unlink.
>>   - lock parent of open file in smb2_open() to make file_present
>>     worthable.
>> v5:
>>   - add lock_rename_child() helper.
>>   - remove d_is_symlink() check for new_path.dentry.
>>   - use lock_rename_child() helper instead of lock_rename().
>>   - use dget() instead of dget_parent().
>>   - check that old_child is still hashed.
>>   - directly check child->parent instead of using
>> take_dentry_name_snapshot().
>> v4:
>>    - switch the order of 3/4 and 4/4 patch.
>>    - fix vfs_path_parent_lookup() parameter description mismatch.
>> v3:
>>   - use dget_parent + take_dentry_name_snapshot() to check stability of
>> source
>>     rename in smb2_vfs_rename().
>> v2:
>>   - add filename_lock to avoid racy issue from fp->filename. (Sergey
>> Senozhatsky)
>>   - fix warning: variable 'old_dentry' is used uninitialized (kernel
>>     test robot)
>>
>> Al Viro (1):
>>   fs: introduce lock_rename_child() helper
>>
>> Namjae Jeon (2):
>>   ksmbd: remove internal.h include
>>   ksmbd: fix racy issue from using ->d_parent and ->d_name
>>
>>  fs/internal.h         |   2 -
>>  fs/ksmbd/smb2pdu.c    | 147 ++++----------
>>  fs/ksmbd/vfs.c        | 435 ++++++++++++++++++------------------------
>>  fs/ksmbd/vfs.h        |  19 +-
>>  fs/ksmbd/vfs_cache.c  |   5 +-
>>  fs/namei.c            | 125 +++++++++---
>>  include/linux/namei.h |   9 +
>>  7 files changed, 342 insertions(+), 400 deletions(-)
>>
>> --
>> 2.25.1
>>
>

      reply	other threads:[~2023-06-13 12:24 UTC|newest]

Thread overview: 10+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2023-03-15 22:34 [PATCH v8 0/3] ksmbd patches included vfs changes Namjae Jeon
2023-03-15 22:34 ` [PATCH v8 1/3] ksmbd: remove internal.h include Namjae Jeon
2023-03-17  8:55   ` Christian Brauner
2023-03-15 22:34 ` [PATCH v8 2/3] fs: introduce lock_rename_child() helper Namjae Jeon
2023-03-15 22:34 ` [PATCH v8 3/3] ksmbd: fix racy issue from using ->d_parent and ->d_name Namjae Jeon
2023-04-21  2:35 ` [PATCH v8 0/3] ksmbd patches included vfs changes Al Viro
2023-04-21  2:38   ` Al Viro
2023-04-21  7:26   ` Namjae Jeon
2023-06-13 10:57 ` Amir Goldstein
2023-06-13 12:24   ` Namjae Jeon [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=CAKYAXd-uL2Es_28VqMD33ogzhWX65ZMg3wTc9UxhE91G0ULwdg@mail.gmail.com \
    --to=linkinjeon@kernel.org \
    --cc=amir73il@gmail.com \
    --cc=brauner@kernel.org \
    --cc=linux-cifs@vger.kernel.org \
    --cc=linux-fsdevel@vger.kernel.org \
    --cc=senozhatsky@chromium.org \
    --cc=smfrench@gmail.com \
    --cc=tom@talpey.com \
    --cc=viro@zeniv.linux.org.uk \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).