From: Christoph Hellwig <hch@infradead.org>
To: Namjae Jeon <namjae.jeon@samsung.com>
Cc: linux-fsdevel@vger.kernel.org, linux-kernel@vger.kernel.org,
linux-cifs@vger.kernel.org, smfrench@gmail.com,
stfrench@microsoft.com, willy@infradead.org,
aurelien.aptel@gmail.com,
linux-cifsd-devel@lists.sourceforge.net,
senozhatsky@chromium.org, sandeen@sandeen.net, aaptel@suse.com,
hch@infradead.org, viro@zeniv.linux.org.uk,
ronniesahlberg@gmail.com, hch@lst.de, dan.carpenter@oracle.com
Subject: Re: [PATCH v4 02/10] cifsd: add server handler
Date: Tue, 15 Jun 2021 09:10:06 +0100 [thread overview]
Message-ID: <YMhgXsAez9jmeUkW@infradead.org> (raw)
In-Reply-To: <20210602034847.5371-3-namjae.jeon@samsung.com>
On Wed, Jun 02, 2021 at 12:48:39PM +0900, Namjae Jeon wrote:
> +/* @FIXME clean up this code */
Hmm, should that be in a submitted codebase?
> +#define DATA_STREAM 1
> +#define DIR_STREAM 2
Should this use a named enum to document the usage a bit better?
> +#ifndef ksmbd_pr_fmt
> +#ifdef SUBMOD_NAME
> +#define ksmbd_pr_fmt(fmt) "ksmbd: " SUBMOD_NAME ": " fmt
> +#else
> +#define ksmbd_pr_fmt(fmt) "ksmbd: " fmt
> +#endif
> +#endif
Why not use the pr_fmt built into pr_*? With that all the message
wrappers except for the _dbg one can go away.
Also can you please decided if this is kcifsd or ksmbd? Using both
names is rather confusing.
> +#ifndef ____ksmbd_align
> +#define ____ksmbd_align __aligned(4)
> +#endif
No need for the ifndef and all the _ prefixes. More importantly from
a quick look it seems like none of the structures really needs the
attribute anyway.
> +#define KSMBD_SHARE_CONFIG_PATH(s) \
> + ({ \
> + char *p = (s)->____payload; \
> + if ((s)->veto_list_sz) \
> + p += (s)->veto_list_sz + 1; \
> + p; \
> + })
Why no inline function?
> +/* @FIXME */
> +#include "ksmbd_server.h"
???
next prev parent reply other threads:[~2021-06-15 8:10 UTC|newest]
Thread overview: 14+ messages / expand[flat|nested] mbox.gz Atom feed top
[not found] <CGME20210602035813epcas1p49ba4ff37fe4b784aa76dce67e4036227@epcas1p4.samsung.com>
2021-06-02 3:48 ` [PATCH v4 00/10] cifsd: introduce new SMB3 kernel server Namjae Jeon
[not found] ` <CGME20210602035814epcas1p3f244e5e018b0d7164081399262bd4bb7@epcas1p3.samsung.com>
2021-06-02 3:48 ` [PATCH v4 01/10] cifsd: add document Namjae Jeon
[not found] ` <CGME20210602035815epcas1p18f19c96ea3d299f97a90d818b83a3c85@epcas1p1.samsung.com>
2021-06-02 3:48 ` [PATCH v4 02/10] cifsd: add server handler Namjae Jeon
2021-06-15 8:10 ` Christoph Hellwig [this message]
2021-06-16 6:49 ` Namjae Jeon
[not found] ` <CGME20210602035817epcas1p1a58f64bc2881ed37ed1fa70140d5bda1@epcas1p1.samsung.com>
2021-06-02 3:48 ` [PATCH v4 04/10] cifsd: add authentication Namjae Jeon
[not found] ` <CGME20210602035819epcas1p201c9ed34d8be214299db2684bdba706b@epcas1p2.samsung.com>
2021-06-02 3:48 ` [PATCH v4 07/10] cifsd: add oplock/lease cache mechanism Namjae Jeon
[not found] ` <CGME20210602035820epcas1p3c444b34a6b6a4252c9091e0bf6c0c167@epcas1p3.samsung.com>
2021-06-02 3:48 ` [PATCH v4 08/10] cifsd: add file operations Namjae Jeon
2021-06-15 8:47 ` Christoph Hellwig
2021-06-16 6:48 ` Namjae Jeon
[not found] ` <CGME20210602035821epcas1p2bb9cbdcdbd61fe9c66697e944c53f297@epcas1p2.samsung.com>
2021-06-02 3:48 ` [PATCH v4 09/10] cifsd: add Kconfig and Makefile Namjae Jeon
[not found] ` <CGME20210602035822epcas1p4013fc24d42e1ea13ef5d4f4b50751168@epcas1p4.samsung.com>
2021-06-02 3:48 ` [PATCH v4 10/10] MAINTAINERS: add cifsd kernel server Namjae Jeon
[not found] ` <CGME20210602035816epcas1p240598e76247034278ad45dc0827b2be7@epcas1p2.samsung.com>
[not found] ` <20210602034847.5371-4-namjae.jeon@samsung.com>
2021-06-15 8:11 ` [PATCH v4 03/10] cifsd: add trasport layers Christoph Hellwig
2021-06-16 6:49 ` Namjae Jeon
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=YMhgXsAez9jmeUkW@infradead.org \
--to=hch@infradead.org \
--cc=aaptel@suse.com \
--cc=aurelien.aptel@gmail.com \
--cc=dan.carpenter@oracle.com \
--cc=hch@lst.de \
--cc=linux-cifs@vger.kernel.org \
--cc=linux-cifsd-devel@lists.sourceforge.net \
--cc=linux-fsdevel@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=namjae.jeon@samsung.com \
--cc=ronniesahlberg@gmail.com \
--cc=sandeen@sandeen.net \
--cc=senozhatsky@chromium.org \
--cc=smfrench@gmail.com \
--cc=stfrench@microsoft.com \
--cc=viro@zeniv.linux.org.uk \
--cc=willy@infradead.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).