Linux-Clk Archive on lore.kernel.org
 help / color / Atom feed
From: Thierry Reding <thierry.reding@gmail.com>
To: LABBE Corentin <clabbe@baylibre.com>
Cc: Jon Hunter <jonathanh@nvidia.com>,
	Nicolas Chauvet <kwizart@gmail.com>,
	Prashant Gaikwad <pgaikwad@nvidia.com>,
	pdeschrijver@nvidia.com,
	Michael Turquette <mturquette@baylibre.com>,
	sboyd@kernel.org, axboe@kernel.dk, linux-tegra@vger.kernel.org,
	linux-kernel@vger.kernel.org, linux-clk@vger.kernel.org,
	linux-ide@vger.kernel.org
Subject: Re: tegra124-jetson-tk1: sata doesnt work since 5.2
Date: Wed, 25 Mar 2020 21:15:56 +0100
Message-ID: <20200325201125.GA832965@ulmo> (raw)
In-Reply-To: <20200325142306.GB27961@Red>


[-- Attachment #1: Type: text/plain, Size: 3857 bytes --]

On Wed, Mar 25, 2020 at 03:23:06PM +0100, LABBE Corentin wrote:
> On Wed, Mar 25, 2020 at 02:00:25PM +0000, Jon Hunter wrote:
> > 
> > On 25/03/2020 13:40, LABBE Corentin wrote:
> > > On Thu, Mar 19, 2020 at 08:55:38AM +0100, Nicolas Chauvet wrote:
> > >> Le jeu. 19 mars 2020 à 08:44, LABBE Corentin <clabbe@baylibre.com> a écrit :
> > >>>
> > >>> Hello
> > >>>
> > >>> sata doesnt work on tegra124-jetson-tk1 on next and master and at least since 5.2 (but 5.1 works).
> > >>> [    0.492810] +5V_SATA: supplied by +5V_SYS
> > >>> [    0.493230] +12V_SATA: supplied by +VDD_MUX
> > >>> [    2.088675] tegra-ahci 70027000.sata: 70027000.sata supply ahci not found, using dummy regulator
> > >>> [    2.097643] tegra-ahci 70027000.sata: 70027000.sata supply phy not found, using dummy regulator
> > >>> [    3.314776] tegra-ahci 70027000.sata: 70027000.sata supply ahci not found, using dummy regulator
> > >>> [    3.323658] tegra-ahci 70027000.sata: 70027000.sata supply phy not found, using dummy regulator
> > >>> [    5.236964] tegra-ahci 70027000.sata: 70027000.sata supply ahci not found, using dummy regulator
> > >>> [    5.245867] tegra-ahci 70027000.sata: 70027000.sata supply phy not found, using dummy regulator
> > >>> [    5.254706] tegra-ahci 70027000.sata: 70027000.sata supply target not found, using dummy regulator
> > >>> [    5.310270] phy phy-sata.6: phy poweron failed --> -110
> > >>> [    5.315604] tegra-ahci 70027000.sata: failed to power on AHCI controller: -110
> > >>> [    5.323022] tegra-ahci: probe of 70027000.sata failed with error -110
> > >>> [   35.694269] +5V_SATA: disabling
> > >>> [   35.697438] +12V_SATA: disabling
> > >>
> > >> It looks strange, because (on same device) , I have sata working as
> > >> appropriate, but ethernet fails with me.
> > >> https://bugzilla.kernel.org/show_bug.cgi?id=206217
> > >>
> > >> It might worth to have another report.
> > >>
> > > 
> > > Hello
> > > 
> > > Mine has ethernet works well. But I hit many problem with it and older kernel.
> > > Perhaps the 5.1.21, were I am stuck, does not have it.
> > > 
> > > Anyway, the tegra of kerneci has the same SATA problem.
> > > https://storage.kernelci.org/next/master/next-20200325/arm/multi_v7_defconfig+CONFIG_SMP=n/gcc-8/lab-baylibre/boot-tegra124-jetson-tk1.txt
> > > 
> > > Maintainers, any idea on this sata issue ?
> > 
> > I have checked our bootlogs for v5.6-rc7 and don't see the issue with
> > either the tegra_defconfig or the multi_v7_defconfig. I am wondering if
> > this could be due a difference in the bootloader version. Currently we
> > are testing with a v2019.07 u-boot bootloader. Looks like the kernelci
> > board is using an older u-boot. Obviously it should still work, but
> > would be good to know if the reason why were are not seeing this is
> > because of the bootloader.
> > 
> > Another thing to check would be the pll_e clock frequency on a working
> > build and non-working build to see if there is a difference in the pll
> > frequency that is causing this.
> > 
> > Cheers
> > Jon
> > 
> 
> Hello
> 
> My uboot is 2016.01-rc4-00002-g3861d78, so a bit old.
> I have a mainline uboot build for this tegra, but still didnt find a clear way to update it.
> Did you have a good documentation on how to update it ?
> If possible some clear uboot commands to update it via tftp.

Not sure about TFTP, but you can find the standard flashing scripts for
various devices here:

	https://github.com/NVIDIA/tegra-uboot-flasher-scripts

Those work by uploading the image via RCM and then running the commands
to flash it.

I think those scripts will also create the images that they will flash,
so you should be able to download that image via TFTP and then flash it
using the command that the tool would normally use.

Thierry

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 833 bytes --]

  reply index

Thread overview: 7+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-03-19  7:44 LABBE Corentin
2020-03-19  7:55 ` Nicolas Chauvet
2020-03-25 13:40   ` LABBE Corentin
2020-03-25 14:00     ` Jon Hunter
2020-03-25 14:23       ` LABBE Corentin
2020-03-25 20:15         ` Thierry Reding [this message]
2020-03-26 13:33           ` LABBE Corentin

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200325201125.GA832965@ulmo \
    --to=thierry.reding@gmail.com \
    --cc=axboe@kernel.dk \
    --cc=clabbe@baylibre.com \
    --cc=jonathanh@nvidia.com \
    --cc=kwizart@gmail.com \
    --cc=linux-clk@vger.kernel.org \
    --cc=linux-ide@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-tegra@vger.kernel.org \
    --cc=mturquette@baylibre.com \
    --cc=pdeschrijver@nvidia.com \
    --cc=pgaikwad@nvidia.com \
    --cc=sboyd@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

Linux-Clk Archive on lore.kernel.org

Archives are clonable:
	git clone --mirror https://lore.kernel.org/linux-clk/0 linux-clk/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 linux-clk linux-clk/ https://lore.kernel.org/linux-clk \
		linux-clk@vger.kernel.org
	public-inbox-index linux-clk

Example config snippet for mirrors

Newsgroup available over NNTP:
	nntp://nntp.lore.kernel.org/org.kernel.vger.linux-clk


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git