linux-clk.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: 李扬韬 <frank@allwinnertech.com>
To: "Maxime Ripard" <maxime@cerno.tech>
Cc: wens <wens@csie.org>, robh+dt <robh+dt@kernel.org>,
	mturquette <mturquette@baylibre.com>, sboyd <sboyd@kernel.org>,
	"linus.walleij" <linus.walleij@linaro.org>,
	"p.zabel" <p.zabel@pengutronix.de>,
	黄烁生 <huangshuosheng@allwinnertech.com>,
	"tiny.windzz" <tiny.windzz@gmail.com>,
	linux-arm-kernel <linux-arm-kernel@lists.infradead.org>,
	devicetree <devicetree@vger.kernel.org>,
	linux-kernel <linux-kernel@vger.kernel.org>,
	linux-clk <linux-clk@vger.kernel.org>,
	linux-gpio <linux-gpio@vger.kernel.org>
Subject: 回复:[PATCH 2/4] pinctrl: sunxi: add support for the Allwinner A100 pin controller
Date: Wed, 03 Jun 2020 17:44:36 +0800	[thread overview]
Message-ID: <8c7a8eeb-f4ea-4df7-b381-5aeab6dd170a.frank@allwinnertech.com> (raw)
In-Reply-To: <20200522152803.twvfvuhd6ztunvll@gilmour.lan>

>> + SUNXI_PIN(SUNXI_PINCTRL_PIN(F, 0),
>> +  SUNXI_FUNCTION(0x0, "gpio_in"),
>> +  SUNXI_FUNCTION(0x1, "gpio_out"),
>> +  SUNXI_FUNCTION(0x2, "mmc0"),  /* D1 */
>> +  SUNXI_FUNCTION(0x3, "jtag"),  /* MS1 */
>> +  SUNXI_FUNCTION(0x4, "jtag"),  /* MS_GPU */
>
>We should use another name here, since the code will just pick the first one and
>ignore the second. What about jtag-gpu?

The underscores are used in front, so changing it to jtag_gpu may be more consistent.

>> + SUNXI_PIN(SUNXI_PINCTRL_PIN(B, 7),
>> +  SUNXI_FUNCTION(0x0, "gpio_in"),
>> +  SUNXI_FUNCTION(0x1, "gpio_out"),
>> +  SUNXI_FUNCTION(0x2, "spdif"),  /* DIN */
>> +  SUNXI_FUNCTION(0x3, "i2s0"),  /* DOUT0 */
>> +  SUNXI_FUNCTION(0x4, "i2s0"),  /* DIN1 */
>
>I guess the second one would be i2s1?

No, each i2s may have many inputs and outputs. 

 SUNXI_PIN(SUNXI_PINCTRL_PIN(H, 19),
     SUNXI_FUNCTION(0x0, "gpio_in"),
              SUNXI_FUNCTION(0x1, "gpio_out"),
              SUNXI_FUNCTION(0x2, "cir0"),          /* IN */
              SUNXI_FUNCTION(0x3, "i2s3_dout3"),       /* DOUT3 */
              SUNXI_FUNCTION(0x4, "i2s3_din3"),       /* DIN3 */
              SUNXI_FUNCTION(0x5, "ledc"),
              SUNXI_FUNCTION_IRQ_BANK(0x6, 6, 19)),

Considering that the same pin has multiple same functions, 
so add a suffix, like i2s3_dout3 and i2s3_din3?   

Or specify muxsel in the device tree may be another solution.

>> + SUNXI_PIN(SUNXI_PINCTRL_PIN(H, 2),
>> +  SUNXI_FUNCTION(0x0, "gpio_in"),
>> +  SUNXI_FUNCTION(0x1, "gpio_out"),
>> +  SUNXI_FUNCTION(0x2, "i2c1"),  /* SCK */
>> +  SUNXI_FUNCTION(0x3, "cpu"),  /* CUR_W */
>
>What is "cpu" supposed to be?

As far as I know, this is a function that has never been used.
The hardware guy said that it can be used to control the CPU to reduce the current.

Thx,
Yangtao

  reply	other threads:[~2020-06-03  9:44 UTC|newest]

Thread overview: 15+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-05-22  3:07 [PATCH 0/4] Allwinner A100 Initial support Frank Lee
2020-05-22  3:07 ` [PATCH 1/4] clk: sunxi-ng: add support for the Allwinner A100 CCU Frank Lee
2020-05-22 15:14   ` Maxime Ripard
2020-06-03  9:42     ` 回复:[PATCH " 李扬韬
2020-06-03  9:48       ` [PATCH " Chen-Yu Tsai
2020-05-22  3:07 ` [PATCH 2/4] pinctrl: sunxi: add support for the Allwinner A100 pin controller Frank Lee
2020-05-22 15:28   ` Maxime Ripard
2020-06-03  9:44     ` 李扬韬 [this message]
2020-06-05 15:13       ` 回复:[PATCH " Maxime Ripard
2020-06-16  9:26         ` Frank Lee
2020-06-20 21:27           ` Linus Walleij
2020-05-22  3:07 ` [PATCH 3/4] arm64: allwinner: A100: add the basical Allwinner A100 DTSI file Frank Lee
2020-05-22  3:07 ` [PATCH 4/4] arm64: allwinner: A100: add support for Allwinner Perf1 board Frank Lee
2020-05-22 15:31   ` Maxime Ripard
2020-05-22 15:02 ` [PATCH 0/4] Allwinner A100 Initial support Maxime Ripard

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=8c7a8eeb-f4ea-4df7-b381-5aeab6dd170a.frank@allwinnertech.com \
    --to=frank@allwinnertech.com \
    --cc=devicetree@vger.kernel.org \
    --cc=huangshuosheng@allwinnertech.com \
    --cc=linus.walleij@linaro.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-clk@vger.kernel.org \
    --cc=linux-gpio@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=maxime@cerno.tech \
    --cc=mturquette@baylibre.com \
    --cc=p.zabel@pengutronix.de \
    --cc=robh+dt@kernel.org \
    --cc=sboyd@kernel.org \
    --cc=tiny.windzz@gmail.com \
    --cc=wens@csie.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).