linux-crypto.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-04-27 06:43:20 to 2020-05-06 17:25:06 UTC [more...]

[GIT PULL] Crypto Update for 5.4
 2020-05-06 17:25 UTC  (11+ messages)
` [GIT PULL] Crypto Fixes "
  ` [GIT PULL] Crypto Fixes for 5.5
        ` [GIT PULL] Crypto Fixes for 5.6
          ` [GIT PULL] Crypto Fixes for 5.7

[PATCH net-next] Revert "crypto: chelsio - Inline single pdu only"
 2020-05-06 14:47 UTC 

[PATCH] crypto: blake2b - Fix clang optimization for ARMv7-M
 2020-05-06  5:12 UTC  (2+ messages)

[PATCH] crypto: curve25519-hacl64 - Disable fortify-source for clang-10
 2020-05-06  2:53 UTC  (14+ messages)
  ` [PATCH] Kbuild: disable FORTIFY_SOURCE on clang-10

libkcapi tests are failing on kernels 5.5+
 2020-05-05 22:04 UTC  (6+ messages)

[PATCH] net: wireguard: avoid unused variable warning
 2020-05-05 20:51 UTC  (3+ messages)

[PATCH 0/7] padata: parallelize deferred page init
 2020-05-05 15:27 UTC  (26+ messages)
` [PATCH 1/7] padata: remove exit routine
` [PATCH 2/7] padata: initialize earlier
` [PATCH 3/7] padata: allocate work structures for parallel jobs from a pool
` [PATCH 4/7] padata: add basic support for multithreaded jobs
` [PATCH 5/7] mm: move zone iterator outside of deferred_init_maxorder()
` [PATCH 6/7] mm: parallelize deferred_init_memmap()
` [PATCH 7/7] padata: document multithreaded jobs

[PATCH 00/20] crypto: introduce crypto_shash_tfm_digest()
 2020-05-05 14:19 UTC  (26+ messages)
` [PATCH 01/20] crypto: hash - "
` [PATCH 02/20] crypto: arm64/aes-glue - use crypto_shash_tfm_digest()
` [PATCH 03/20] crypto: essiv "
` [PATCH 04/20] crypto: artpec6 "
` [PATCH 05/20] crypto: ccp "
` [PATCH 06/20] crypto: ccree "
` [PATCH 07/20] crypto: hisilicon/sec2 "
` [PATCH 08/20] crypto: mediatek "
` [PATCH 09/20] crypto: n2 "
` [PATCH 10/20] crypto: omap-sham "
` [PATCH 11/20] crypto: s5p-sss "
` [PATCH 12/20] nfc: s3fwrn5: "
` [PATCH 13/20] fscrypt: "
` [PATCH 14/20] ecryptfs: "
` [PATCH 15/20] nfsd: "
` [PATCH 16/20] ubifs: "
` [PATCH 17/20] Bluetooth: "
` [PATCH 18/20] sctp: "
` [PATCH 19/20] KEYS: encrypted: "
` [PATCH 20/20] ASoC: cros_ec_codec: "

[PATCH -next] crypto: xilinx - Remove set but not used variable 'drv_ctx'
 2020-05-05 10:12 UTC 

[PATCH net-next 0/5] Crypto/chcr: Fix issues regarding algorithm implementation in driver
 2020-05-05  3:12 UTC  (6+ messages)
` [PATCH net-next 1/5] Crypto/chcr: fix gcm-aes and rfc4106-gcm failed tests
` [PATCH net-next 2/5] Crypto/chcr: fix ctr, cbc, xts and rfc3686-ctr "
` [PATCH net-next 3/5] Crypto/chcr: fix for ccm(aes) failed test
` [PATCH net-next 4/5] Crypto/chcr: support for 48 byte key_len in aes-xts
` [PATCH net-next 5/5] Crypto/chcr: fix for hmac(sha) test fails

[PATCH RFC] Frequent connection loss using krb5[ip] NFS mounts
 2020-05-04 19:10 UTC  (4+ messages)
` [PATCH RFC] SUNRPC: crypto calls should never schedule

[PATCH] cxgb4/chcr: avoid -Wreturn-local-addr warning
 2020-05-04 18:48 UTC  (2+ messages)

[PATCH 0/7] sha1 library cleanup
 2020-05-04 10:27 UTC  (13+ messages)
` [PATCH 1/7] mptcp: use SHA256_BLOCK_SIZE, not SHA_MESSAGE_BYTES
  ` [MPTCP] "
` [PATCH 2/7] crypto: powerpc/sha1 - remove unused temporary workspace
` [PATCH 3/7] crypto: powerpc/sha1 - prefix the "sha1_" functions
` [PATCH 4/7] crypto: s390/sha1 "
` [PATCH 5/7] crypto: lib/sha1 - rename "sha" to "sha1"
` [PATCH 6/7] crypto: lib/sha1 - remove unnecessary includes of linux/cryptohash.h
` [PATCH 7/7] crypto: lib/sha1 - fold linux/cryptohash.h into crypto/sha.h

[PATCH] ubifs: fix wrong use of crypto_shash_descsize()
 2020-05-04  7:16 UTC  (2+ messages)

[PATCH] crypto: lib/aes - move IRQ disabling into AES library
 2020-05-02 18:54 UTC  (2+ messages)

[PATCH] lib/xxhash: make xxh{32,64}_update() return void
 2020-05-02 16:46 UTC  (3+ messages)

[PATCH 0/1] mm/zswap: move to use crypto_acomp APIs
 2020-05-02  2:04 UTC  (2+ messages)
` [PATCH 1/1] mm/zswap: move to use crypto_acomp API for hardware acceleration

[PATCH v2] crypto: lib/sha256 - return void
 2020-05-01 21:40 UTC  (2+ messages)

WARNING: refcount bug in crypto_mod_get
 2020-05-01 17:01 UTC 

[PATCH] crypto: lib/sha256 - return void
 2020-05-01 16:39 UTC  (3+ messages)

[PATCH char-misc-next] crypto: xilinx: Handle AES PM API return status
 2020-05-01 10:54 UTC  (4+ messages)
` [PATCH char-misc-next v2] "

[PATCH 00/15] gcc-10 warning fixes
 2020-04-30 21:30 UTC  (2+ messages)
` [PATCH 01/15] crypto - Avoid free() namespace collision

[PATCH v4 00/19] Manually convert thermal, crypto and misc devices to ReST
 2020-04-30 16:18 UTC  (5+ messages)
` [PATCH v4 02/19] docs: crypto: convert asymmetric-keys.txt "
` [PATCH v4 03/19] docs: crypto: convert api-intro.txt to ReST format
` [PATCH v4 04/19] docs: crypto: convert async-tx-api.txt "
` [PATCH v4 05/19] docs: crypto: descore-readme.txt: convert "

[PATCH v3 0/3] hwrng: cctrng kconfig updates
 2020-04-30 14:10 UTC  (12+ messages)
` [PATCH v3 1/3] hwrng: cctrng - Add dependency on OF
` [PATCH v3 2/3] hwrng: cctrng - change default to n
` [PATCH v3 3/3] hwrng: cctrng - update help description

[PATCH -next] crypto: drbg - fix error return code in drbg_alloc_state()
 2020-04-30  8:15 UTC  (2+ messages)

[PATCH] crypto: bcm - Fix unused assignment
 2020-04-30  5:33 UTC  (2+ messages)

[PATCH] crypto: bcm - Remove the unnecessary cast for PTR_ERR()
 2020-04-30  5:33 UTC  (2+ messages)

[PATCH v3 0/3] crypto: fix some DRBG Kconfig deps
 2020-04-30  5:32 UTC  (4+ messages)
` [PATCH v3 1/3] crypto: drbg: DRBG should select SHA512

[PATCH -next] hwrng: cctrng - Make some symbols static
 2020-04-30  5:32 UTC  (2+ messages)

[PATCH -next] crypto: hisilicon/qm - Make qm_controller_reset() static
 2020-04-30  5:31 UTC  (2+ messages)

[PATCH crypto-stable v2] crypto: arch - limit simd usage to 4k chunks
 2020-04-30  5:30 UTC  (9+ messages)
` [PATCH crypto-stable v3 1/2] crypto: arch/lib "

[PATCH v1] hwrng: Use UUID API for exporting the UUID
 2020-04-30  5:30 UTC  (2+ messages)

[PATCH v2] crypto: ccp: Add support for SEV-ES to the PSP driver
 2020-04-30  5:29 UTC  (3+ messages)

[PATCH] padata: add separate cpuhp node for CPUHP_PADATA_DEAD
 2020-04-30  5:29 UTC  (2+ messages)

[PATCH] lib/mpi: Fix 64-bit MIPS build with Clang
 2020-04-30  5:30 UTC  (2+ messages)

[PATCH v2] crypto: acomp - search acomp with scomp backend in crypto_has_acomp
 2020-04-30  5:10 UTC 

[PATCH] crypto: acomp - search acomp with scomp backend in crypto_has_acomp
 2020-04-30  4:29 UTC  (2+ messages)

crypto: omap: sha/aes fixes
 2020-04-29 14:42 UTC  (7+ messages)
` [PATCH 1/6] crypto: omap-aes: avoid spamming console with self tests
` [PATCH 2/6] crypto: omap-sham: force kernel driver usage for sha algos
` [PATCH 3/6] crypto: omap-crypto: fix userspace copied buffer access
` [PATCH 4/6] crypto: omap-sham: huge buffer access fixes
` [PATCH 5/6] crypto: omap-sham: fix very small data size handling
` [PATCH 6/6] crypto: omap-aes: prevent unregistering algorithms twice

[PATCH v6 0/3] crypto: engine - support for parallel and batch requests
 2020-04-28 15:49 UTC  (4+ messages)
` [PATCH v6 1/3] crypto: algapi - create function to add request in front of queue
` [PATCH v6 2/3] crypto: engine - support for parallel requests based on retry mechanism
` [PATCH v6 3/3] crypto: engine - support for batch requests

[cryptodev:master 12/28] drivers/crypto/hisilicon/qm.c:2810:7: error: implicit declaration of function 'acpi_evaluate_integer'; did you mean 'acpi_evaluate_object'?
 2020-04-28 11:30 UTC  (2+ messages)

[PATCH] crypto: caam - fix use after free issue in *_crypt_done
 2020-04-28 10:09 UTC  (3+ messages)

[PATCH 0/3] hwrng: cctrng kconfig updates
 2020-04-27 21:48 UTC  (11+ messages)
` [PATCH 1/3] hwrng: cctrng - Add dependency on OF
` [PATCH 2/3] hwrng: cctrng - change default to n

[CRASH] crypto: omap: kernel panic when modprobing tcrypt
 2020-04-27 14:56 UTC  (7+ messages)

[PATCH v2 0/3] hwrng: cctrng kconfig updates
 2020-04-27 11:14 UTC  (6+ messages)
` [PATCH v2 1/3] hwrng: cctrng - Add dependency on OF
` [PATCH v2 2/3] hwrng: cctrng - change default to n
` [PATCH v2 3/3] hwrng: cctrng - update help description

[PATCH v2 00/14] crypto: allwinner: add xRNG and hashes
 2020-04-27  9:23 UTC  (8+ messages)
` [PATCH v2 13/14] crypto: sun8i-ce: Add support for the PRNG
` [PATCH v2 14/14] crypto: sun8i-ce: Add support for the TRNG

[PATCH] crypto: bcm - Use the defined variable to clean code
 2020-04-27  8:22 UTC 

[PATCH 0/3] crypto: stm32/hash: Defer probe management
 2020-04-27  6:42 UTC  (4+ messages)
` [PATCH 1/3] crypto: stm32/hash - defer probe for reset controller
` [PATCH 2/3] crypto: stm32/hash - defer probe for dma device
` [PATCH 3/3] crypto: stm32/hash - don't print error on probe deferral


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).