linux-crypto.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-07-13 06:05:26 to 2020-07-20 17:10:14 UTC [more...]

[PATCH 0/3] DH: SP800-56A rev 3 compliant shared secret
 2020-07-20 17:08 UTC  (28+ messages)
` [PATCH v2 0/5] DH: SP800-56A rev 3 compliant validation checks
  ` [PATCH v2 1/5] crypto: ECDH - check validity of Z before export
  ` [PATCH v2 2/5] lib/mpi: Add mpi_sub_ui()
  ` [PATCH v2 3/5] crypto: DH - check validity of Z before export
  ` [PATCH v2 4/5] crypto: DH SP800-56A rev 3 local public key validation
  ` [PATCH v2 5/5] crypto: ECDH "
  ` [PATCH v3 0/5] DH: SP800-56A rev 3 compliant validation checks
    ` [PATCH v3 1/5] crypto: ECDH - check validity of Z before export
    ` [PATCH v3 3/5] crypto: DH "
    ` [PATCH v3 4/5] crypto: DH SP800-56A rev 3 local public key validation

get rid of the address_space override in setsockopt
 2020-07-20 16:38 UTC  (28+ messages)
` [PATCH 01/24] bpfilter: reject kernel addresses
` [PATCH 02/24] bpfilter: fix up a sparse annotation
` [PATCH 03/24] net: add a new sockptr_t type
` [PATCH 04/24] net: switch copy_bpf_fprog_from_user to sockptr_t
` [PATCH 05/24] net: switch sock_setbindtodevice "
` [PATCH 06/24] net: switch sock_set_timeout "
` [PATCH 07/24] "
` [PATCH 08/24] net/xfrm: switch xfrm_user_policy "
` [PATCH 09/24] netfilter: remove the unused user argument to do_update_counters
` [PATCH 10/24] netfilter: switch xt_copy_counters to sockptr_t
` [PATCH 11/24] netfilter: switch nf_setsockopt "
` [PATCH 12/24] bpfilter: switch bpfilter_ip_set_sockopt "
` [PATCH 13/24] net/ipv4: switch ip_mroute_setsockopt "
` [PATCH 14/24] net/ipv4: merge ip_options_get and ip_options_get_from_user
` [PATCH 15/24] net/ipv4: switch do_ip_setsockopt to sockptr_t
` [PATCH 16/24] net/ipv6: switch ip6_mroute_setsockopt "
` [PATCH 17/24] net/ipv6: split up ipv6_flowlabel_opt
` [PATCH 18/24] net/ipv6: switch ipv6_flowlabel_opt to sockptr_t
` [PATCH 19/24] net/ipv6: factor out a ipv6_set_opt_hdr helper
` [PATCH 20/24] net/ipv6: switch do_ipv6_setsockopt to sockptr_t
` [PATCH 21/24] net/udp: switch udp_lib_setsockopt "
` [PATCH 22/24] net/tcp: switch ->md5_parse "
` [PATCH 23/24] net/tcp: switch do_tcp_setsockopt "
` [PATCH 24/24] net: pass a sockptr_t into ->setsockopt

[PATCH] crypto: x86 - Put back integer parts of include/asm/inst.h
 2020-07-20 13:51 UTC 

[PATCH -next] crypto: allwinner - Convert to DEFINE_SHOW_ATTRIBUTE
 2020-07-20 12:10 UTC  (2+ messages)

[PATCH -next] crypto: caam: Convert to DEFINE_SHOW_ATTRIBUTE
 2020-07-20 12:01 UTC  (2+ messages)

linux-next: manual merge of the tip tree with the crypto tree
 2020-07-20 11:59 UTC  (9+ messages)

[PATCH -next] crypto: amlogic: Convert to DEFINE_SHOW_ATTRIBUTE
 2020-07-20  8:40 UTC  (2+ messages)

[PATCH for v5.9] arm64: Replace HTTP links with HTTPS ones
 2020-07-19 19:42 UTC  (2+ messages)

[PATCH] crypto: testmgr.h: delete duplicated words
 2020-07-19 18:07 UTC 

[PATCH for v5.9] crypto: Replace HTTP links with HTTPS ones
 2020-07-19 16:49 UTC 

[PATCH for v5.9] ARM: STM32: Replace HTTP links with HTTPS ones
 2020-07-19  9:49 UTC 

[PATCH 1/1 v2] inside-secure irq balance
 2020-07-19  6:09 UTC  (3+ messages)

[PATCH] powerpc: Replace HTTP links with HTTPS ones
 2020-07-18 10:39 UTC 

[PATCH 1/1 v2] marvell cesa irq balance
 2020-07-18  9:44 UTC 

[RFC PATCH 0/7] crypto: get rid of ecb(arc4)
 2020-07-18  8:18 UTC  (6+ messages)
` [RFC PATCH 4/7] crypto: remove ARC4 support from the skcipher API

[PATCH] crypto: skcipher.h: drop duplicated word in kernel-doc
 2020-07-18  1:33 UTC  (2+ messages)

[PATCH] crypto: hash.h: drop duplicated word in a comment
 2020-07-18  1:33 UTC  (2+ messages)

[PATCH v2 0/7] crypto: add CRYPTO_ALG_ALLOCATES_MEMORY
 2020-07-17 14:42 UTC  (3+ messages)

[PATCH 1/1] inside-secure irq balance
 2020-07-17 13:50 UTC  (13+ messages)

linux-next: manual merge of the akpm-current tree with the crypto tree
 2020-07-17 10:14 UTC 

[Patch v2 0/9] crypto: hisilicon/qm - misc fixes
 2020-07-17  7:16 UTC  (6+ messages)
` [Patch v2 8/9] crypto: hisilicon/qm - fix the process of register algorithms to crypto

[PATCH] crypto: xts: use memmove to avoid overlapped memory copy
 2020-07-17  6:43 UTC  (6+ messages)

[PATCH 0/1] crypto: af_alg - add extra parameters for DRBG interface
 2020-07-16 16:40 UTC  (12+ messages)
` [PATCH 1/1] "
      ` [PATCH v2] "

[PATCH 0/2] crypto: caam - add tagged keys functionality and tk transformations for skcipher
 2020-07-16 14:12 UTC  (12+ messages)
` [PATCH 1/2] crypto: caam - add tag object functionality
` [PATCH 2/2] crypto: caam - support tagged keys for skcipher algorithms

[RESEND PATCH v5] mm/zswap: move to use crypto_acomp API for hardware acceleration
 2020-07-16 13:50 UTC 

[PATCH] crypto: xts - prefix function and struct names with "xts"
 2020-07-16 11:56 UTC  (2+ messages)

[PATCH] crypto: lrw - prefix function and struct names with "lrw"
 2020-07-16 11:56 UTC  (2+ messages)

[PATCH 2/2] Crypto/chcr: Fix some pr_xxx messages
 2020-07-16 11:56 UTC  (2+ messages)

[PATCH 1/2] Crypto/chcr: Avoid some code duplication
 2020-07-16 11:56 UTC  (2+ messages)

[PATCH v2 0/6] crypto: hisilicon/hpre bugfix - misc fixes
 2020-07-16 11:55 UTC  (2+ messages)

[PATCH] HARDWARE RANDOM NUMBER GENERATOR CORE: Replace HTTP links with HTTPS ones
 2020-07-16 11:54 UTC  (2+ messages)

[PATCH] crypto/x86: Remove include/asm/inst.h
 2020-07-16 11:54 UTC  (2+ messages)

[PATCH v4 00/13] crypto: permit asynchronous skciphers as driver fallbacks
 2020-07-16 11:53 UTC  (2+ messages)

[PATCH v2 0/5] crypto: add sha256() function
 2020-07-16 11:54 UTC  (2+ messages)

[PATCH] crypto: x86/chacha-sse3 - use unaligned loads for state array
 2020-07-16 11:54 UTC  (2+ messages)

[PATCH v2 0/5] crypto: hisilicon/sec2 - fix SEC bugs and coding styles
 2020-07-16 11:53 UTC  (2+ messages)

[PATCH -next] crypto: zip: Convert to DEFINE_SHOW_ATTRIBUTE
 2020-07-16  9:03 UTC 

[PATCH -next] crypto: hisilicon: Convert to DEFINE_SHOW_ATTRIBUTE
 2020-07-16  9:03 UTC 

[PATCH] crypto: caam - Remove broken arc4 support
 2020-07-16  8:09 UTC  (2+ messages)

[PATCH] crypto: omap-aes - Fix sparse and compiler warnings
 2020-07-16  8:06 UTC 

[PATCH 1/1] marvell cesa irq balance
 2020-07-16  7:23 UTC  (2+ messages)

[PATCH v4 0/5] hwrng: add support for i.MX6 rngb
 2020-07-15 15:26 UTC  (6+ messages)
` [PATCH v4 1/5] dt-bindings: rng: add RNGB compatibles for i.MX6 SoCs
` [PATCH v4 2/5] ARM: dts: imx6sl: fix rng node
` [PATCH v4 3/5] ARM: dts: imx6sll: add rng
` [PATCH v4 4/5] ARM: dts: imx6ull: "
` [PATCH v4 5/5] hwrng: imx-rngc: enable driver for i.MX6

[PATCH v3 0/5] hwrng: add support for i.MX6 rngb
 2020-07-14 21:09 UTC  (10+ messages)
` [PATCH v3 1/5] dt-bindings: rng: add RNGB compatibles for i.MX6 SoCs
` [PATCH v3 2/5] ARM: dts: imx6sl: fix rng node
` [PATCH v3 3/5] ARM: dts: imx6sll: add rng
` [PATCH v3 4/5] ARM: dts: imx6ull: "
` [PATCH v3 5/5] hwrng: imx-rngc: enable driver for i.MX6

[PATCH 0/6] padata cleanups
 2020-07-14 20:13 UTC  (7+ messages)
` [PATCH 1/6] padata: remove start function
` [PATCH 2/6] padata: remove stop function
` [PATCH 3/6] padata: inline single call of pd_setup_cpumasks()
` [PATCH 4/6] padata: remove effective cpumasks from the instance
` [PATCH 5/6] padata: fold padata_alloc_possible() into padata_alloc()
` [PATCH 6/6] padata: remove padata_parallel_queue

[PATCH v2 0/5] vfio/pci: add blocklist and disable qat
 2020-07-14 15:28 UTC  (7+ messages)
` [PATCH v2 1/5] PCI: Add Intel QuickAssist device IDs
` [PATCH v2 2/5] vfio/pci: Add device blocklist
` [PATCH v2 3/5] vfio/pci: Add QAT devices to blocklist
` [PATCH v2 4/5] crypto: qat - replace device ids defines
` [PATCH v2 5/5] crypto: qat - use PCI_VDEVICE

[PATCH 0/6] crypto: add CRYPTO_ALG_ALLOCATES_MEMORY
 2020-07-14 13:38 UTC  (6+ messages)
` [PATCH 5/6] crypto: set the flag CRYPTO_ALG_ALLOCATES_MEMORY

[PATCH v2 0/5] hwrng: add support for i.MX6 rngb
 2020-07-14 12:24 UTC  (4+ messages)
` [PATCH v2 1/5] dt-bindings: rng: add RNGB compatibles for i.MX6 SoCs

[PATCH 2/2] Crypto/chcr: Fix some pr_xxx messages
 2020-07-13 20:00 UTC 

[PATCH 1/2] Crypto/chcr: Avoid some code duplication
 2020-07-13 19:30 UTC 

[PATCH] crypto: qat: fix double free in qat_uclo_create_batch_init_list
 2020-07-13 14:19 UTC  (2+ messages)

[PATCHv5 0/7] crypto: sa2ul driver support
 2020-07-13  8:40 UTC  (5+ messages)
` [PATCHv5 2/7] crypto: sa2ul: Add crypto driver

[PATCHv6 0/7] crypto: add driver for TI K3 SA2UL
 2020-07-13  8:34 UTC  (8+ messages)
` [PATCHv6 1/7] dt-bindings: crypto: Add TI SA2UL crypto accelerator documentation
` [PATCHv6 2/7] crypto: sa2ul: Add crypto driver
` [PATCHv6 3/7] crypto: sa2ul: add sha1/sha256/sha512 support
` [PATCHv6 4/7] crypto: sa2ul: Add AEAD algorithm support
` [PATCHv6 5/7] crypto: sa2ul: add device links to child devices
` [PATCHv6 6/7] arm64: dts: ti: k3-am6: Add crypto accelarator node
` [PATCHv6 7/7] arm64: dts: ti: k3-j721e-main: Add crypto accelerator node

[PATCH v31 00/12] /dev/random - a new approach with full SP800-90B
 2020-07-13  6:22 UTC  (13+ messages)
` [PATCH v31 01/12] Linux Random Number Generator
` [PATCH v31 02/12] LRNG - allocate one DRNG instance per NUMA node
` [PATCH v31 03/12] LRNG - sysctls and /proc interface
` [PATCH v31 04/12] LRNG - add switchable DRNG support
` [PATCH v31 05/12] crypto: DRBG - externalize DRBG functions for LRNG
` [PATCH v31 06/12] LRNG - add SP800-90A DRBG extension
` [PATCH v31 07/12] LRNG - add kernel crypto API PRNG extension
` [PATCH v31 08/12] crypto: provide access to a static Jitter RNG state
` [PATCH v31 09/12] LRNG - add Jitter RNG fast noise source
` [PATCH v31 10/12] LRNG - add SP800-90B compliant health tests
` [PATCH v31 11/12] LRNG - add interface for gathering of raw entropy
` [PATCH v31 12/12] LRNG - add power-on and runtime self-tests


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).