linux-crypto.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-07-16 09:00:23 to 2020-07-22 20:49:23 UTC [more...]

[PATCH v2 1/2] kbuild: introduce ccflags-remove-y and asflags-remove-y
 2020-07-22 20:49 UTC  (8+ messages)
` [PATCH v2 2/2] kbuild: trace functions in subdirectories of lib/

[PATCH v1] crypto: ccp: sp-pci: use generic power management
 2020-07-22 18:40 UTC  (8+ messages)
      ` [PATCH v2] "

[PATCH 0/2] Add support for the RNG in Ingenic JZ4780 and X1000
 2020-07-22 18:27 UTC  (4+ messages)
` [PATCH 1/2] dt-bindings: RNG: Add Ingenic RNG bindings
` [PATCH 2/2] crypto: Ingenic: Add hardware RNG for Ingenic JZ4780 and X1000

get rid of the address_space override in setsockopt
 2020-07-22 17:09 UTC  (50+ messages)
` [PATCH 01/24] bpfilter: reject kernel addresses
` [PATCH 02/24] bpfilter: fix up a sparse annotation
` [PATCH 03/24] net: add a new sockptr_t type
` [PATCH 04/24] net: switch copy_bpf_fprog_from_user to sockptr_t
` [PATCH 05/24] net: switch sock_setbindtodevice "
` [PATCH 06/24] net: switch sock_set_timeout "
` [PATCH 07/24] "
` [PATCH 08/24] net/xfrm: switch xfrm_user_policy "
` [PATCH 09/24] netfilter: remove the unused user argument to do_update_counters
` [PATCH 10/24] netfilter: switch xt_copy_counters to sockptr_t
` [PATCH 11/24] netfilter: switch nf_setsockopt "
` [PATCH 12/24] bpfilter: switch bpfilter_ip_set_sockopt "
` [PATCH 13/24] net/ipv4: switch ip_mroute_setsockopt "
` [PATCH 14/24] net/ipv4: merge ip_options_get and ip_options_get_from_user
` [PATCH 15/24] net/ipv4: switch do_ip_setsockopt to sockptr_t
` [PATCH 16/24] net/ipv6: switch ip6_mroute_setsockopt "
` [PATCH 17/24] net/ipv6: split up ipv6_flowlabel_opt
` [PATCH 18/24] net/ipv6: switch ipv6_flowlabel_opt to sockptr_t
` [PATCH 19/24] net/ipv6: factor out a ipv6_set_opt_hdr helper
` [PATCH 20/24] net/ipv6: switch do_ipv6_setsockopt to sockptr_t
` [PATCH 21/24] net/udp: switch udp_lib_setsockopt "
` [PATCH 22/24] net/tcp: switch ->md5_parse "
` [PATCH 23/24] net/tcp: switch do_tcp_setsockopt "
` [PATCH 24/24] net: pass a sockptr_t into ->setsockopt
  ` [MPTCP] "

[PATCH 0/1] crypto: af_alg - add extra parameters for DRBG interface
 2020-07-22 15:59 UTC  (16+ messages)
` [PATCH 1/1] "
      ` [PATCH v2] "

[PATCH 0/3] DH: SP800-56A rev 3 compliant shared secret
 2020-07-22 13:11 UTC  (21+ messages)
` [PATCH v2 0/5] DH: SP800-56A rev 3 compliant validation checks
  ` [PATCH v2 2/5] lib/mpi: Add mpi_sub_ui()
  ` [PATCH v3 0/5] DH: SP800-56A rev 3 compliant validation checks
    ` [PATCH v3 1/5] crypto: ECDH - check validity of Z before export
    ` [PATCH v3 2/5] lib/mpi: Add mpi_sub_ui()
    ` [PATCH v3 3/5] crypto: DH - check validity of Z before export
    ` [PATCH v3 4/5] crypto: DH SP800-56A rev 3 local public key validation
    ` [PATCH v3 5/5] crypto: ECDH "

[PATCH 0/7] crypto: caam - updates for 5.9
 2020-07-22 12:25 UTC  (9+ messages)
` [PATCH 1/7] crypto: caam - remove deadcode on 32-bit platforms
` [PATCH 2/7] crypto: caam/qi2 - fix error reporting for caam_hash_alloc
` [PATCH 3/7] crypto: caam/qi2 - create ahash shared descriptors only once
` [PATCH 4/7] crypto: caam - silence .setkey in case of bad key length
` [PATCH 5/7] crypto: caam/jr - remove incorrect reference to caam_jr_register()
` [PATCH 6/7] crypto: caam - add more RNG hw error codes
` [PATCH 7/7] crypto: caam/qi2 - add module alias

[PATCH v2 0/7] crypto: add CRYPTO_ALG_ALLOCATES_MEMORY
 2020-07-22  7:29 UTC  (4+ messages)

[PATCH for v5.9] ARM: STM32: Replace HTTP links with HTTPS ones
 2020-07-22  7:11 UTC  (5+ messages)

[PATCH v4 00/17] crypto: allwinner: add xRNG and hashes
 2020-07-22  6:21 UTC  (21+ messages)
` [PATCH v4 01/17] crypto: sun8i-ss: Add SS_START define
` [PATCH v4 02/17] crypto: sun8i-ss: Add support for the PRNG
` [PATCH v4 03/17] crypto: sun8i-ss: support hash algorithms
` [PATCH v4 04/17] crypto: sun8i-ss: fix a trivial typo
` [PATCH v4 05/17] crypto: sun8i-ss: Add more comment on some structures
` [PATCH v4 06/17] crypto: sun8i-ss: better debug printing
` [PATCH v4 07/17] crypto: sun8i-ce: handle endianness of t_common_ctl
` [PATCH v4 08/17] crypto: sun8i-ce: move iv data to request context
` [PATCH v4 09/17] crypto: sun8i-ce: split into prepare/run/unprepare
` [PATCH v4 10/17] crypto: sun8i-ce: handle different error registers
` [PATCH v4 11/17] crypto: sun8i-ce: rename has_t_dlen_in_bytes to cipher_t_dlen_in_bytes
` [PATCH v4 12/17] crypto: sun8i-ce: support hash algorithms
` [PATCH v4 13/17] crypto: sun8i-ce: Add stat_bytes debugfs
` [PATCH v4 14/17] crypto: sun8i-ce: Add support for the PRNG
` [PATCH v4 15/17] crypto: sun8i-ce: Add support for the TRNG
` [PATCH v4 16/17] crypto: sun8i-ce: fix comparison of integer expressions of different signedness
    ` [PATCH] Makefile.extrawarn: Move sign-compare from W=2 to W=3
` [PATCH v4 17/17] crypto: sun8i-ss: fix comparison of integer expressions of different signedness

[PATCH] crypto: xts - Replace memcpy() invocation with simple assignment
 2020-07-21  6:05 UTC 

[PATCH 1/1 v3] marvell cesa irq balance
 2020-07-21  4:40 UTC 

[PATCH 1/1 v3] inside-secure irq balance
 2020-07-21  4:37 UTC 

linux-next: manual merge of the tip tree with the crypto tree
 2020-07-21  4:28 UTC 

[PATCH] crypto: x86 - Put back integer parts of include/asm/inst.h
 2020-07-20 13:51 UTC 

[PATCH -next] crypto: allwinner - Convert to DEFINE_SHOW_ATTRIBUTE
 2020-07-20 12:10 UTC  (2+ messages)

[PATCH -next] crypto: caam: Convert to DEFINE_SHOW_ATTRIBUTE
 2020-07-20 12:01 UTC  (2+ messages)

linux-next: manual merge of the tip tree with the crypto tree
 2020-07-20 11:59 UTC  (9+ messages)

[PATCH -next] crypto: amlogic: Convert to DEFINE_SHOW_ATTRIBUTE
 2020-07-20  8:40 UTC  (2+ messages)

[PATCH for v5.9] arm64: Replace HTTP links with HTTPS ones
 2020-07-19 19:42 UTC  (2+ messages)

[PATCH] crypto: testmgr.h: delete duplicated words
 2020-07-19 18:07 UTC 

[PATCH for v5.9] crypto: Replace HTTP links with HTTPS ones
 2020-07-19 16:49 UTC 

[PATCH 1/1 v2] inside-secure irq balance
 2020-07-19  6:09 UTC  (3+ messages)

[PATCH] powerpc: Replace HTTP links with HTTPS ones
 2020-07-18 10:39 UTC 

[PATCH 1/1 v2] marvell cesa irq balance
 2020-07-18  9:44 UTC 

[RFC PATCH 0/7] crypto: get rid of ecb(arc4)
 2020-07-18  8:18 UTC  (6+ messages)
` [RFC PATCH 4/7] crypto: remove ARC4 support from the skcipher API

[PATCH] crypto: skcipher.h: drop duplicated word in kernel-doc
 2020-07-18  1:33 UTC  (2+ messages)

[PATCH] crypto: hash.h: drop duplicated word in a comment
 2020-07-18  1:33 UTC  (2+ messages)

[PATCH 1/1] inside-secure irq balance
 2020-07-17 13:50 UTC  (13+ messages)

linux-next: manual merge of the akpm-current tree with the crypto tree
 2020-07-17 10:14 UTC 

[Patch v2 0/9] crypto: hisilicon/qm - misc fixes
 2020-07-17  7:16 UTC  (6+ messages)
` [Patch v2 8/9] crypto: hisilicon/qm - fix the process of register algorithms to crypto

[PATCH] crypto: xts: use memmove to avoid overlapped memory copy
 2020-07-17  6:43 UTC  (6+ messages)

[PATCH 0/2] crypto: caam - add tagged keys functionality and tk transformations for skcipher
 2020-07-16 14:12 UTC  (12+ messages)
` [PATCH 1/2] crypto: caam - add tag object functionality
` [PATCH 2/2] crypto: caam - support tagged keys for skcipher algorithms

[RESEND PATCH v5] mm/zswap: move to use crypto_acomp API for hardware acceleration
 2020-07-16 13:50 UTC 

[PATCH] crypto: xts - prefix function and struct names with "xts"
 2020-07-16 11:56 UTC  (2+ messages)

[PATCH] crypto: lrw - prefix function and struct names with "lrw"
 2020-07-16 11:56 UTC  (2+ messages)

[PATCH 2/2] Crypto/chcr: Fix some pr_xxx messages
 2020-07-16 11:56 UTC  (2+ messages)

[PATCH 1/2] Crypto/chcr: Avoid some code duplication
 2020-07-16 11:56 UTC  (2+ messages)

[PATCH v2 0/6] crypto: hisilicon/hpre bugfix - misc fixes
 2020-07-16 11:55 UTC  (2+ messages)

[PATCH] HARDWARE RANDOM NUMBER GENERATOR CORE: Replace HTTP links with HTTPS ones
 2020-07-16 11:54 UTC  (2+ messages)

[PATCH] crypto/x86: Remove include/asm/inst.h
 2020-07-16 11:54 UTC  (2+ messages)

[PATCH v4 00/13] crypto: permit asynchronous skciphers as driver fallbacks
 2020-07-16 11:53 UTC  (2+ messages)

[PATCH v2 0/5] crypto: add sha256() function
 2020-07-16 11:54 UTC  (2+ messages)

[PATCH] crypto: x86/chacha-sse3 - use unaligned loads for state array
 2020-07-16 11:54 UTC  (2+ messages)

[PATCH v2 0/5] crypto: hisilicon/sec2 - fix SEC bugs and coding styles
 2020-07-16 11:53 UTC  (2+ messages)


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).