linux-csky.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH V2 00/11] Subject: Remove duplicated kmap code
@ 2020-05-04  1:09 ira.weiny
  2020-05-04  1:09 ` [PATCH V2 01/11] arch/kmap: Remove BUG_ON() ira.weiny
                   ` (11 more replies)
  0 siblings, 12 replies; 28+ messages in thread
From: ira.weiny @ 2020-05-04  1:09 UTC (permalink / raw)
  To: linux-kernel, Andrew Morton, Christian Koenig, Huang Rui
  Cc: Ira Weiny, Thomas Bogendoerfer, James E.J. Bottomley,
	Helge Deller, Benjamin Herrenschmidt, Paul Mackerras,
	David S. Miller, Thomas Gleixner, Ingo Molnar, Borislav Petkov,
	x86, H. Peter Anvin, Dave Hansen, Andy Lutomirski,
	Peter Zijlstra, Chris Zankel, Max Filippov, Dan Williams,
	linux-snps-arc, linux-arm-kernel, linux-csky, linux-mips,
	linux-parisc, linuxppc-dev, sparclinux, linux-xtensa, dri-devel

From: Ira Weiny <ira.weiny@intel.com>

The kmap infrastructure has been copied almost verbatim to every architecture.
This series consolidates obvious duplicated code by defining core functions
which call into the architectures only when needed.

Some of the k[un]map_atomic() implementations have some similarities but the
similarities were not sufficient to warrant further changes.

In addition we remove a duplicate implementation of kmap() in DRM.

Testing was done by 0day to cover all the architectures I can't readily
build/test.

---
Changes from V1:
	Fix bisect-ability
	Update commit message and fix line lengths
	Remove unneded kunmap_atomic_high() declarations
	Remove unneded kmap_atomic_high() declarations
	collect reviews
	rebase to 5.7-rc4

Changes from V0:
	Define kmap_flush_tlb() and make kmap() truely arch independent.
	Redefine the k[un]map_atomic_* code to call into the architectures for
		high mem pages
	Ensure all architectures define kmap_prot, use it appropriately, and
		define kmap_atomic_prot()
	Remove drm implementation of kmap_atomic()

Ira Weiny (11):
  arch/kmap: Remove BUG_ON()
  arch/xtensa: Move kmap build bug out of the way
  arch/kmap: Remove redundant arch specific kmaps
  arch/kunmap: Remove duplicate kunmap implementations
  {x86,powerpc,microblaze}/kmap: Move preempt disable
  arch/kmap_atomic: Consolidate duplicate code
  arch/kunmap_atomic: Consolidate duplicate code
  arch/kmap: Ensure kmap_prot visibility
  arch/kmap: Don't hard code kmap_prot values
  arch/kmap: Define kmap_atomic_prot() for all arch's
  drm: Remove drm specific kmap_atomic code

 arch/arc/include/asm/highmem.h        | 15 -------
 arch/arc/mm/highmem.c                 | 28 +++---------
 arch/arm/include/asm/highmem.h        |  7 ---
 arch/arm/mm/highmem.c                 | 35 +++------------
 arch/csky/include/asm/highmem.h       |  9 +---
 arch/csky/mm/highmem.c                | 43 +++++--------------
 arch/microblaze/include/asm/highmem.h | 28 +-----------
 arch/microblaze/mm/highmem.c          | 16 ++-----
 arch/microblaze/mm/init.c             |  3 --
 arch/mips/include/asm/highmem.h       |  9 +---
 arch/mips/mm/cache.c                  |  6 +--
 arch/mips/mm/highmem.c                | 49 ++++-----------------
 arch/nds32/include/asm/highmem.h      |  7 ---
 arch/nds32/mm/highmem.c               | 39 +++--------------
 arch/parisc/include/asm/cacheflush.h  |  4 +-
 arch/powerpc/include/asm/highmem.h    | 29 +------------
 arch/powerpc/mm/highmem.c             | 21 ++-------
 arch/powerpc/mm/mem.c                 |  3 --
 arch/sparc/include/asm/highmem.h      | 22 ----------
 arch/sparc/mm/highmem.c               | 18 +++-----
 arch/x86/include/asm/highmem.h        |  9 ----
 arch/x86/mm/highmem_32.c              | 50 ++-------------------
 arch/xtensa/include/asm/highmem.h     | 27 ------------
 arch/xtensa/mm/highmem.c              | 22 ++++------
 drivers/gpu/drm/ttm/ttm_bo_util.c     | 56 ++----------------------
 drivers/gpu/drm/vmwgfx/vmwgfx_blit.c  | 16 +++----
 include/drm/ttm/ttm_bo_api.h          |  4 --
 include/linux/highmem.h               | 62 +++++++++++++++++++++++++--
 28 files changed, 140 insertions(+), 497 deletions(-)

-- 
2.25.1


^ permalink raw reply	[flat|nested] 28+ messages in thread

end of thread, other threads:[~2020-05-07  4:56 UTC | newest]

Thread overview: 28+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-05-04  1:09 [PATCH V2 00/11] Subject: Remove duplicated kmap code ira.weiny
2020-05-04  1:09 ` [PATCH V2 01/11] arch/kmap: Remove BUG_ON() ira.weiny
2020-05-04  1:09 ` [PATCH V2 02/11] arch/xtensa: Move kmap build bug out of the way ira.weiny
2020-05-04  1:09 ` [PATCH V2 03/11] arch/kmap: Remove redundant arch specific kmaps ira.weiny
2020-05-04  1:09 ` [PATCH V2 04/11] arch/kunmap: Remove duplicate kunmap implementations ira.weiny
2020-05-04  1:09 ` [PATCH V2 05/11] {x86,powerpc,microblaze}/kmap: Move preempt disable ira.weiny
2020-05-06  6:11   ` Christoph Hellwig
2020-05-06 20:25     ` Ira Weiny
2020-05-04  1:09 ` [PATCH V2 06/11] arch/kmap_atomic: Consolidate duplicate code ira.weiny
2020-05-06  6:12   ` Christoph Hellwig
2020-05-04  1:09 ` [PATCH V2 07/11] arch/kunmap_atomic: " ira.weiny
2020-05-06  6:12   ` Christoph Hellwig
2020-05-04  1:09 ` [PATCH V2 08/11] arch/kmap: Ensure kmap_prot visibility ira.weiny
2020-05-06  6:13   ` Christoph Hellwig
2020-05-06 20:33     ` Ira Weiny
2020-05-07  4:56   ` Christoph Hellwig
2020-05-04  1:09 ` [PATCH V2 09/11] arch/kmap: Don't hard code kmap_prot values ira.weiny
2020-05-04  1:09 ` [PATCH V2 10/11] arch/kmap: Define kmap_atomic_prot() for all arch's ira.weiny
2020-05-06  6:14   ` Christoph Hellwig
2020-05-04  1:09 ` [PATCH V2 11/11] drm: Remove drm specific kmap_atomic code ira.weiny
2020-05-04 11:18   ` Daniel Vetter
2020-05-04 20:24     ` Ira Weiny
2020-05-04  1:35 ` [PATCH V2 00/11] Subject: Remove duplicated kmap code Al Viro
2020-05-04  5:04   ` Ira Weiny
2020-05-04  5:33     ` Al Viro
2020-05-04 20:17       ` Ira Weiny
2020-05-04 21:02         ` Al Viro
2020-05-04 23:27           ` Ira Weiny

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).