On Tue, Feb 13, 2018 at 04:58:22PM +0000, srinivas.kandagatla@linaro.org wrote: > + num_regions = is_contiguous ? 1 : periods; > + buf_sz = is_contiguous ? (period_sz * periods) : period_sz; Please write normal if statements, it's much easier to read. > + buf_sz = PAGE_ALIGN(buf_sz); I don't understand what this is doing, buf_sz is a length not an address so why are we attempting to align it?