devicetree.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH v2] dt-bindings: mfd: rohm,bd71837-pmic: Add common properties
@ 2020-09-17 19:37 Krzysztof Kozlowski
  2020-09-18  5:48 ` Vaittinen, Matti
                   ` (3 more replies)
  0 siblings, 4 replies; 7+ messages in thread
From: Krzysztof Kozlowski @ 2020-09-17 19:37 UTC (permalink / raw)
  To: Lee Jones, Rob Herring, Matti Vaittinen, devicetree, linux-kernel
  Cc: Krzysztof Kozlowski

Add common properties appearing in DTSes (clock-names,
clock-output-names) with the common values (actually used in DTSes) to
fix dtbs_check warnings like:

  arch/arm64/boot/dts/freescale/imx8mq-librem5-r2.dt.yaml:
    pmic@4b: 'clock-names', 'clock-output-names', do not match any of the regexes: 'pinctrl-[0-9]+'

Signed-off-by: Krzysztof Kozlowski <krzk@kernel.org>

---

Changes since v1:
1. Define the names, as used in existing DTS files.
---
 .../devicetree/bindings/mfd/rohm,bd71837-pmic.yaml          | 6 ++++++
 1 file changed, 6 insertions(+)

diff --git a/Documentation/devicetree/bindings/mfd/rohm,bd71837-pmic.yaml b/Documentation/devicetree/bindings/mfd/rohm,bd71837-pmic.yaml
index 65018a019e1d..3bfdd33702ad 100644
--- a/Documentation/devicetree/bindings/mfd/rohm,bd71837-pmic.yaml
+++ b/Documentation/devicetree/bindings/mfd/rohm,bd71837-pmic.yaml
@@ -32,9 +32,15 @@ properties:
   clocks:
     maxItems: 1
 
+  clock-names:
+    const: osc
+
   "#clock-cells":
     const: 0
 
+  clock-output-names:
+    const: pmic_clk
+
 # The BD718x7 supports two different HW states as reset target states. States
 # are called as SNVS and READY. At READY state all the PMIC power outputs go
 # down and OTP is reload. At the SNVS state all other logic and external
-- 
2.17.1


^ permalink raw reply related	[flat|nested] 7+ messages in thread

* Re: [PATCH v2] dt-bindings: mfd: rohm,bd71837-pmic: Add common properties
  2020-09-17 19:37 [PATCH v2] dt-bindings: mfd: rohm,bd71837-pmic: Add common properties Krzysztof Kozlowski
@ 2020-09-18  5:48 ` Vaittinen, Matti
  2020-09-18  6:58   ` Krzysztof Kozlowski
  2020-09-23 20:32 ` Rob Herring
                   ` (2 subsequent siblings)
  3 siblings, 1 reply; 7+ messages in thread
From: Vaittinen, Matti @ 2020-09-18  5:48 UTC (permalink / raw)
  To: robh+dt, devicetree, linux-kernel, krzk, lee.jones

Hi deeee Ho peeps!

On Thu, 2020-09-17 at 21:37 +0200, Krzysztof Kozlowski wrote:
> Add common properties appearing in DTSes (clock-names,
> clock-output-names) with the common values (actually used in DTSes)
> to
> fix dtbs_check warnings like:
> 
>   arch/arm64/boot/dts/freescale/imx8mq-librem5-r2.dt.yaml:
>     pmic@4b: 'clock-names', 'clock-output-names', do not match any of
> the regexes: 'pinctrl-[0-9]+'
> 
> Signed-off-by: Krzysztof Kozlowski <krzk@kernel.org>
> 
> ---
> 
> Changes since v1:
> 1. Define the names, as used in existing DTS files.
> ---
>  .../devicetree/bindings/mfd/rohm,bd71837-pmic.yaml          | 6
> ++++++
>  1 file changed, 6 insertions(+)
> 
> diff --git a/Documentation/devicetree/bindings/mfd/rohm,bd71837-
> pmic.yaml b/Documentation/devicetree/bindings/mfd/rohm,bd71837-
> pmic.yaml
> index 65018a019e1d..3bfdd33702ad 100644
> --- a/Documentation/devicetree/bindings/mfd/rohm,bd71837-pmic.yaml
> +++ b/Documentation/devicetree/bindings/mfd/rohm,bd71837-pmic.yaml
> @@ -32,9 +32,15 @@ properties:
>    clocks:
>      maxItems: 1
>  
> +  clock-names:
> +    const: osc

I guess existing board dtses use "osc" then? Ok.

>    "#clock-cells":
>      const: 0
>  
> +  clock-output-names:
> +    const: pmic_clk

This is not a strong opinion but I feel that pmic_clk is a bit too
generic name? I mean, what if there is a system with more than one
PMICs? (I don't see such use-case with the BD718x7 though - but perhaps
this can serve as a misleading example for other PMICs? For example
with the ROHM BD96801 family there may be multiple PMICs in one
system). Anyways - if Rob is happy with this then please go with it :)

Acked-By: Matti Vaittinen <matti.vaittinen@fi.rohmeurope.com>
 * 
Thanks again for improving these bindings! I am constantly struggling
with these x_x. Writing the bindings is probably hardest part of PMIC
driver development -_-;



^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PATCH v2] dt-bindings: mfd: rohm,bd71837-pmic: Add common properties
  2020-09-18  5:48 ` Vaittinen, Matti
@ 2020-09-18  6:58   ` Krzysztof Kozlowski
  0 siblings, 0 replies; 7+ messages in thread
From: Krzysztof Kozlowski @ 2020-09-18  6:58 UTC (permalink / raw)
  To: Vaittinen, Matti; +Cc: robh+dt, devicetree, linux-kernel, lee.jones

On Fri, 18 Sep 2020 at 07:48, Vaittinen, Matti
<Matti.Vaittinen@fi.rohmeurope.com> wrote:
>
> Hi deeee Ho peeps!
>
> On Thu, 2020-09-17 at 21:37 +0200, Krzysztof Kozlowski wrote:
> > Add common properties appearing in DTSes (clock-names,
> > clock-output-names) with the common values (actually used in DTSes)
> > to
> > fix dtbs_check warnings like:
> >
> >   arch/arm64/boot/dts/freescale/imx8mq-librem5-r2.dt.yaml:
> >     pmic@4b: 'clock-names', 'clock-output-names', do not match any of
> > the regexes: 'pinctrl-[0-9]+'
> >
> > Signed-off-by: Krzysztof Kozlowski <krzk@kernel.org>
> >
> > ---
> >
> > Changes since v1:
> > 1. Define the names, as used in existing DTS files.
> > ---
> >  .../devicetree/bindings/mfd/rohm,bd71837-pmic.yaml          | 6
> > ++++++
> >  1 file changed, 6 insertions(+)
> >
> > diff --git a/Documentation/devicetree/bindings/mfd/rohm,bd71837-
> > pmic.yaml b/Documentation/devicetree/bindings/mfd/rohm,bd71837-
> > pmic.yaml
> > index 65018a019e1d..3bfdd33702ad 100644
> > --- a/Documentation/devicetree/bindings/mfd/rohm,bd71837-pmic.yaml
> > +++ b/Documentation/devicetree/bindings/mfd/rohm,bd71837-pmic.yaml
> > @@ -32,9 +32,15 @@ properties:
> >    clocks:
> >      maxItems: 1
> >
> > +  clock-names:
> > +    const: osc
>
> I guess existing board dtses use "osc" then? Ok.

Yes.

>
> >    "#clock-cells":
> >      const: 0
> >
> > +  clock-output-names:
> > +    const: pmic_clk
>
> This is not a strong opinion but I feel that pmic_clk is a bit too
> generic name? I mean, what if there is a system with more than one
> PMICs? (I don't see such use-case with the BD718x7 though - but perhaps
> this can serve as a misleading example for other PMICs?

I don't expect two PMICs. Sometimes secondary device is added with few
regulators, e.g. a MUIC. Still only one device can supply the CPU and
probably this would be called PMIC.

> For example
> with the ROHM BD96801 family there may be multiple PMICs in one
> system). Anyways - if Rob is happy with this then please go with it :)

The name was taken from existing DTS files. That was Rob's idea as well.

Best regards,
Krzysztof

>
> Acked-By: Matti Vaittinen <matti.vaittinen@fi.rohmeurope.com>
>  *
> Thanks again for improving these bindings! I am constantly struggling
> with these x_x. Writing the bindings is probably hardest part of PMIC
> driver development -_-;
>
>

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PATCH v2] dt-bindings: mfd: rohm,bd71837-pmic: Add common properties
  2020-09-17 19:37 [PATCH v2] dt-bindings: mfd: rohm,bd71837-pmic: Add common properties Krzysztof Kozlowski
  2020-09-18  5:48 ` Vaittinen, Matti
@ 2020-09-23 20:32 ` Rob Herring
  2020-10-02 16:13 ` Krzysztof Kozlowski
  2020-11-04 15:19 ` Lee Jones
  3 siblings, 0 replies; 7+ messages in thread
From: Rob Herring @ 2020-09-23 20:32 UTC (permalink / raw)
  To: Krzysztof Kozlowski
  Cc: devicetree, Matti Vaittinen, linux-kernel, Rob Herring, Lee Jones

On Thu, 17 Sep 2020 21:37:54 +0200, Krzysztof Kozlowski wrote:
> Add common properties appearing in DTSes (clock-names,
> clock-output-names) with the common values (actually used in DTSes) to
> fix dtbs_check warnings like:
> 
>   arch/arm64/boot/dts/freescale/imx8mq-librem5-r2.dt.yaml:
>     pmic@4b: 'clock-names', 'clock-output-names', do not match any of the regexes: 'pinctrl-[0-9]+'
> 
> Signed-off-by: Krzysztof Kozlowski <krzk@kernel.org>
> 
> ---
> 
> Changes since v1:
> 1. Define the names, as used in existing DTS files.
> ---
>  .../devicetree/bindings/mfd/rohm,bd71837-pmic.yaml          | 6 ++++++
>  1 file changed, 6 insertions(+)
> 

Reviewed-by: Rob Herring <robh@kernel.org>

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PATCH v2] dt-bindings: mfd: rohm,bd71837-pmic: Add common properties
  2020-09-17 19:37 [PATCH v2] dt-bindings: mfd: rohm,bd71837-pmic: Add common properties Krzysztof Kozlowski
  2020-09-18  5:48 ` Vaittinen, Matti
  2020-09-23 20:32 ` Rob Herring
@ 2020-10-02 16:13 ` Krzysztof Kozlowski
  2020-10-05  8:13   ` Lee Jones
  2020-11-04 15:19 ` Lee Jones
  3 siblings, 1 reply; 7+ messages in thread
From: Krzysztof Kozlowski @ 2020-10-02 16:13 UTC (permalink / raw)
  To: Lee Jones; +Cc: Rob Herring, Matti Vaittinen, devicetree, linux-kernel

On Thu, Sep 17, 2020 at 09:37:54PM +0200, Krzysztof Kozlowski wrote:
> Add common properties appearing in DTSes (clock-names,
> clock-output-names) with the common values (actually used in DTSes) to
> fix dtbs_check warnings like:
> 
>   arch/arm64/boot/dts/freescale/imx8mq-librem5-r2.dt.yaml:
>     pmic@4b: 'clock-names', 'clock-output-names', do not match any of the regexes: 'pinctrl-[0-9]+'
> 
> Signed-off-by: Krzysztof Kozlowski <krzk@kernel.org>
> 
> ---
> 
> Changes since v1:
> 1. Define the names, as used in existing DTS files.
> ---
>  .../devicetree/bindings/mfd/rohm,bd71837-pmic.yaml          | 6 ++++++
>  1 file changed, 6 insertions(+)

Dear Lee,

Could you take it via MFD tree? There is a review from Rob and ack from
author (Matti).

Best regards,
Krzysztof

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PATCH v2] dt-bindings: mfd: rohm,bd71837-pmic: Add common properties
  2020-10-02 16:13 ` Krzysztof Kozlowski
@ 2020-10-05  8:13   ` Lee Jones
  0 siblings, 0 replies; 7+ messages in thread
From: Lee Jones @ 2020-10-05  8:13 UTC (permalink / raw)
  To: Krzysztof Kozlowski
  Cc: Rob Herring, Matti Vaittinen, devicetree, linux-kernel

On Fri, 02 Oct 2020, Krzysztof Kozlowski wrote:

> On Thu, Sep 17, 2020 at 09:37:54PM +0200, Krzysztof Kozlowski wrote:
> > Add common properties appearing in DTSes (clock-names,
> > clock-output-names) with the common values (actually used in DTSes) to
> > fix dtbs_check warnings like:
> > 
> >   arch/arm64/boot/dts/freescale/imx8mq-librem5-r2.dt.yaml:
> >     pmic@4b: 'clock-names', 'clock-output-names', do not match any of the regexes: 'pinctrl-[0-9]+'
> > 
> > Signed-off-by: Krzysztof Kozlowski <krzk@kernel.org>
> > 
> > ---
> > 
> > Changes since v1:
> > 1. Define the names, as used in existing DTS files.
> > ---
> >  .../devicetree/bindings/mfd/rohm,bd71837-pmic.yaml          | 6 ++++++
> >  1 file changed, 6 insertions(+)
> 
> Dear Lee,
> 
> Could you take it via MFD tree? There is a review from Rob and ack from
> author (Matti).

I don't usually take patches this late in the cycle.

-- 
Lee Jones [李琼斯]
Senior Technical Lead - Developer Services
Linaro.org │ Open source software for Arm SoCs
Follow Linaro: Facebook | Twitter | Blog

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PATCH v2] dt-bindings: mfd: rohm,bd71837-pmic: Add common properties
  2020-09-17 19:37 [PATCH v2] dt-bindings: mfd: rohm,bd71837-pmic: Add common properties Krzysztof Kozlowski
                   ` (2 preceding siblings ...)
  2020-10-02 16:13 ` Krzysztof Kozlowski
@ 2020-11-04 15:19 ` Lee Jones
  3 siblings, 0 replies; 7+ messages in thread
From: Lee Jones @ 2020-11-04 15:19 UTC (permalink / raw)
  To: Krzysztof Kozlowski
  Cc: Rob Herring, Matti Vaittinen, devicetree, linux-kernel

On Thu, 17 Sep 2020, Krzysztof Kozlowski wrote:

> Add common properties appearing in DTSes (clock-names,
> clock-output-names) with the common values (actually used in DTSes) to
> fix dtbs_check warnings like:
> 
>   arch/arm64/boot/dts/freescale/imx8mq-librem5-r2.dt.yaml:
>     pmic@4b: 'clock-names', 'clock-output-names', do not match any of the regexes: 'pinctrl-[0-9]+'
> 
> Signed-off-by: Krzysztof Kozlowski <krzk@kernel.org>
> 
> ---
> 
> Changes since v1:
> 1. Define the names, as used in existing DTS files.
> ---
>  .../devicetree/bindings/mfd/rohm,bd71837-pmic.yaml          | 6 ++++++
>  1 file changed, 6 insertions(+)

Applied, thanks.

-- 
Lee Jones [李琼斯]
Senior Technical Lead - Developer Services
Linaro.org │ Open source software for Arm SoCs
Follow Linaro: Facebook | Twitter | Blog

^ permalink raw reply	[flat|nested] 7+ messages in thread

end of thread, other threads:[~2020-11-04 15:19 UTC | newest]

Thread overview: 7+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-09-17 19:37 [PATCH v2] dt-bindings: mfd: rohm,bd71837-pmic: Add common properties Krzysztof Kozlowski
2020-09-18  5:48 ` Vaittinen, Matti
2020-09-18  6:58   ` Krzysztof Kozlowski
2020-09-23 20:32 ` Rob Herring
2020-10-02 16:13 ` Krzysztof Kozlowski
2020-10-05  8:13   ` Lee Jones
2020-11-04 15:19 ` Lee Jones

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).