devicetree.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Andy Shevchenko <andy.shevchenko@gmail.com>
To: Michael Walle <michael@walle.cc>
Cc: Andy Shevchenko <andriy.shevchenko@linux.intel.com>,
	"Rafael J. Wysocki" <rafael@kernel.org>,
	Rob Herring <robh+dt@kernel.org>,
	Krzysztof Kozlowski <krzysztof.kozlowski+dt@linaro.org>,
	ACPI Devel Maling List <linux-acpi@vger.kernel.org>,
	devicetree <devicetree@vger.kernel.org>,
	Linux Kernel Mailing List <linux-kernel@vger.kernel.org>
Subject: Re: fwnode_for_each_child_node() and OF backend discrepancy
Date: Tue, 28 Jun 2022 15:29:13 +0200	[thread overview]
Message-ID: <CAHp75VcANMjxgS6S24Zh+mz66usb6LBnQk-ENvU9JHSXXsG1DA@mail.gmail.com> (raw)
In-Reply-To: <2f2d7685e0e43194270a310034004970@walle.cc>

On Tue, Jun 28, 2022 at 3:23 PM Michael Walle <michael@walle.cc> wrote:
>
> >> I was trying to fix the lan966x driver [1] which doesn't work if there
> >> are disabled nodes in between.
> >
> > Can you elaborate what's wrong now in the behaviour of the driver? In
> > the code it uses twice the _available variant.
>
> Imagine the following device tree snippet:
>   port0 {
>     reg = <0>;
>     status = "okay";
>   }
>   port1 {
>     reg = <1>;
>     status = "disabled";
>   }
>   port@2 {
>     reg = <2>;
>     status = "okay";
>   }
>
> The driver will set num_phys_ports to 2. When port@2 is probed, it
> will have the (correct!) physical port number 2. That will then
> trigger various EINVAL checks with "port_num >= num_phys_ports" or
> WARN()s.

It means the above mentioned condition is wrong: it should be

"port_idx >= num_phys_ports" (if the port_idx doesn't exists, that's
the bug in the first place)

> So the easiest fix would be to actual count all the child nodes
> (regardless if they are available or not), assuming there are as
> many nodes as physical ports.
>
> But num_phys_ports being a property of the hardware

So, name is wrong, that's how I read it, it should be
num_of_acrive_phys_ports (or alike).

> I don't
> think it's good to deduce it by counting the child nodes anyway,

Right.

> but it should rather be a (hardcoded) property of the driver.

Also good to update.

> [1]
> https://elixir.bootlin.com/linux/v5.19-rc4/source/drivers/net/ethernet/microchip/lan966x/lan966x_main.c

-- 
With Best Regards,
Andy Shevchenko

  reply	other threads:[~2022-06-28 13:31 UTC|newest]

Thread overview: 26+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-06-27 12:49 fwnode_for_each_child_node() and OF backend discrepancy Michael Walle
2022-06-27 13:08 ` Krzysztof Kozlowski
2022-06-27 13:33   ` Rafael J. Wysocki
2022-06-28 10:32     ` Krzysztof Kozlowski
2022-06-28 14:41       ` Sakari Ailus
2022-06-29 10:50       ` Rafael J. Wysocki
2022-06-29 13:01         ` Grant Likely
2022-06-28 11:10 ` Andy Shevchenko
2022-06-28 11:36   ` Michael Walle
2022-06-28 13:11     ` Andy Shevchenko
2022-06-28 13:23       ` Michael Walle
2022-06-28 13:29         ` Andy Shevchenko [this message]
2022-06-28 13:47           ` Michael Walle
2022-06-28 13:51             ` Krzysztof Kozlowski
2022-06-28 14:22               ` Michael Walle
2022-06-28 14:36                 ` Krzysztof Kozlowski
2022-06-28 15:09                   ` Michael Walle
2022-06-28 15:17                     ` Krzysztof Kozlowski
2022-06-28 20:28                       ` Andy Shevchenko
2022-06-28 20:52                         ` Horatiu Vultur
2022-06-28 21:07                           ` Michael Walle
2022-06-30 20:16                             ` Horatiu Vultur
2022-06-30 21:00                               ` Michael Walle
2022-06-30 21:21                                 ` Vladimir Oltean
2022-06-30 21:32                                   ` Michael Walle
2022-06-28 21:59             ` Vladimir Oltean

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=CAHp75VcANMjxgS6S24Zh+mz66usb6LBnQk-ENvU9JHSXXsG1DA@mail.gmail.com \
    --to=andy.shevchenko@gmail.com \
    --cc=andriy.shevchenko@linux.intel.com \
    --cc=devicetree@vger.kernel.org \
    --cc=krzysztof.kozlowski+dt@linaro.org \
    --cc=linux-acpi@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=michael@walle.cc \
    --cc=rafael@kernel.org \
    --cc=robh+dt@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).