From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-6.8 required=3.0 tests=HEADER_FROM_DIFFERENT_DOMAINS, INCLUDES_PATCH,MAILING_LIST_MULTI,SIGNED_OFF_BY,SPF_HELO_NONE,SPF_PASS autolearn=unavailable autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id 6ECF0C2BA83 for ; Fri, 14 Feb 2020 17:51:15 +0000 (UTC) Received: from vger.kernel.org (vger.kernel.org [209.132.180.67]) by mail.kernel.org (Postfix) with ESMTP id 5430A206D7 for ; Fri, 14 Feb 2020 17:51:15 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S2388139AbgBNRvO (ORCPT ); Fri, 14 Feb 2020 12:51:14 -0500 Received: from iolanthe.rowland.org ([192.131.102.54]:39854 "HELO iolanthe.rowland.org" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with SMTP id S2388754AbgBNP66 (ORCPT ); Fri, 14 Feb 2020 10:58:58 -0500 Received: (qmail 3236 invoked by uid 2102); 14 Feb 2020 10:58:57 -0500 Received: from localhost (sendmail-bs@127.0.0.1) by localhost with SMTP; 14 Feb 2020 10:58:57 -0500 Date: Fri, 14 Feb 2020 10:58:57 -0500 (EST) From: Alan Stern X-X-Sender: stern@iolanthe.rowland.org To: Boqun Feng cc: linux-kernel@vger.kernel.org, Andrea Parri , Will Deacon , Peter Zijlstra , Nicholas Piggin , David Howells , Jade Alglave , Luc Maranget , "Paul E. McKenney" , Akira Yokosawa , Daniel Lustig , Jonathan Corbet , , Subject: Re: [RFC 3/3] tools/memory-model: Add litmus test for RMW + smp_mb__after_atomic() In-Reply-To: <20200214040132.91934-4-boqun.feng@gmail.com> Message-ID: MIME-Version: 1.0 Content-Type: TEXT/PLAIN; charset=US-ASCII Sender: linux-doc-owner@vger.kernel.org Precedence: bulk List-ID: X-Mailing-List: linux-doc@vger.kernel.org On Fri, 14 Feb 2020, Boqun Feng wrote: > We already use a litmus test in atomic_t.txt to describe atomic RMW + > smp_mb__after_atomic() is "strong acquire" (both the read and the write > part is ordered). "strong acquire" is not an appropriate description -- there is no such thing as a strong acquire in the LKMM -- nor is it a good name for the litmus test. A better description would be "stronger than acquire", as in the sentence preceding the litmus test in atomic_t.txt. > So make it a litmus test in memory-model litmus-tests > directory, so that people can access the litmus easily. > > Additionally, change the processor numbers "P1, P2" to "P0, P1" in > atomic_t.txt for the consistency with the processor numbers in the > litmus test, which herd can handle. > > Signed-off-by: Boqun Feng > --- > Documentation/atomic_t.txt | 6 ++-- > ...+mb__after_atomic-is-strong-acquire.litmus | 29 +++++++++++++++++++ > tools/memory-model/litmus-tests/README | 5 ++++ > 3 files changed, 37 insertions(+), 3 deletions(-) > create mode 100644 tools/memory-model/litmus-tests/Atomic-RMW+mb__after_atomic-is-strong-acquire.litmus > > diff --git a/Documentation/atomic_t.txt b/Documentation/atomic_t.txt > index ceb85ada378e..e3ad4e4cd9ed 100644 > --- a/Documentation/atomic_t.txt > +++ b/Documentation/atomic_t.txt > @@ -238,14 +238,14 @@ strictly stronger than ACQUIRE. As illustrated: > { > } > > - P1(int *x, atomic_t *y) > + P0(int *x, atomic_t *y) > { > r0 = READ_ONCE(*x); > smp_rmb(); > r1 = atomic_read(y); > } > > - P2(int *x, atomic_t *y) > + P1(int *x, atomic_t *y) > { > atomic_inc(y); > smp_mb__after_atomic(); > @@ -260,7 +260,7 @@ This should not happen; but a hypothetical atomic_inc_acquire() -- > because it would not order the W part of the RMW against the following > WRITE_ONCE. Thus: > > - P1 P2 > + P0 P1 > > t = LL.acq *y (0) > t++; > diff --git a/tools/memory-model/litmus-tests/Atomic-RMW+mb__after_atomic-is-strong-acquire.litmus b/tools/memory-model/litmus-tests/Atomic-RMW+mb__after_atomic-is-strong-acquire.litmus > new file mode 100644 > index 000000000000..e7216cf9d92a > --- /dev/null > +++ b/tools/memory-model/litmus-tests/Atomic-RMW+mb__after_atomic-is-strong-acquire.litmus > @@ -0,0 +1,29 @@ > +C Atomic-RMW+mb__after_atomic-is-strong-acquire > + > +(* > + * Result: Never > + * > + * Test of an atomic RMW followed by a smp_mb__after_atomic() is s/Test of/Test that/ > + * "strong-acquire": both the read and write part of the RMW is ordered before This should say "stronger than a normal acquire". And "part" should be "parts", and "is ordered" should be "are ordered". Also, please try to arrange the line breaks so that the comment lines don't have vastly different lengths. Similar changes should be made for the text added to README. Alan Stern