linux-edac.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Robert Richter <rric@kernel.org>
To: "Hawa, Hanna" <hhhawa@amazon.com>
Cc: thor.thayer@linux.intel.com, bp@alien8.de, mchehab@kernel.org,
	james.morse@arm.com, morbidrsa@gmail.com, ralf@linux-mips.org,
	david.daney@cavium.com, andy.gross@linaro.org,
	david.brown@linaro.org, ckadabi@codeaurora.org,
	vnkgutta@codeaurora.org, jglauber@cavium.com,
	khuong@os.amperecomputing.com, dwmw@amazon.co.uk,
	benh@amazon.com, ronenk@amazon.com, talel@amazon.com,
	jonnyc@amazon.com, hanochu@amazon.com,
	linux-edac@vger.kernel.org, linux-kernel@vger.kernel.org,
	linux-mips@vger.kernel.org, linux-arm-msm@vger.kernel.org
Subject: Re: [RFC 1/1] edac: Add a counter parameter for edac_device_handle_ue/ce()
Date: Thu, 1 Aug 2019 16:17:01 +0200	[thread overview]
Message-ID: <20190801141701.bmcken464mrqwhdg@rric.localdomain> (raw)
In-Reply-To: <7d6aac9e-20e5-3901-a423-d76ac917b251@amazon.com>

On 01.08.19 15:29:03, Hawa, Hanna wrote:
> On 8/1/2019 2:35 PM, Robert Richter wrote:
> > On 15.07.19 13:53:07, Hanna Hawa wrote:
> > > Add a counter parameter in order to avoid losing errors count for edac
> > > device, the error count reports the number of errors reported by an edac
> > > device similar to the way MC_EDAC do.
> > > 
> > > Signed-off-by: Hanna Hawa <hhhawa@amazon.com>
> > > ---
> > >   drivers/edac/altera_edac.c      | 20 ++++++++++++--------
> > >   drivers/edac/amd8111_edac.c     |  6 +++---
> > >   drivers/edac/cpc925_edac.c      |  4 ++--
> > >   drivers/edac/edac_device.c      | 18 ++++++++++--------
> > >   drivers/edac/edac_device.h      |  8 ++++++--
> > >   drivers/edac/highbank_l2_edac.c |  4 ++--
> > >   drivers/edac/mpc85xx_edac.c     |  4 ++--
> > >   drivers/edac/mv64x60_edac.c     |  4 ++--
> > >   drivers/edac/octeon_edac-l2c.c  | 20 ++++++++++----------
> > >   drivers/edac/octeon_edac-pc.c   |  6 +++---
> > >   drivers/edac/qcom_edac.c        |  8 ++++----
> > >   drivers/edac/thunderx_edac.c    | 10 +++++-----
> > >   drivers/edac/xgene_edac.c       | 26 +++++++++++++-------------
> > >   13 files changed, 74 insertions(+), 64 deletions(-)
> > 
> > > diff --git a/drivers/edac/edac_device.h b/drivers/edac/edac_device.h
> > > index 1aaba74..cf1a1da 100644
> > > --- a/drivers/edac/edac_device.h
> > > +++ b/drivers/edac/edac_device.h
> > > @@ -290,23 +290,27 @@ extern struct edac_device_ctl_info *edac_device_del_device(struct device *dev);
> > >    *	perform a common output and handling of an 'edac_dev' UE event
> > >    *
> > >    * @edac_dev: pointer to struct &edac_device_ctl_info
> > > + * @error_count: number of errors of the same type
> > >    * @inst_nr: number of the instance where the UE error happened
> > >    * @block_nr: number of the block where the UE error happened
> > >    * @msg: message to be printed
> > >    */
> > >   extern void edac_device_handle_ue(struct edac_device_ctl_info *edac_dev,
> > > -				int inst_nr, int block_nr, const char *msg);
> > > +				  u16 error_count, int inst_nr, int block_nr,
> > > +				  const char *msg);
> > >   /**
> > >    * edac_device_handle_ce():
> > >    *	perform a common output and handling of an 'edac_dev' CE event
> > >    *
> > >    * @edac_dev: pointer to struct &edac_device_ctl_info
> > > + * @error_count: number of errors of the same type
> > >    * @inst_nr: number of the instance where the CE error happened
> > >    * @block_nr: number of the block where the CE error happened
> > >    * @msg: message to be printed
> > >    */
> > >   extern void edac_device_handle_ce(struct edac_device_ctl_info *edac_dev,
> > 
> > How about renaming this to __edac_device_handle_ce() and then have 2
> > macros for:
> > 
> >   * edac_device_handle_ce() to keep old i/f.
> > 
> >   * edac_device_handle_ce_count(), with count parameter added.
> > 
> > Same for uncorrectable errors.
> > 
> > Code of other driver can be kept as it is then.
> 
> Don't you think it'll be confused to have different APIs between EDAC_MC and
> EDAC_DEVICE?
> (in MC the count passed as part of edac_mc_handle_error())

I don't think edac_mc_handle_error() with 11 function arguments is a
good reference for somethin we want to adopt. For the majority of
drivers you just introduce another useless argument with the following
pattern:

	edac_device_handle_ce(edac_dev, 1, 0, 0, edac_dev_name);

IMO, the api should be improved when touching it.

-Robert

  reply	other threads:[~2019-08-01 14:17 UTC|newest]

Thread overview: 9+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-07-15 10:53 [RFC 1/1] edac: Add a counter parameter for edac_device_handle_ue/ce() Hanna Hawa
2019-07-17 12:06 ` Jan Glauber
2019-07-17 14:45   ` Hawa, Hanna
2019-07-25 18:36 ` Mauro Carvalho Chehab
2019-07-28  9:34   ` [UNVERIFIED SENDER] " Hawa, Hanna
2019-08-01 11:35 ` Robert Richter
2019-08-01 12:29   ` Hawa, Hanna
2019-08-01 14:17     ` Robert Richter [this message]
2019-08-01 14:30       ` Hawa, Hanna

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20190801141701.bmcken464mrqwhdg@rric.localdomain \
    --to=rric@kernel.org \
    --cc=andy.gross@linaro.org \
    --cc=benh@amazon.com \
    --cc=bp@alien8.de \
    --cc=ckadabi@codeaurora.org \
    --cc=david.brown@linaro.org \
    --cc=david.daney@cavium.com \
    --cc=dwmw@amazon.co.uk \
    --cc=hanochu@amazon.com \
    --cc=hhhawa@amazon.com \
    --cc=james.morse@arm.com \
    --cc=jglauber@cavium.com \
    --cc=jonnyc@amazon.com \
    --cc=khuong@os.amperecomputing.com \
    --cc=linux-arm-msm@vger.kernel.org \
    --cc=linux-edac@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mips@vger.kernel.org \
    --cc=mchehab@kernel.org \
    --cc=morbidrsa@gmail.com \
    --cc=ralf@linux-mips.org \
    --cc=ronenk@amazon.com \
    --cc=talel@amazon.com \
    --cc=thor.thayer@linux.intel.com \
    --cc=vnkgutta@codeaurora.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).