linux-efi.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH 0/9] crypto: sha256 - Merge crypto/sha256.h into crypto/sha.h
@ 2019-09-01 20:35 Hans de Goede
  2019-09-01 20:35 ` [PATCH 1/9] crypto: arm - Rename functions to avoid conflict with crypto/sha256.h Hans de Goede
                   ` (10 more replies)
  0 siblings, 11 replies; 15+ messages in thread
From: Hans de Goede @ 2019-09-01 20:35 UTC (permalink / raw)
  To: Herbert Xu, David S . Miller, Thomas Gleixner, Ingo Molnar,
	Borislav Petkov, H . Peter Anvin, Heiko Carstens, Vasily Gorbik,
	Christian Borntraeger, Russell King, Catalin Marinas,
	Will Deacon, Gilad Ben-Yossef, Atul Gupta
  Cc: Hans de Goede, Marc Zyngier, Eric Biggers, Andy Lutomirski,
	Ard Biesheuvel, linux-crypto, x86, linux-s390, linux-efi,
	linux-kernel, linux-arm-kernel

Hi All,

As promised here is a follow-up series to my earlier sha256 series.

Note I have only compiled and tested this series on x86_64 !! 

All changes to architecture specific code on other archs have not even
been tested to compile! With that said most of these changes were done
using my editors search - replace function so things should be fine...
(and FWIW I did do a Kconfig hack to compile test the ccree change).

The first patch in this series rename various file local functions /
arrays to avoid conflicts with the new include/crypto/sha256.h, followed
by a patch merging include/crypto/sha256.h into include/crypto/sha.h.

The last patch makes use of this merging to remove a bit more code
duplication, making sha256_generic use sha256_init and sha224_init from
lib/crypto/sha256.c. An added advantage of this, is that this gives these
2 functions coverage by the crypto selftests.

Regards,

Hans


^ permalink raw reply	[flat|nested] 15+ messages in thread

end of thread, other threads:[~2019-09-05  4:56 UTC | newest]

Thread overview: 15+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-09-01 20:35 [PATCH 0/9] crypto: sha256 - Merge crypto/sha256.h into crypto/sha.h Hans de Goede
2019-09-01 20:35 ` [PATCH 1/9] crypto: arm - Rename functions to avoid conflict with crypto/sha256.h Hans de Goede
2019-09-01 20:35 ` [PATCH 2/9] crypto: arm64 " Hans de Goede
2019-09-01 20:35 ` [PATCH 3/9] crypto: s390 " Hans de Goede
2019-09-01 20:35 ` [PATCH 4/9] crypto: x86 " Hans de Goede
2019-09-01 20:35 ` [PATCH 5/9] crypto: ccree - Rename arrays " Hans de Goede
2019-09-03  7:45   ` Gilad Ben-Yossef
2019-09-03  7:51     ` Hans de Goede
2019-09-03  7:59       ` Gilad Ben-Yossef
2019-09-01 20:35 ` [PATCH 6/9] crypto: chelsio " Hans de Goede
2019-09-01 20:35 ` [PATCH 7/9] crypto: n2 " Hans de Goede
2019-09-01 20:35 ` [PATCH 8/9] crypto: sha256 - Merge crypto/sha256.h into crypto/sha.h Hans de Goede
2019-09-01 20:35 ` [PATCH 9/9] crypto: sha256 - Remove sha256/224_init code duplication Hans de Goede
2019-09-04 13:02 ` [PATCH 0/9] crypto: sha256 - Merge crypto/sha256.h into crypto/sha.h Ard Biesheuvel
2019-09-05  4:55 ` Herbert Xu

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).