linux-efi.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-03-15 01:32:08 to 2020-04-09 11:32:20 UTC [more...]

[GIT PULL 00/13] More EFI updates for v5.6
 2020-04-09 11:32 UTC  (17+ messages)
` [PATCH 05/13] efi/x86: don't map the entire kernel text RW for mixed mode

[PATCH] x86/efi: Add a prototype for efi_arch_mem_reserve()
 2020-04-09  7:13 UTC  (4+ messages)

[efi:urgent] BUILD SUCCESS f5356a8c201bf2dfa3783b3894f31f8e96f94624
 2020-04-09  1:43 UTC 

[PATCH] efi/x86: Fix the deletion of variables in mixed mode
 2020-04-08  8:20 UTC  (2+ messages)

[PATCH 1/2] x86/boot/compressed/64: Remove .bss/.pgtable from bzImage
 2020-04-08  7:49 UTC  (22+ messages)
                            ` [PATCH 1/2] efi/x86: Move efi stub globals from .bss to .data
                              ` [PATCH 2/2] efi/x86: Always relocate the kernel for EFI handover entry

[PATCH] Documentation: efi/x86: clarify EFI handover protocol and its requirements
 2020-04-07 16:27 UTC  (4+ messages)

[PATCH] efi/libstub/file: merge filename buffers to reduce stack usage
 2020-04-07 15:56 UTC 

[PATCH] efi/libstub/arm64: avoid image_base value from efi_loaded_image
 2020-04-07  8:07 UTC  (13+ messages)

[efi:urgent] BUILD SUCCESS 33da38529f13f938a73107aa2dc7c3b4e786967a
 2020-04-03 23:01 UTC 

[PATCH] efi/libstub/x86: remove redundant assignment to pointer hdr
 2020-04-02 12:31 UTC  (2+ messages)

[PATCH v1 0/5] Add fw_devlink kernel commandline option
 2020-03-31 17:10 UTC  (4+ messages)
` [PATCH v1 5/5] of: property: Delete of_devlink "

[GIT PULL] EFI changes for v5.7
 2020-03-31  0:25 UTC  (2+ messages)

[efi:next] BUILD SUCCESS a7a39e7e9249f2c47245d87fa0e86c874c0eb69f
 2020-03-29 17:17 UTC 

[GIT PULL 0/2] EFI touchups for v5.7
 2020-03-29 10:08 UTC  (4+ messages)
` [PATCH 1/2] efi/libstub/arm64: avoid image_base value from efi_loaded_image
` [PATCH 2/2] efi/libstub/arm: fix spurious message that an initrd was loaded

[PATCH 00/14] efi/gop: Refactoring + mode-setting feature
 2020-03-29  7:47 UTC  (46+ messages)
` [PATCH 01/14] efi/gop: Remove redundant current_fb_base
` [PATCH 02/14] efi/gop: Move check for framebuffer before con_out
` [PATCH 03/14] efi/gop: Get mode information outside the loop
` [PATCH 04/14] efi/gop: Factor out locating the gop into a function
` [PATCH 05/14] efi/gop: Slightly re-arrange logic of find_gop
` [PATCH 06/14] efi/gop: Move variable declarations into loop block
` [PATCH 07/14] efi/gop: Use helper macros for populating lfb_base
` [PATCH 08/14] efi/gop: Use helper macros for find_bits
` [PATCH 09/14] efi/gop: Remove unreachable code from setup_pixel_info
` [PATCH 10/14] efi/gop: Add prototypes for query_mode and set_mode
` [PATCH 11/14] efi/gop: Allow specifying mode number on command line
` [PATCH 12/14] efi/gop: Allow specifying mode by <xres>x<yres>
` [PATCH 13/14] efi/gop: Allow specifying depth as well as resolution
` [PATCH 14/14] efi/gop: Allow automatically choosing the best mode
` [PATCH v2 00/14] efi/gop: Refactoring + mode-setting feature
          ` efi/gop: skip cur_mode in choose_mode_auto
            ` [PATCH v3] efi/gop: Allow automatically choosing the best mode
` [PATCH v2 01/14] efi/gop: Remove redundant current_fb_base
` [PATCH v2 02/14] efi/gop: Move check for framebuffer before con_out
` [PATCH v2 03/14] efi/gop: Get mode information outside the loop
` [PATCH v2 04/14] efi/gop: Factor out locating the gop into a function
` [PATCH v2 05/14] efi/gop: Slightly re-arrange logic of find_gop
` [PATCH v2 06/14] efi/gop: Move variable declarations into loop block
` [PATCH v2 07/14] efi/gop: Use helper macros for populating lfb_base
` [PATCH v2 08/14] efi/gop: Use helper macros for find_bits
` [PATCH v2 09/14] efi/gop: Remove unreachable code from setup_pixel_info
` [PATCH v2 10/14] efi/gop: Add prototypes for query_mode and set_mode
` [PATCH v2 11/14] efi/gop: Allow specifying mode number on command line
` [PATCH v2 12/14] efi/gop: Allow specifying mode by <xres>x<yres>
` [PATCH v2 13/14] efi/gop: Allow specifying depth as well as resolution
` [PATCH v2 14/14] efi/gop: Allow automatically choosing the best mode

[PATCH 0/2] efi/arm64: execute the kernel in place if possible
 2020-03-28 14:10 UTC  (7+ messages)
` [PATCH 1/2] efi/libstub/arm64: avoid copying the kernel unnecessarily
` [PATCH 2/2] efi/arm64: increase the PE/COFF alignment so the kernel can run in place

[PATCH 0/5] ARM: simplify handover from UEFI to decompressor
 2020-03-27 13:59 UTC  (10+ messages)
` [PATCH 1/5] ARM: decompressor: move headroom variable out of LC0
` [PATCH 2/5] ARM: decompressor: split off _edata and stack base into separate object
` [PATCH 3/5] ARM: decompressor: defer loading of the contents of the LC0 structure
` [PATCH 4/5] ARM: decompressor: move GOT into .data for EFI enabled builds
` [PATCH 5/5] ARM: decompressor: run decompressor in place if loaded via UEFI

[PATCH v6 2/2] eif/capsule-pstore: Add capsule pstore backend
 2020-03-27  6:07 UTC  (6+ messages)

[efi:next] BUILD SUCCESS 7f464c588240add3620dc2080872cc4d44f7d248
 2020-03-26 21:53 UTC 

[PATCH v6 1/2] efi: Add 'nr_config_table' variable in efi structure
 2020-03-25 17:34 UTC  (4+ messages)

[PATCH v6 0/2] Add capsule-pstore backend support
 2020-03-25 17:33 UTC  (9+ messages)

[PATCH] efi/cper: Use scnprintf() for avoiding potential buffer overflow
 2020-03-25 10:13 UTC  (3+ messages)

[PATCH v6 00/10] Subject: Enable Linux guests on Hyper-V on ARM64
 2020-03-20 17:22 UTC  (38+ messages)
` [PATCH v6 01/10] arm64: hyperv: Add core Hyper-V include files
` [PATCH v6 04/10] arm64: hyperv: Add memory alloc/free functions for Hyper-V size pages
` [PATCH v6 05/10] arm64: hyperv: Add interrupt handlers for VMbus and stimer
` [PATCH v6 06/10] arm64: hyperv: Add kexec and panic handlers
` [PATCH v6 07/10] arm64: hyperv: Initialize hypervisor on boot
` [PATCH v6 08/10] Drivers: hv: vmbus: Add hooks for per-CPU IRQ
` [PATCH v6 09/10] arm64: efi: Export screen_info
` [PATCH v6 10/10] Drivers: hv: Enable Hyper-V code to be built on ARM64
  ` [PATCH v6 03/10] arm64: hyperv: Add hypercall and register access functions

[PATCH v12 00/10] efi/firmware/platform-x86: Add EFI embedded fw support
 2020-03-20 16:41 UTC  (8+ messages)
` [PATCH v12 03/10] firmware: Rename FW_OPT_NOFALLBACK to FW_OPT_NOFALLBACK_SYSFS

[PATCH] Revert "x86/reboot, efi: Use EFI reboot for Acer TravelMate X514-51T"
 2020-03-20 13:54 UTC  (7+ messages)

[PATCH 4.19 47/48] efi: Fix debugobjects warning on efi_rts_work
 2020-03-19 13:04 UTC 


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).