linux-erofs.lists.ozlabs.org archive mirror
 help / color / mirror / Atom feed
 messages from 2019-08-21 14:03:27 to 2019-09-02 12:34:58 UTC [more...]

[PATCH v6 00/24] erofs: promote erofs from staging
 2019-09-02 12:31 UTC  (85+ messages)
` [PATCH v6 01/24] erofs: add on-disk layout
` [PATCH v6 03/24] erofs: add super block operations
` [PATCH v6 04/24] erofs: add raw address_space operations
` [PATCH v6 05/24] erofs: add inode operations
` [PATCH v6 06/24] erofs: support special inode
` [PATCH v6 08/24] erofs: add namei functions
` [PATCH 00/21] erofs: patchset addressing Christoph's comments
  ` [PATCH 01/21] erofs: remove all the byte offset comments
  ` [PATCH 02/21] erofs: on-disk format should have explicitly assigned numbers
  ` [PATCH 03/21] erofs: some macros are much more readable as a function
  ` [PATCH 04/21] erofs: kill __packed for on-disk structures
  ` [PATCH 05/21] erofs: update erofs_inode_is_data_compressed helper
  ` [PATCH 06/21] erofs: kill erofs_{init,exit}_inode_cache
  ` [PATCH 07/21] erofs: use erofs_inode naming
  ` [PATCH 08/21] erofs: update comments in inode.c
  ` [PATCH 09/21] erofs: update erofs symlink stuffs
  ` [PATCH 10/21] erofs: kill is_inode_layout_compression()
  ` [PATCH 11/21] erofs: use dsb instead of layout for ondisk super_block
  ` [PATCH 12/21] erofs: kill verbose debug info in erofs_fill_super
  ` [PATCH 13/21] erofs: simplify erofs_grab_bio() since bio_alloc() never fail
  ` [PATCH 14/21] erofs: kill prio and nofail of erofs_get_meta_page()
  ` [PATCH 15/21] erofs: kill __submit_bio()
  ` [PATCH 16/21] erofs: kill magic underscores
  ` [PATCH 17/21] erofs: use a switch statement when dealing with the file modes
  ` [PATCH 18/21] erofs: add "erofs_" prefix for common and short functions
  ` [PATCH 19/21] erofs: kill all erofs specific fault injection
  ` [PATCH 20/21] erofs: kill use_vmap module parameter
  ` [PATCH 21/21] erofs: save one level of indentation

[PATCH v2 1/7] erofs: on-disk format should have explicitly assigned numbers
 2019-08-31 10:57 UTC  (38+ messages)
` [PATCH v2 2/7] erofs: some marcos are much more readable as a function
      ` [PATCH v3 1/7] erofs: on-disk format should have explicitly assigned numbers
        ` [PATCH v3 2/7] erofs: some macros are much more readable as a function
          ` [PATCH v4 "
        ` [PATCH v3 3/7] erofs: use a better form for complicated on-disk fields
        ` [PATCH v3 4/7] erofs: kill __packed for on-disk structures
        ` [PATCH v3 5/7] erofs: kill erofs_{init,exit}_inode_cache
        ` [PATCH v3 6/7] erofs: remove all likely/unlikely annotations
        ` [PATCH v3 7/7] erofs: redundant assignment in __erofs_get_meta_page()
` [PATCH v2 3/7] erofs: use a better form for complicated on-disk fields
` [PATCH v2 4/7] erofs: kill __packed for on-disk structures
` [PATCH v2 5/7] erofs: kill erofs_{init,exit}_inode_cache
` [PATCH v2 6/7] erofs: remove all likely/unlikely annotations
` [PATCH v2 7/7] erofs: reduntant assignment in __erofs_get_meta_page()

[PATCH v8 00/24] erofs: promote erofs from staging v8
 2019-08-30 16:55 UTC  (10+ messages)
` [PATCH v8 20/24] erofs: introduce generic decompression backend
    ` [PATCH v2] erofs: move erofs out of staging

[PATCH] erofs: using switch-case while checking the inode type
 2019-08-30 14:22 UTC  (3+ messages)

[PATCH v8] Add flags option to get xattr method paired to __vfs_getxattr
 2019-08-30  1:24 UTC  (7+ messages)

[PATCH] staging: erofs: using switch-case while checking the inode type
 2019-08-29 18:57 UTC  (8+ messages)

[PATCH] erofs: remove all likely/unlikely annotations
 2019-08-29 17:17 UTC  (2+ messages)
` [PATCH] erofs: reduntant assignment in __erofs_get_meta_page()

[PATCH 1/2] erofs: on-disk format should have explicitly assigned numbers
 2019-08-29 15:22 UTC  (2+ messages)
` [PATCH 2/2] erofs: some marcos are much more readable as a function

[bug report] staging: erofs: introduce erofs_grab_bio
 2019-08-28 12:22 UTC  (7+ messages)

[PATCH v7] Add flags option to get xattr method paired to __vfs_getxattr
 2019-08-28  8:58 UTC  (4+ messages)

[bug report] staging: erofs: tidy up decompression frontend
 2019-08-27 10:46 UTC  (6+ messages)

[PATCH] erofs-utils: fix up "-E legacy-compress" option
 2019-08-26 15:39 UTC  (2+ messages)

[PATCH] erofs-utils: fix a memory leak of compressmeta
 2019-08-26 15:00 UTC  (2+ messages)

[PATCH] erofs: fix compile warnings when moving out include/trace/events/erofs.h
 2019-08-26 14:26 UTC  (4+ messages)
` [PATCH RESEND] "

[PATCH] erofs-utils: code for superblock checksum calculation
 2019-08-24 15:16 UTC  (5+ messages)

[PATCH] erofs-utils: code for superblock checksum calculation
 2019-08-24 10:14 UTC  (7+ messages)

erofs: Question on unused fields in on-disk structs
 2019-08-22 14:38 UTC  (11+ messages)

[PATCH] erofs-utils: erofs debug utility
 2019-08-22  0:09 UTC  (5+ messages)

[PATCH 0/2] Submitting my first patch series (Checkpatch fixes)
 2019-08-21 20:11 UTC  (7+ messages)
` [PATCH 2/2] staging/erofs: Balanced braces around a few conditional statements

[PATCH 5/6] staging: erofs: detect potential multiref due to corrupted images
 2019-08-21 14:24 UTC  (3+ messages)
` [PATCH v2 "


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).