From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-8.6 required=3.0 tests=DKIM_INVALID,DKIM_SIGNED, HEADER_FROM_DIFFERENT_DOMAINS,MAILING_LIST_MULTI,MENTIONS_GIT_HOSTING, SPF_HELO_NONE,SPF_PASS,URIBL_BLOCKED,USER_AGENT_GIT autolearn=unavailable autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id B56BCC4BA1A for ; Tue, 25 Feb 2020 21:49:05 +0000 (UTC) Received: from vger.kernel.org (vger.kernel.org [209.132.180.67]) by mail.kernel.org (Postfix) with ESMTP id 73C212467C for ; Tue, 25 Feb 2020 21:49:05 +0000 (UTC) Authentication-Results: mail.kernel.org; dkim=fail reason="signature verification failed" (2048-bit key) header.d=infradead.org header.i=@infradead.org header.b="jtCxeVx9" Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1729658AbgBYVs5 (ORCPT ); Tue, 25 Feb 2020 16:48:57 -0500 Received: from bombadil.infradead.org ([198.137.202.133]:43664 "EHLO bombadil.infradead.org" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1729540AbgBYVsr (ORCPT ); Tue, 25 Feb 2020 16:48:47 -0500 DKIM-Signature: v=1; a=rsa-sha256; q=dns/txt; c=relaxed/relaxed; d=infradead.org; s=bombadil.20170209; h=Content-Transfer-Encoding: MIME-Version:Message-Id:Date:Subject:Cc:To:From:Sender:Reply-To:Content-Type: Content-ID:Content-Description:In-Reply-To:References; bh=8RN7MTq+5xgiJmwHMp2eMaxo1YxGTO4DUpwlGso361U=; b=jtCxeVx9gVjpI++KcK7HlP1heq nzxHy2KF6q8K3Ero+aE/Du4pG6Z5OEzsfzjWASdx8SMpQMnto1fcBQXB47NLMeizy9ouXnh1Pop02 ZxM9MtlPi+Q/NYNmcfmlEQSWd4RjKZ1zmxWFRRV6n9A9OXLUS4TYCQczXpPjYohL32nLS2z4NIK5i 0j4HkRyr5fd4uKL2Bk5YGQ19IADMd6knu5w+IwrOAZKmwm5UmjM2fKxBgv49R1KKPzr/yLJQ3ev+s 730kwB3XOK8GML4QjyJs/j2Dxk6RQrTZ7zCbqimFW9GgS6DLNzKJxxjSfz50M468hFQGVhV0Pca8O AKzodV9Q==; Received: from willy by bombadil.infradead.org with local (Exim 4.92.3 #3 (Red Hat Linux)) id 1j6i4G-0007pE-TP; Tue, 25 Feb 2020 21:48:40 +0000 From: Matthew Wilcox To: linux-fsdevel@vger.kernel.org Cc: "Matthew Wilcox (Oracle)" , linux-mm@kvack.org, linux-kernel@vger.kernel.org, linux-btrfs@vger.kernel.org, linux-erofs@lists.ozlabs.org, linux-ext4@vger.kernel.org, linux-f2fs-devel@lists.sourceforge.net, cluster-devel@redhat.com, ocfs2-devel@oss.oracle.com, linux-xfs@vger.kernel.org Subject: [PATCH v8 00/25] Change readahead API Date: Tue, 25 Feb 2020 13:48:13 -0800 Message-Id: <20200225214838.30017-1-willy@infradead.org> X-Mailer: git-send-email 2.21.1 MIME-Version: 1.0 Content-Transfer-Encoding: 8bit Sender: linux-ext4-owner@vger.kernel.org Precedence: bulk List-ID: X-Mailing-List: linux-ext4@vger.kernel.org From: "Matthew Wilcox (Oracle)" This series adds a readahead address_space operation to replace the readpages operation. The key difference is that pages are added to the page cache as they are allocated (and then looked up by the filesystem) instead of passing them on a list to the readpages operation and having the filesystem add them to the page cache. It's a net reduction in code for each implementation, more efficient than walking a list, and solves the direct-write vs buffered-read problem reported by yu kuai at https://lore.kernel.org/linux-fsdevel/20200116063601.39201-1-yukuai3@huawei.com/ The only unconverted filesystems are those which use fscache. Their conversion is pending Dave Howells' rewrite which will make the conversion substantially easier. I want to thank the reviewers/testers; Dave Chinner, John Hubbard, Eric Biggers, Johannes Thumshirn, Dave Sterba, Zi Yan and Christoph Hellwig have done a marvellous job of providing constructive criticism. I've tried to take it all on board, but I may have missed something simply because you've done such a thorough job. This series can also be found at http://git.infradead.org/users/willy/linux-dax.git/shortlog/refs/tags/readahead_v8 v8: - btrfs, ext4 and xfs all survive an xfstests run (thanks to Kent Overstreet for providing the ktest framework) - iomap restructuring dropped due to Christoph's opposition and the redesign of readahead_page() meaning it wasn't needed any more. - f2fs_mpage_readpages() made static again - Made iomap_readahead() comment more useful - Added kernel-doc for the entire readahead_control API - Conditionally zero batch_count in readahead_page() (requested by John) - Hold RCU read lock while iterating over the xarray in readahead_page_batch() - Iterate over the correct pages in readahead_page_batch() - Correct the return type of readahead_index() (spotted by Zi Yan) - Added a 'skip_page' parameter to read_pages for better documentation purposes and so we can reuse the readahead_control higher in the call chain in future. - Removed the use_list bool (requested by Christoph) - Removed the explicit initialisation of _nr_pages to 0 (requested by Christoph & John) - Add comments explaining why nr_to_read is being capped (requested by John) - Reshuffled some of the patches: - Split out adding the readahead_control API from the three patches which added it piecemeal - Shift the final two mm patches to be with the other mm patches - Split the f2fs "pass the inode" patch from the "convert to readahead" patch, like ext4 v7: - Now passes an xfstests run on ext4! - Documentation improvements - Move the readahead prototypes out of mm.h (new patch) - readahead_for_each* iterators are gone; replaced with readahead_page() and readahead_page_batch() - page_cache_readahead_limit() renamed to page_cache_readahead_unbounded() and arguments changed - iomap_readahead_actor() restructured differently - The readahead code no longer uses the word 'offset' to reduce ambiguity - read_pages() now maintains the rac so we can just call it and continue instead of mucking around with branches - More assertions - More readahead functions return void v6: - Name the private members of readahead_control with a leading underscore (suggested by Christoph Hellwig) - Fix whitespace in rst file - Remove misleading comment in btrfs patch - Add readahead_next() API and use it in iomap - Add iomap_readahead kerneldoc. - Fix the mpage_readahead kerneldoc - Make various readahead functions return void - Keep readahead_index() and readahead_offset() pointing to the start of this batch through the body. No current user requires this, but it's less surprising. - Add kerneldoc for page_cache_readahead_limit - Make page_idx an unsigned long, and rename it to just 'i' - Get rid of page_offset local variable - Add patch to call memalloc_nofs_save() before allocating pages (suggested by Michal Hocko) - Resplit a lot of patches for more logical progression and easier review (suggested by John Hubbard) - Added sign-offs where received, and I deemed still relevant v5 switched to passing a readahead_control struct (mirroring the writepages_control struct passed to writepages). This has a number of advantages: - It fixes a number of bugs in various implementations, eg forgetting to increment 'start', an off-by-one error in 'nr_pages' or treating 'start' as a byte offset instead of a page offset. - It allows us to change the arguments without changing all the implementations of ->readahead which just call mpage_readahead() or iomap_readahead() - Figuring out which pages haven't been attempted by the implementation is more natural this way. - There's less code in each implementation. Matthew Wilcox (Oracle) (25): mm: Move readahead prototypes from mm.h mm: Return void from various readahead functions mm: Ignore return value of ->readpages mm: Move readahead nr_pages check into read_pages mm: Add new readahead_control API mm: Use readahead_control to pass arguments mm: Rename various 'offset' parameters to 'index' mm: rename readahead loop variable to 'i' mm: Remove 'page_offset' from readahead loop mm: Put readahead pages in cache earlier mm: Add readahead address space operation mm: Move end_index check out of readahead loop mm: Add page_cache_readahead_unbounded mm: Document why we don't set PageReadahead mm: Use memalloc_nofs_save in readahead path fs: Convert mpage_readpages to mpage_readahead btrfs: Convert from readpages to readahead erofs: Convert uncompressed files from readpages to readahead erofs: Convert compressed files from readpages to readahead ext4: Convert from readpages to readahead ext4: Pass the inode to ext4_mpage_readpages f2fs: Convert from readpages to readahead f2fs: Pass the inode to f2fs_mpage_readpages fuse: Convert from readpages to readahead iomap: Convert from readpages to readahead Documentation/filesystems/locking.rst | 6 +- Documentation/filesystems/vfs.rst | 15 ++ block/blk-core.c | 1 + drivers/staging/exfat/exfat_super.c | 7 +- fs/block_dev.c | 7 +- fs/btrfs/extent_io.c | 46 ++--- fs/btrfs/extent_io.h | 3 +- fs/btrfs/inode.c | 16 +- fs/erofs/data.c | 39 ++-- fs/erofs/zdata.c | 29 +-- fs/ext2/inode.c | 10 +- fs/ext4/ext4.h | 5 +- fs/ext4/inode.c | 21 +- fs/ext4/readpage.c | 25 +-- fs/ext4/verity.c | 35 +--- fs/f2fs/data.c | 50 ++--- fs/f2fs/f2fs.h | 3 - fs/f2fs/verity.c | 35 +--- fs/fat/inode.c | 7 +- fs/fuse/file.c | 46 ++--- fs/gfs2/aops.c | 23 +-- fs/hpfs/file.c | 7 +- fs/iomap/buffered-io.c | 92 +++------ fs/iomap/trace.h | 2 +- fs/isofs/inode.c | 7 +- fs/jfs/inode.c | 7 +- fs/mpage.c | 38 +--- fs/nilfs2/inode.c | 15 +- fs/ocfs2/aops.c | 34 ++-- fs/omfs/file.c | 7 +- fs/qnx6/inode.c | 7 +- fs/reiserfs/inode.c | 8 +- fs/udf/inode.c | 7 +- fs/xfs/xfs_aops.c | 13 +- fs/zonefs/super.c | 7 +- include/linux/fs.h | 2 + include/linux/iomap.h | 3 +- include/linux/mm.h | 19 -- include/linux/mpage.h | 4 +- include/linux/pagemap.h | 151 ++++++++++++++ include/trace/events/erofs.h | 6 +- include/trace/events/f2fs.h | 6 +- mm/fadvise.c | 6 +- mm/internal.h | 12 +- mm/migrate.c | 2 +- mm/readahead.c | 278 ++++++++++++++++---------- 46 files changed, 580 insertions(+), 589 deletions(-) base-commit: 11a48a5a18c63fd7621bb050228cebf13566e4d8 -- 2.25.0