linux-fbdev.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Geert Uytterhoeven <geert@linux-m68k.org>
To: Sam Ravnborg <sam@ravnborg.org>
Cc: David Airlie <airlied@linux.ie>, Daniel Vetter <daniel@ffwll.ch>,
	Maxime Ripard <mripard@kernel.org>,
	Linux Fbdev development list <linux-fbdev@vger.kernel.org>,
	Linux Kernel Mailing List <linux-kernel@vger.kernel.org>,
	DRI Development <dri-devel@lists.freedesktop.org>
Subject: Re: [PATCH resend 3/5] video: fbdev: ssd1307fb: Extract ssd1307fb_set_address_range()
Date: Tue, 20 Jul 2021 09:51:32 +0200	[thread overview]
Message-ID: <CAMuHMdUJsLMErGYkr8M3y+yGtVd1YhHAmir2_FEOC7n3=9-yfA@mail.gmail.com> (raw)
In-Reply-To: <YPXNdJNpYoPSpxSb@ravnborg.org>

Hi Sam,

On Mon, Jul 19, 2021 at 9:07 PM Sam Ravnborg <sam@ravnborg.org> wrote:
> On Wed, Jul 14, 2021 at 04:58:02PM +0200, Geert Uytterhoeven wrote:
> > Extract the code to set the column and page ranges into a helper
> > function.
> >
> > Signed-off-by: Geert Uytterhoeven <geert@linux-m68k.org>
> > ---
> >  drivers/video/fbdev/ssd1307fb.c | 61 +++++++++++++++++++--------------
> >  1 file changed, 36 insertions(+), 25 deletions(-)
> >
> > diff --git a/drivers/video/fbdev/ssd1307fb.c b/drivers/video/fbdev/ssd1307fb.c
> > index 6d7bd025bca1a175..cfa27ea0feab4f01 100644
> > --- a/drivers/video/fbdev/ssd1307fb.c
> > +++ b/drivers/video/fbdev/ssd1307fb.c
> > @@ -152,6 +152,38 @@ static inline int ssd1307fb_write_cmd(struct i2c_client *client, u8 cmd)
> >       return ret;
> >  }
> >
> > +static int ssd1307fb_set_address_range(struct ssd1307fb_par *par, u8 col_start,
> > +                                    u8 cols, u8 page_start, u8 pages)
> > +{
> Bikeshedding, but I think a dedicated function for col_range and another
> for page_range had been simpler to read.

I agree.
Originally, before I removed the call during initialization, there were
two calls to this function, so it made sense to have a single function.

> With or wihout this change:
> Acked-by: Sam Ravnborg <sam@ravnborg.org>

Thanks!

Gr{oetje,eeting}s,

                        Geert

-- 
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@linux-m68k.org

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
                                -- Linus Torvalds

  parent reply	other threads:[~2021-07-20  7:53 UTC|newest]

Thread overview: 13+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-07-14 14:57 [PATCH resend 0/5] video: fbdev: ssd1307fb: Optimizations and improvements Geert Uytterhoeven
2021-07-14 14:58 ` [PATCH resend 1/5] video: fbdev: ssd1307fb: Propagate errors via ssd1307fb_update_display() Geert Uytterhoeven
2021-07-14 14:58 ` [PATCH resend 2/5] video: fbdev: ssd1307fb: Simplify ssd1307fb_update_display() Geert Uytterhoeven
     [not found]   ` <YPXM8AXNje7GXf+i@ravnborg.org>
2021-07-20  7:43     ` Geert Uytterhoeven
2021-07-14 14:58 ` [PATCH resend 3/5] video: fbdev: ssd1307fb: Extract ssd1307fb_set_address_range() Geert Uytterhoeven
     [not found]   ` <YPXNdJNpYoPSpxSb@ravnborg.org>
2021-07-20  7:51     ` Geert Uytterhoeven [this message]
2021-07-14 14:58 ` [PATCH resend 4/5] video: fbdev: ssd1307fb: Optimize screen updates Geert Uytterhoeven
     [not found]   ` <YPXQnlpWUa1QaZKd@ravnborg.org>
2021-07-20  7:56     ` Geert Uytterhoeven
2021-07-20  9:16       ` Geert Uytterhoeven
2021-07-14 14:58 ` [PATCH resend 5/5] video: fbdev: ssd1307fb: Cache address ranges Geert Uytterhoeven
     [not found] ` <YO8CT+Hcw1wfhnH5@ravnborg.org>
2021-07-15  6:54   ` [PATCH resend 0/5] video: fbdev: ssd1307fb: Optimizations and improvements Geert Uytterhoeven
2021-07-20 14:53     ` Daniel Vetter
     [not found] ` <YPXRMXQxCW+Agaz8@ravnborg.org>
2021-07-20  7:33   ` Geert Uytterhoeven

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to='CAMuHMdUJsLMErGYkr8M3y+yGtVd1YhHAmir2_FEOC7n3=9-yfA@mail.gmail.com' \
    --to=geert@linux-m68k.org \
    --cc=airlied@linux.ie \
    --cc=daniel@ffwll.ch \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=linux-fbdev@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mripard@kernel.org \
    --cc=sam@ravnborg.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).