linux-fpga.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Russ Weight <russell.h.weight@intel.com>
To: Xu Yilun <yilun.xu@intel.com>
Cc: mdf@kernel.org, linux-fpga@vger.kernel.org, trix@redhat.com,
	lgoncalv@redhat.com, hao.wu@intel.com, matthew.gerlach@intel.com,
	richard.gong@intel.com
Subject: Re: [PATCH v1 1/5] fpga: mgr: Use standard dev_release for class driver
Date: Wed, 9 Jun 2021 08:57:05 -0700	[thread overview]
Message-ID: <0ac3450d-7073-b65c-42ea-38471d1e966a@intel.com> (raw)
In-Reply-To: <20210609152843.GA1994229@yilunxu-OptiPlex-7050>



On 6/9/21 8:28 AM, Xu Yilun wrote:
> On Tue, Jun 08, 2021 at 05:49:21PM -0700, Russ Weight wrote:
>> The FPGA manager class driver data structure is being treated as a
>> managed resource instead of using the class.dev_release call-back
>> function to release the class data structure. This change populates
>> the class.dev_release function, changes the fpga_mgr_free() function
>> to call put_device() and changes the fpga_mgr_unregister() function
>> to call device_del() instead of device_unregister().
>>
>> Signed-off-by: Russ Weight <russell.h.weight@intel.com>
>> ---
>>  drivers/fpga/fpga-mgr.c | 57 +++++++++++++++++++----------------------
>>  1 file changed, 26 insertions(+), 31 deletions(-)
>>
>> diff --git a/drivers/fpga/fpga-mgr.c b/drivers/fpga/fpga-mgr.c
>> index b85bc47c91a9..1a4031c0771e 100644
>> --- a/drivers/fpga/fpga-mgr.c
>> +++ b/drivers/fpga/fpga-mgr.c
>> @@ -551,7 +551,7 @@ EXPORT_SYMBOL_GPL(fpga_mgr_unlock);
>>  
>>  /**
>>   * fpga_mgr_create - create and initialize a FPGA manager struct
>> - * @dev:	fpga manager device from pdev
>> + * @parent:	fpga manager device from pdev
> Could you split the renaming change to a separate patch? 

Sure - I'll split it out.
>
>>   * @name:	fpga manager name
>>   * @mops:	pointer to structure of fpga manager ops
>>   * @priv:	fpga manager private data
>> @@ -561,7 +561,7 @@ EXPORT_SYMBOL_GPL(fpga_mgr_unlock);
>>   *
>>   * Return: pointer to struct fpga_manager or NULL
>>   */
>> -struct fpga_manager *fpga_mgr_create(struct device *dev, const char *name,
>> +struct fpga_manager *fpga_mgr_create(struct device *parent, const char *name,
>>  				     const struct fpga_manager_ops *mops,
>>  				     void *priv)
>>  {
>> @@ -571,12 +571,12 @@ struct fpga_manager *fpga_mgr_create(struct device *dev, const char *name,
>>  	if (!mops || !mops->write_complete || !mops->state ||
>>  	    !mops->write_init || (!mops->write && !mops->write_sg) ||
>>  	    (mops->write && mops->write_sg)) {
>> -		dev_err(dev, "Attempt to register without fpga_manager_ops\n");
>> +		dev_err(parent, "Attempt to register without fpga_manager_ops\n");
>>  		return NULL;
>>  	}
>>  
>>  	if (!name || !strlen(name)) {
>> -		dev_err(dev, "Attempt to register with no name!\n");
>> +		dev_err(parent, "Attempt to register with no name!\n");
>>  		return NULL;
>>  	}
>>  
>> @@ -585,8 +585,10 @@ struct fpga_manager *fpga_mgr_create(struct device *dev, const char *name,
>>  		return NULL;
>>  
>>  	id = ida_simple_get(&fpga_mgr_ida, 0, 0, GFP_KERNEL);
>> -	if (id < 0)
>> -		goto error_kfree;
>> +	if (id < 0) {
>> +		kfree(mgr);
>> +		return NULL;
>> +	}
>>  
>>  	mutex_init(&mgr->ref_mutex);
>>  
>> @@ -597,22 +599,17 @@ struct fpga_manager *fpga_mgr_create(struct device *dev, const char *name,
>>  	device_initialize(&mgr->dev);
>>  	mgr->dev.class = fpga_mgr_class;
>>  	mgr->dev.groups = mops->groups;
>> -	mgr->dev.parent = dev;
>> -	mgr->dev.of_node = dev->of_node;
>> +	mgr->dev.parent = parent;
>> +	mgr->dev.of_node = parent->of_node;
>>  	mgr->dev.id = id;
>>  
>>  	ret = dev_set_name(&mgr->dev, "fpga%d", id);
>> -	if (ret)
>> -		goto error_device;
>> +	if (ret) {
>> +		put_device(&mgr->dev);
>> +		return NULL;
>> +	}
>>  
>>  	return mgr;
>> -
>> -error_device:
>> -	ida_simple_remove(&fpga_mgr_ida, id);
>> -error_kfree:
>> -	kfree(mgr);
>> -
>> -	return NULL;
>>  }
>>  EXPORT_SYMBOL_GPL(fpga_mgr_create);
>>  
>> @@ -622,8 +619,7 @@ EXPORT_SYMBOL_GPL(fpga_mgr_create);
>>   */
>>  void fpga_mgr_free(struct fpga_manager *mgr)
>>  {
>> -	ida_simple_remove(&fpga_mgr_ida, mgr->dev.id);
>> -	kfree(mgr);
>> +	put_device(&mgr->dev);
>>  }
>>  EXPORT_SYMBOL_GPL(fpga_mgr_free);
>>  
>> @@ -631,12 +627,12 @@ static void devm_fpga_mgr_release(struct device *dev, void *res)
>>  {
>>  	struct fpga_mgr_devres *dr = res;
>>  
>> -	fpga_mgr_free(dr->mgr);
>> +	put_device(&dr->mgr->dev);
> I don't think we have to change this. devm_fpga_mgr_create() saves people from calling
> fpga_mgr_free(), so it may be more readable fpga_mgr_free() is called
> here.

I changed it because I'm not real comfortable with using "free" terminology for lowering
a reference count. But, I can change it back if you think it is more readable that way.

> Thanks,
> Yilun
>
>>  }
>>  
>>  /**
>>   * devm_fpga_mgr_create - create and initialize a managed FPGA manager struct
>> - * @dev:	fpga manager device from pdev
>> + * @parent:	fpga manager device from pdev
>>   * @name:	fpga manager name
>>   * @mops:	pointer to structure of fpga manager ops
>>   * @priv:	fpga manager private data
>> @@ -651,7 +647,7 @@ static void devm_fpga_mgr_release(struct device *dev, void *res)
>>   *
>>   * Return: pointer to struct fpga_manager or NULL
>>   */
>> -struct fpga_manager *devm_fpga_mgr_create(struct device *dev, const char *name,
>> +struct fpga_manager *devm_fpga_mgr_create(struct device *parent, const char *name,
>>  					  const struct fpga_manager_ops *mops,
>>  					  void *priv)
>>  {
>> @@ -661,13 +657,13 @@ struct fpga_manager *devm_fpga_mgr_create(struct device *dev, const char *name,
>>  	if (!dr)
>>  		return NULL;
>>  
>> -	dr->mgr = fpga_mgr_create(dev, name, mops, priv);
>> +	dr->mgr = fpga_mgr_create(parent, name, mops, priv);
>>  	if (!dr->mgr) {
>>  		devres_free(dr);
>>  		return NULL;
>>  	}
>>  
>> -	devres_add(dev, dr);
>> +	devres_add(parent, dr);
>>  
>>  	return dr->mgr;
>>  }
>> @@ -692,16 +688,11 @@ int fpga_mgr_register(struct fpga_manager *mgr)
>>  
>>  	ret = device_add(&mgr->dev);
>>  	if (ret)
>> -		goto error_device;
>> +		return ret;
>>  
>>  	dev_info(&mgr->dev, "%s registered\n", mgr->name);
>>  
>>  	return 0;
>> -
>> -error_device:
>> -	ida_simple_remove(&fpga_mgr_ida, mgr->dev.id);
>> -
>> -	return ret;
>>  }
>>  EXPORT_SYMBOL_GPL(fpga_mgr_register);
>>  
>> @@ -722,7 +713,7 @@ void fpga_mgr_unregister(struct fpga_manager *mgr)
>>  	if (mgr->mops->fpga_remove)
>>  		mgr->mops->fpga_remove(mgr);
>>  
>> -	device_unregister(&mgr->dev);
>> +	device_del(&mgr->dev);
>>  }
>>  EXPORT_SYMBOL_GPL(fpga_mgr_unregister);
>>  
>> @@ -781,6 +772,10 @@ EXPORT_SYMBOL_GPL(devm_fpga_mgr_register);
>>  
>>  static void fpga_mgr_dev_release(struct device *dev)
>>  {
>> +	struct fpga_manager *mgr = to_fpga_manager(dev);
>> +
>> +	ida_simple_remove(&fpga_mgr_ida, mgr->dev.id);
>> +	kfree(mgr);
>>  }
>>  
>>  static int __init fpga_mgr_class_init(void)
>> -- 
>> 2.25.1


  reply	other threads:[~2021-06-09 15:57 UTC|newest]

Thread overview: 14+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-06-09  0:49 [PATCH v1 0/5] fpga: Populate dev_release functions Russ Weight
2021-06-09  0:49 ` [PATCH v1 1/5] fpga: mgr: Use standard dev_release for class driver Russ Weight
2021-06-09 15:28   ` Xu Yilun
2021-06-09 15:57     ` Russ Weight [this message]
2021-06-09  0:49 ` [PATCH v1 2/5] fpga: altera-pr-ip: Remove fpga_mgr_unregister() call Russ Weight
2021-06-09 15:37   ` Xu Yilun
2021-06-09 16:25     ` Russ Weight
2021-06-09 16:45       ` Moritz Fischer
2021-06-09  0:49 ` [PATCH v1 3/5] fpga: stratix10-soc: Add missing fpga_mgr_free() call Russ Weight
2021-06-09 15:50   ` Xu Yilun
2021-06-09  0:49 ` [PATCH v1 4/5] fpga: bridge: Use standard dev_release for class driver Russ Weight
2021-06-09 15:58   ` Xu Yilun
2021-06-09  0:49 ` [PATCH v1 5/5] fpga: region: " Russ Weight
2021-06-09 16:01   ` Xu Yilun

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=0ac3450d-7073-b65c-42ea-38471d1e966a@intel.com \
    --to=russell.h.weight@intel.com \
    --cc=hao.wu@intel.com \
    --cc=lgoncalv@redhat.com \
    --cc=linux-fpga@vger.kernel.org \
    --cc=matthew.gerlach@intel.com \
    --cc=mdf@kernel.org \
    --cc=richard.gong@intel.com \
    --cc=trix@redhat.com \
    --cc=yilun.xu@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).