linux-fpga.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Russ Weight <russell.h.weight@intel.com>
To: Xu Yilun <yilun.xu@intel.com>
Cc: mdf@kernel.org, linux-fpga@vger.kernel.org, trix@redhat.com,
	lgoncalv@redhat.com, hao.wu@intel.com, matthew.gerlach@intel.com,
	richard.gong@intel.com
Subject: Re: [PATCH v2 8/8] fpga: region: Use standard dev_release for class driver
Date: Thu, 10 Jun 2021 11:53:05 -0700	[thread overview]
Message-ID: <1794f883-b148-dc6e-fee1-f0a99d80ab9d@intel.com> (raw)
In-Reply-To: <20210610082920.GH2007225@yilunxu-OptiPlex-7050>



On 6/10/21 1:29 AM, Xu Yilun wrote:
> On Wed, Jun 09, 2021 at 03:11:35PM -0700, Russ Weight wrote:
>> The FPGA region class driver data structure is being treated as a managed
>> resource instead of using standard dev_release call-back to release the
>> class data structure. This change populates the class.dev_release function
>> and changes the fpga_region_free() function to call put_device().
>> It also changes fpga_region_unregister() to call device_del() instead
>> of device_unregister().
>>
>> Signed-off-by: Russ Weight <russell.h.weight@intel.com>
>> ---
>> v2:
>>   - Moved the renaming of "dev" to "parent" to a separate patch
>>   - Call fpga_region_free() in devm_fpga_region_release() instead of put_device()
>> ---
>>  drivers/fpga/fpga-region.c | 30 +++++++++++++++---------------
>>  1 file changed, 15 insertions(+), 15 deletions(-)
>>
>> diff --git a/drivers/fpga/fpga-region.c b/drivers/fpga/fpga-region.c
>> index 563626d66e56..bdc15fab60c0 100644
>> --- a/drivers/fpga/fpga-region.c
>> +++ b/drivers/fpga/fpga-region.c
>> @@ -204,8 +204,10 @@ struct fpga_region
>>  		return NULL;
>>  
>>  	id = ida_simple_get(&fpga_region_ida, 0, 0, GFP_KERNEL);
>> -	if (id < 0)
>> -		goto err_free;
>> +	if (id < 0) {
>> +		kfree(region);
>> +		return NULL;
>> +	}
>>  
>>  	region->mgr = mgr;
>>  	region->get_bridges = get_bridges;
>> @@ -219,17 +221,12 @@ struct fpga_region
>>  	region->dev.id = id;
>>  
>>  	ret = dev_set_name(&region->dev, "region%d", id);
>> -	if (ret)
>> -		goto err_remove;
>> +	if (ret) {
>> +		put_device(&region->dev);
>> +		return NULL;
>> +	}
>>  
>>  	return region;
>> -
>> -err_remove:
>> -	ida_simple_remove(&fpga_region_ida, id);
>> -err_free:
>> -	kfree(region);
>> -
>> -	return NULL;
>>  }
>>  EXPORT_SYMBOL_GPL(fpga_region_create);
>>  
>> @@ -239,8 +236,7 @@ EXPORT_SYMBOL_GPL(fpga_region_create);
>>   */
>>  void fpga_region_free(struct fpga_region *region)
>>  {
>> -	ida_simple_remove(&fpga_region_ida, region->dev.id);
>> -	kfree(region);
>> +	put_device(&region->dev);
>>  }
>>  EXPORT_SYMBOL_GPL(fpga_region_free);
>>  
>> @@ -253,7 +249,7 @@ static void devm_fpga_region_release(struct device *dev, void *res)
>>  
>>  /**
>>   * devm_fpga_region_create - create and initialize a managed FPGA region struct
>> - * @dev: device parent
>> + * @parent: device parent
> This should be in Patch #5.
>
> Others look good to me. You could append my reviewed-by after this fix.

Thanks Yilun. I made the fix.

- Russ

>
> Reviewed-by: Xu Yilun <yilun.xu@intel.com>
>
>>   * @mgr: manager that programs this region
>>   * @get_bridges: optional function to get bridges to a list
>>   *
>> @@ -310,12 +306,16 @@ EXPORT_SYMBOL_GPL(fpga_region_register);
>>   */
>>  void fpga_region_unregister(struct fpga_region *region)
>>  {
>> -	device_unregister(&region->dev);
>> +	device_del(&region->dev);
>>  }
>>  EXPORT_SYMBOL_GPL(fpga_region_unregister);
>>  
>>  static void fpga_region_dev_release(struct device *dev)
>>  {
>> +	struct fpga_region *region = to_fpga_region(dev);
>> +
>> +	ida_simple_remove(&fpga_region_ida, region->dev.id);
>> +	kfree(region);
>>  }
>>  
>>  /**
>> -- 
>> 2.25.1


      reply	other threads:[~2021-06-10 18:53 UTC|newest]

Thread overview: 19+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-06-09 22:11 [PATCH v2 0/8] fpga: Populate dev_release functions Russ Weight
2021-06-09 22:11 ` [PATCH v2 1/8] fpga: altera-pr-ip: Remove function alt_pr_unregister Russ Weight
2021-06-10  7:37   ` Xu Yilun
2021-06-09 22:11 ` [PATCH v2 2/8] fpga: stratix10-soc: Add missing fpga_mgr_free() call Russ Weight
2021-06-09 22:11 ` [PATCH v2 3/8] fpga: mgr: Rename dev to parent for parent device Russ Weight
2021-06-10  8:02   ` Xu Yilun
2021-06-09 22:11 ` [PATCH v2 4/8] fpga: bridge: " Russ Weight
2021-06-10  8:04   ` Xu Yilun
2021-06-09 22:11 ` [PATCH v2 5/8] fpga: region: " Russ Weight
2021-06-10  8:07   ` Xu Yilun
2021-06-10  8:25   ` Xu Yilun
2021-06-10 18:45     ` Russ Weight
2021-06-09 22:11 ` [PATCH v2 6/8] fpga: mgr: Use standard dev_release for class driver Russ Weight
2021-06-10  8:13   ` Xu Yilun
2021-06-09 22:11 ` [PATCH v2 7/8] fpga: bridge: " Russ Weight
2021-06-10  8:17   ` Xu Yilun
2021-06-09 22:11 ` [PATCH v2 8/8] fpga: region: " Russ Weight
2021-06-10  8:29   ` Xu Yilun
2021-06-10 18:53     ` Russ Weight [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1794f883-b148-dc6e-fee1-f0a99d80ab9d@intel.com \
    --to=russell.h.weight@intel.com \
    --cc=hao.wu@intel.com \
    --cc=lgoncalv@redhat.com \
    --cc=linux-fpga@vger.kernel.org \
    --cc=matthew.gerlach@intel.com \
    --cc=mdf@kernel.org \
    --cc=richard.gong@intel.com \
    --cc=trix@redhat.com \
    --cc=yilun.xu@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).