From: Xu Yilun <yilun.xu@intel.com>
To: Russ Weight <russell.h.weight@intel.com>
Cc: mdf@kernel.org, linux-fpga@vger.kernel.org, trix@redhat.com,
lgoncalv@redhat.com, hao.wu@intel.com, matthew.gerlach@intel.com,
richard.gong@intel.com
Subject: Re: [PATCH v2 4/8] fpga: bridge: Rename dev to parent for parent device
Date: Thu, 10 Jun 2021 16:04:18 +0800 [thread overview]
Message-ID: <20210610080418.GC2007225@yilunxu-OptiPlex-7050> (raw)
In-Reply-To: <20210609221135.261837-5-russell.h.weight@intel.com>
Looks good to me.
Reviewed-by: Xu Yilun <yilun.xu@intel.com>
On Wed, Jun 09, 2021 at 03:11:31PM -0700, Russ Weight wrote:
> Rename variable "dev" to "parent" in cases where it represents the parent
> device.
>
> Signed-off-by: Russ Weight <russell.h.weight@intel.com>
> ---
> v2:
> - This patch contains the renaming of "dev" to "parent" that was previously
> part of the patch: "fpga: bridge: Use standard dev_release for class driver"
> ---
> drivers/fpga/fpga-bridge.c | 18 +++++++++---------
> 1 file changed, 9 insertions(+), 9 deletions(-)
>
> diff --git a/drivers/fpga/fpga-bridge.c b/drivers/fpga/fpga-bridge.c
> index 05c6d4f2d043..6c56afc66a6d 100644
> --- a/drivers/fpga/fpga-bridge.c
> +++ b/drivers/fpga/fpga-bridge.c
> @@ -313,7 +313,7 @@ ATTRIBUTE_GROUPS(fpga_bridge);
>
> /**
> * fpga_bridge_create - create and initialize a struct fpga_bridge
> - * @dev: FPGA bridge device from pdev
> + * @parent: FPGA bridge device from pdev
> * @name: FPGA bridge name
> * @br_ops: pointer to structure of fpga bridge ops
> * @priv: FPGA bridge private data
> @@ -323,7 +323,7 @@ ATTRIBUTE_GROUPS(fpga_bridge);
> *
> * Return: struct fpga_bridge or NULL
> */
> -struct fpga_bridge *fpga_bridge_create(struct device *dev, const char *name,
> +struct fpga_bridge *fpga_bridge_create(struct device *parent, const char *name,
> const struct fpga_bridge_ops *br_ops,
> void *priv)
> {
> @@ -331,7 +331,7 @@ struct fpga_bridge *fpga_bridge_create(struct device *dev, const char *name,
> int id, ret;
>
> if (!name || !strlen(name)) {
> - dev_err(dev, "Attempt to register with no name!\n");
> + dev_err(parent, "Attempt to register with no name!\n");
> return NULL;
> }
>
> @@ -353,8 +353,8 @@ struct fpga_bridge *fpga_bridge_create(struct device *dev, const char *name,
> device_initialize(&bridge->dev);
> bridge->dev.groups = br_ops->groups;
> bridge->dev.class = fpga_bridge_class;
> - bridge->dev.parent = dev;
> - bridge->dev.of_node = dev->of_node;
> + bridge->dev.parent = parent;
> + bridge->dev.of_node = parent->of_node;
> bridge->dev.id = id;
>
> ret = dev_set_name(&bridge->dev, "br%d", id);
> @@ -392,7 +392,7 @@ static void devm_fpga_bridge_release(struct device *dev, void *res)
>
> /**
> * devm_fpga_bridge_create - create and init a managed struct fpga_bridge
> - * @dev: FPGA bridge device from pdev
> + * @parent: FPGA bridge device from pdev
> * @name: FPGA bridge name
> * @br_ops: pointer to structure of fpga bridge ops
> * @priv: FPGA bridge private data
> @@ -408,7 +408,7 @@ static void devm_fpga_bridge_release(struct device *dev, void *res)
> * Return: struct fpga_bridge or NULL
> */
> struct fpga_bridge
> -*devm_fpga_bridge_create(struct device *dev, const char *name,
> +*devm_fpga_bridge_create(struct device *parent, const char *name,
> const struct fpga_bridge_ops *br_ops, void *priv)
> {
> struct fpga_bridge **ptr, *bridge;
> @@ -417,12 +417,12 @@ struct fpga_bridge
> if (!ptr)
> return NULL;
>
> - bridge = fpga_bridge_create(dev, name, br_ops, priv);
> + bridge = fpga_bridge_create(parent, name, br_ops, priv);
> if (!bridge) {
> devres_free(ptr);
> } else {
> *ptr = bridge;
> - devres_add(dev, ptr);
> + devres_add(parent, ptr);
> }
>
> return bridge;
> --
> 2.25.1
next prev parent reply other threads:[~2021-06-10 8:10 UTC|newest]
Thread overview: 19+ messages / expand[flat|nested] mbox.gz Atom feed top
2021-06-09 22:11 [PATCH v2 0/8] fpga: Populate dev_release functions Russ Weight
2021-06-09 22:11 ` [PATCH v2 1/8] fpga: altera-pr-ip: Remove function alt_pr_unregister Russ Weight
2021-06-10 7:37 ` Xu Yilun
2021-06-09 22:11 ` [PATCH v2 2/8] fpga: stratix10-soc: Add missing fpga_mgr_free() call Russ Weight
2021-06-09 22:11 ` [PATCH v2 3/8] fpga: mgr: Rename dev to parent for parent device Russ Weight
2021-06-10 8:02 ` Xu Yilun
2021-06-09 22:11 ` [PATCH v2 4/8] fpga: bridge: " Russ Weight
2021-06-10 8:04 ` Xu Yilun [this message]
2021-06-09 22:11 ` [PATCH v2 5/8] fpga: region: " Russ Weight
2021-06-10 8:07 ` Xu Yilun
2021-06-10 8:25 ` Xu Yilun
2021-06-10 18:45 ` Russ Weight
2021-06-09 22:11 ` [PATCH v2 6/8] fpga: mgr: Use standard dev_release for class driver Russ Weight
2021-06-10 8:13 ` Xu Yilun
2021-06-09 22:11 ` [PATCH v2 7/8] fpga: bridge: " Russ Weight
2021-06-10 8:17 ` Xu Yilun
2021-06-09 22:11 ` [PATCH v2 8/8] fpga: region: " Russ Weight
2021-06-10 8:29 ` Xu Yilun
2021-06-10 18:53 ` Russ Weight
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20210610080418.GC2007225@yilunxu-OptiPlex-7050 \
--to=yilun.xu@intel.com \
--cc=hao.wu@intel.com \
--cc=lgoncalv@redhat.com \
--cc=linux-fpga@vger.kernel.org \
--cc=matthew.gerlach@intel.com \
--cc=mdf@kernel.org \
--cc=richard.gong@intel.com \
--cc=russell.h.weight@intel.com \
--cc=trix@redhat.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).