From: Russ Weight <russell.h.weight@intel.com>
To: Tom Rix <trix@redhat.com>, <mdf@kernel.org>,
<linux-fpga@vger.kernel.org>, "Wu, Hao" <hao.wu@intel.com>
Cc: <lgoncalv@redhat.com>, <yilun.xu@intel.com>,
<matthew.gerlach@intel.com>, <richard.gong@intel.com>
Subject: Re: [RESEND PATCH v10 0/3] fpga: Use standard class dev_release function
Date: Tue, 27 Jul 2021 09:15:54 -0700 [thread overview]
Message-ID: <f8c391e2-987a-916a-a0e9-7795f71ec76d@intel.com> (raw)
In-Reply-To: <661d53d0-0ba4-d344-8da0-995a9b612905@redhat.com>
On 7/27/21 6:24 AM, Tom Rix wrote:
>
> On 7/26/21 2:33 PM, Russ Weight wrote:
>> Hi Moritz,
>>
>> I sent this version of the patchset out on July 8th. The only discussion has
>> been around the compat-id structure. I think there is agreement that this can
>> be treated separately. What are your thoughts? Do you think this patchset is
>> ready?
>
> While I agree the compat_id can be treated separately, i still have a problem with the 2 register functions.
>
> In this discussion,
>
> https://lore.kernel.org/linux-fpga/DM6PR11MB38194D113950FA4B75C7F2C485E49@DM6PR11MB3819.namprd11.prod.outlook.com/
>
> *register_full(..., *info) becomes
>
> *register(..., *info)
>
> and
>
> *register_simple() is moved out of the public api and becomes private to the subsystem.
Somehow I missed that part of the email. I'm not sure I understand the part about
register_simple() "becomes private to the subsystem". Most users would call the simple
version of the API. Is the proposal to replicate the register_simple() interface
for each driver that calls it?
> Tom
>
>>
>> Thanks,
>> - Russ
>>
>>
>> On 7/26/21 2:27 PM, Russ Weight wrote:
>>> The FPGA framework has a convention of using managed resource functions
>>> to allow parent drivers to manage the data structures allocated by the
>>> class drivers. They use an empty *_dev_release() function to satisfy the
>>> class driver.
>>>
>>> This is inconsistent with linux driver model.
>>>
>>> These changes remove the managed resource functions and populate the class
>>> dev_release callback functions. They also merge the create() and register()
>>> functions into a single register() or register_full() function for each of
>>> the fpga-mgr, fpga-region, and fpga-bridge class drivers.
>>>
>>> The new *register_full() functions accept an info data structure to provide
>>> flexibility in passing optional parameters. The *register() functions
>>> support the legacy parameter list for users that don't require the use of
>>> optional parameters.
>>>
>>> For more context, refer to this email thread:
>>>
>>> https://marc.info/?l=linux-fpga&m=162127412218557&w=2
>>>
>>> I turned on the configs assocated with each of the modified files, but I
>>> must have been missing some dependencies, because not all of them compiled.
>>> I did a run-time test specifically with the dfl-fme infrastructure. This
>>> would have exercised the region, bridge, and fpga-mgr frameworks.
>>>
>>> Changelog v9 -> v10:
>>> - Fixed commit messages to reference register_full() instead of
>>> register_simple().
>>> - Removed the fpga_bridge_register_full() function, because there is
>>> not need for it yet. Updated the documentation and commit message
>>> accordingly.
>>> - Updated documentation to reference the fpga_manager_info and
>>> fpga_region_info structures.
>>>
>>> Changelog v8 -> v9:
>>> - Cleaned up documentation for the FPGA Manager, Bridge, and Region
>>> register functions
>>> - Renamed fpga_*_register() to fpga_*_register_full()
>>> - Renamed fpga_*_register_simple() to fpga_*_register()
>>> - Renamed devm_fpga_mgr_register() to devm_fpga_mgr_register_full()
>>> - Renamed devm_fpga_mgr_register_simple() to devm_fpga_mgr_register()
>>>
>>> Changelog v7 -> v8:
>>> - Added reviewed-by tags.
>>> - Updated Documentation/driver-api/fpga/ files: fpga-mgr.rst,
>>> fpga-bridge.rst, and fpga-region.rst.
>>>
>>> Changelog v6 -> v7:
>>> - Update the commit messages to describe the new parameters for the
>>> *register() functions and to mention the *register_simple() functions.
>>> - Fix function prototypes in header file to rename dev to parent.
>>> - Make use of the PTR_ERR_OR_ZERO() macro when possible.
>>> - Some cleanup of comments.
>>> - Update function definitions/prototypes to apply const to the new info
>>> parameter.
>>> - Verify that info->br_ops is non-null in the fpga_bridge_register()
>>> function.
>>> - Verify a non-null info pointer in the fpga_region_register() function.
>>>
>>> Changelog v5 -> v6:
>>> - Moved FPGA manager/bridge/region optional parameters out of the ops
>>> structure and back into the FPGA class driver structure.
>>> - Changed fpga_*_register() function parameters to accept an info data
>>> structure to provide flexibility in passing optional parameters.
>>> - Added fpga_*_register_simple() functions to support current parameters
>>> for users that don't require use of optional parameters.
>>>
>>> Changelog v4 -> v5:
>>> - Rebased on top of recently accepted patches.
>>> - Removed compat_id from the fpga_mgr_register() parameter list
>>> and added it to the fpga_manager_ops structure. This also required
>>> dynamically allocating the dfl-fme-ops structure in order to add
>>> the appropriate compat_id.
>>> - Created the fpga_region_ops data structure which is optionally passed
>>> to fpga_region_register(). compat_id, the get_bridges() pointer, and
>>> the priv pointer are included in the fpga_region_ops structure.
>>>
>>> Changelog v3 -> v4:
>>> - Added the compat_id parameter to fpga_mgr_register() and
>>> devm_fpga_mgr_register() to ensure that the compat_id is set before
>>> the device_register() call.
>>> - Added the compat_id parameter to fpga_region_register() to ensure
>>> that the compat_id is set before the device_register() call.
>>> - Modified the dfl_fpga_feature_devs_enumerate() function to restore
>>> the fpga_region_register() call to the correct location.
>>>
>>> Changelog v2 -> v3:
>>> - Cleaned up comment headers for fpga_mgr_register(), fpga_bridge_register(),
>>> and fpga_region_register().
>>> - Fixed error return on ida_simple_get() failure for fpga_mgr_register(),
>>> fpga_bridge_register(), and fpga_region_register().
>>> - Fixed error return value for fpga_bridge_register(): ERR_PTR(ret) instead
>>> of NULL.
>>>
>>> Changelog v1 -> v2:
>>> - Restored devm_fpga_mgr_register() functionality to the fpga-mgr
>>> class driver, adapted for the combined create/register functionality.
>>> - All previous callers of devm_fpga_mgr_register() will continue to call
>>> devm_fpga_mgr_register().
>>> - replaced unnecessary ternary operators in return statements with
>>> standard if conditions.
>>>
>>> Russ Weight (3):
>>> fpga: mgr: Use standard dev_release for class driver
>>> fpga: bridge: Use standard dev_release for class driver
>>> fpga: region: Use standard dev_release for class driver
>>>
>>> Documentation/driver-api/fpga/fpga-bridge.rst | 6 +-
>>> Documentation/driver-api/fpga/fpga-mgr.rst | 38 +++-
>>> Documentation/driver-api/fpga/fpga-region.rst | 12 +-
>>> drivers/fpga/altera-cvp.c | 12 +-
>>> drivers/fpga/altera-fpga2sdram.c | 12 +-
>>> drivers/fpga/altera-freeze-bridge.c | 10 +-
>>> drivers/fpga/altera-hps2fpga.c | 12 +-
>>> drivers/fpga/altera-pr-ip-core.c | 7 +-
>>> drivers/fpga/altera-ps-spi.c | 9 +-
>>> drivers/fpga/dfl-fme-br.c | 10 +-
>>> drivers/fpga/dfl-fme-mgr.c | 22 +-
>>> drivers/fpga/dfl-fme-region.c | 17 +-
>>> drivers/fpga/dfl.c | 12 +-
>>> drivers/fpga/fpga-bridge.c | 122 +++-------
>>> drivers/fpga/fpga-mgr.c | 215 ++++++++----------
>>> drivers/fpga/fpga-region.c | 119 ++++------
>>> drivers/fpga/ice40-spi.c | 9 +-
>>> drivers/fpga/machxo2-spi.c | 9 +-
>>> drivers/fpga/of-fpga-region.c | 10 +-
>>> drivers/fpga/socfpga-a10.c | 16 +-
>>> drivers/fpga/socfpga.c | 9 +-
>>> drivers/fpga/stratix10-soc.c | 16 +-
>>> drivers/fpga/ts73xx-fpga.c | 9 +-
>>> drivers/fpga/xilinx-pr-decoupler.c | 17 +-
>>> drivers/fpga/xilinx-spi.c | 11 +-
>>> drivers/fpga/zynq-fpga.c | 16 +-
>>> drivers/fpga/zynqmp-fpga.c | 9 +-
>>> include/linux/fpga/fpga-bridge.h | 30 ++-
>>> include/linux/fpga/fpga-mgr.h | 62 +++--
>>> include/linux/fpga/fpga-region.h | 36 ++-
>>> 30 files changed, 383 insertions(+), 511 deletions(-)
>>>
>
next prev parent reply other threads:[~2021-07-27 16:17 UTC|newest]
Thread overview: 16+ messages / expand[flat|nested] mbox.gz Atom feed top
2021-07-26 21:27 [RESEND PATCH v10 0/3] fpga: Use standard class dev_release function Russ Weight
2021-07-26 21:27 ` [RESEND PATCH v10 1/3] fpga: mgr: Use standard dev_release for class driver Russ Weight
2021-07-26 21:27 ` [RESEND PATCH v10 2/3] fpga: bridge: " Russ Weight
2021-07-26 21:27 ` [RESEND PATCH v10 3/3] fpga: region: " Russ Weight
2021-07-26 21:33 ` [RESEND PATCH v10 0/3] fpga: Use standard class dev_release function Russ Weight
2021-07-27 5:43 ` Moritz Fischer
2021-07-27 13:24 ` Tom Rix
2021-07-27 16:15 ` Russ Weight [this message]
2021-07-27 16:22 ` Tom Rix
2021-07-27 16:38 ` Russ Weight
2021-07-27 16:55 ` Tom Rix
2021-07-27 17:16 ` Russ Weight
2021-07-27 17:44 ` Tom Rix
2021-07-27 21:07 ` Russ Weight
2021-07-28 1:33 ` Xu Yilun
2021-08-20 14:59 ` Tom Rix
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=f8c391e2-987a-916a-a0e9-7795f71ec76d@intel.com \
--to=russell.h.weight@intel.com \
--cc=hao.wu@intel.com \
--cc=lgoncalv@redhat.com \
--cc=linux-fpga@vger.kernel.org \
--cc=matthew.gerlach@intel.com \
--cc=mdf@kernel.org \
--cc=richard.gong@intel.com \
--cc=trix@redhat.com \
--cc=yilun.xu@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).