From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: from mail-wr1-f68.google.com ([209.85.221.68]:43496 "EHLO mail-wr1-f68.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1731678AbeITU4R (ORCPT ); Thu, 20 Sep 2018 16:56:17 -0400 Received: by mail-wr1-f68.google.com with SMTP id k5-v6so9770065wre.10 for ; Thu, 20 Sep 2018 08:12:20 -0700 (PDT) From: Miklos Szeredi To: David Howells Cc: Al Viro , linux-fsdevel@vger.kernel.org, linux-kernel@vger.kernel.org Subject: [PATCH 0/6] mount-api: fixes and cleanups Date: Thu, 20 Sep 2018 17:12:08 +0200 Message-Id: <20180920151214.15484-1-mszeredi@redhat.com> Sender: linux-fsdevel-owner@vger.kernel.org List-ID: These fix issues with handling subtype (fuse specific thing) and rename some constants on the new API to make me happy. I realize the last patch could be viewed as bikeshedding, but I do think suggesting falsehood in a constant name can lead to painful real life bugs, so now is the time to think about these issues. Miklos Szeredi (6): selinux: fold superblock_doinit() into only caller vfs_submount: use SB_SUBMOUNT instead of MS_SUBMOUNT mount: fix regression in setting "subtype" from legacy API fsconfig: parse "subtype" param for old internal API fsmount: do not use legacy MS_ flags fsconfig: rename FSCONFIG_CMD_CREATE to FSCONFIG_CMD_OBTAIN fs/fs_context.c | 44 +++++++++------------------------------ fs/fsopen.c | 6 +++--- fs/namespace.c | 51 +++++++++++++++++++++++++++++++--------------- include/uapi/linux/fs.h | 2 +- include/uapi/linux/mount.h | 9 ++++++++ samples/vfs/test-fsmount.c | 2 +- security/selinux/hooks.c | 37 ++++++++------------------------- 7 files changed, 68 insertions(+), 83 deletions(-) -- 2.14.3