From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: from mx1.redhat.com ([209.132.183.28]:37240 "EHLO mx1.redhat.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1725723AbeJDF3n (ORCPT ); Thu, 4 Oct 2018 01:29:43 -0400 Date: Wed, 3 Oct 2018 18:39:09 -0400 From: Richard Guy Briggs To: Paul Moore Cc: jack@suse.cz, viro@zeniv.linux.org.uk, linux-audit@redhat.com, linux-fsdevel@vger.kernel.org, amir73il@gmail.com Subject: Re: [PATCH 09/11] audit: Allocate fsnotify mark independently of chunk Message-ID: <20181003223909.smlgskao36dcogxa@madcap2.tricolour.ca> References: <20180904160632.21210-1-jack@suse.cz> <20180904160632.21210-10-jack@suse.cz> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: Sender: linux-fsdevel-owner@vger.kernel.org List-ID: On 2018-10-03 18:08, Paul Moore wrote: > On Tue, Sep 4, 2018 at 12:06 PM Jan Kara wrote: > > Allocate fsnotify mark independently instead of embedding it inside > > chunk. This will allow us to just replace chunk attached to mark when > > growing / shrinking chunk instead of replacing mark attached to inode > > which is a more complex operation. > > > > Signed-off-by: Jan Kara > > --- > > kernel/audit_tree.c | 64 +++++++++++++++++++++++++++++++++++++++++------------ > > 1 file changed, 50 insertions(+), 14 deletions(-) > > > > diff --git a/kernel/audit_tree.c b/kernel/audit_tree.c > > index 0cd08b3581f1..481fdc190c2f 100644 > > --- a/kernel/audit_tree.c > > +++ b/kernel/audit_tree.c > > @@ -142,10 +148,33 @@ static void audit_mark_put_chunk(struct audit_chunk *chunk) > > call_rcu(&chunk->head, __put_chunk); > > } > > > > +static inline struct audit_tree_mark *audit_mark(struct fsnotify_mark *entry) > > +{ > > + return container_of(entry, struct audit_tree_mark, mark); > > +} > > + > > +static struct audit_chunk *mark_chunk(struct fsnotify_mark *mark) > > +{ > > + return audit_mark(mark)->chunk; > > +} > > + > > ... > > > @@ -426,7 +460,7 @@ static int tag_chunk(struct inode *inode, struct audit_tree *tree) > > if (!old_entry) > > return create_chunk(inode, tree); > > > > - old = container_of(old_entry, struct audit_chunk, mark); > > + old = mark_chunk(old_entry)->chunk; > > I'm pretty sure you mean the following instead? > > old = mark_chunk(old_entry); Yup, nice catch. This could have been "old = audit_mark(old_entry)->chunk" but the mark_chunk() helper avoids that. (It compiles because it got fixed/replaced in the following patch.) This is why "old" should be called "old_chunk" and "old_entry" should be called "old_mark" (which the latter is in the last patch). > > /* are we already there? */ > > spin_lock(&hash_lock); > > paul moore - RGB -- Richard Guy Briggs Sr. S/W Engineer, Kernel Security, Base Operating Systems Remote, Ottawa, Red Hat Canada IRC: rgb, SunRaycer Voice: +1.647.777.2635, Internal: (81) 32635