linux-fsdevel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Jan Kara <jack@suse.cz>
To: Amir Goldstein <amir73il@gmail.com>
Cc: Jan Kara <jack@suse.cz>,
	Christian Brauner <christian.brauner@ubuntu.com>,
	linux-fsdevel <linux-fsdevel@vger.kernel.org>,
	Miklos Szeredi <miklos@szeredi.hu>,
	"J. Bruce Fields" <bfields@fieldses.org>
Subject: Re: fsnotify path hooks
Date: Thu, 8 Apr 2021 14:52:58 +0200	[thread overview]
Message-ID: <20210408125258.GB3271@quack2.suse.cz> (raw)
In-Reply-To: <CAOQ4uxjS56hjaXeTUdce2gJT3tTFb2Zs1_PiUJZzXF9i-SPGkw@mail.gmail.com>

On Tue 06-04-21 21:49:13, Amir Goldstein wrote:
> [...]
> > > > So yeh, I do think it is manageable. I think the best solution would be
> > > > something along the lines of wrappers like the following:
> > > >
> > > > static inline int vfs_mkdir(...)
> > > > {
> > > >         int error = __vfs_mkdir_nonotify(...);
> > > >         if (!error)
> > > >                 fsnotify_mkdir(dir, dentry);
> > > >         return error;
> > > > }
> > > >
> > > > And then the few call sites that call the fsnotify_path_ hooks
> > > > (i.e. in syscalls and perhaps later in nfsd) will call the
> > > > __vfs_xxx_nonotify() variant.
> > >
> > > Yes, that is OK with me. Or we could have something like:
> > >
> > > static inline void fsnotify_dirent(struct vfsmount *mnt, struct inode *dir,
> > >                                    struct dentry *dentry, __u32 mask)
> > > {
> > >         if (!mnt) {
> > >                 fsnotify(mask, d_inode(dentry), FSNOTIFY_EVENT_INODE, dir,
> > >                          &dentry->d_name, NULL, 0);
> > >         } else {
> > >                 struct path path = {
> > >                         .mnt = mnt,
> > >                         .dentry = d_find_any_alias(dir)
> > >                 };
> > >                 fsnotify(mask, d_inode(dentry), FSNOTIFY_EVENT_PATH, &path,
> > >                          &dentry->d_name, NULL, 0);
> > >         }
> > > }
> > >
> > > static inline void fsnotify_mkdir(struct vfsmount *mnt, struct inode *inode,
> > >                                   struct dentry *dentry)
> > > {
> > >         audit_inode_child(inode, dentry, AUDIT_TYPE_CHILD_CREATE);
> > >
> > >         fsnotify_dirent(mnt, inode, dentry, FS_CREATE | FS_ISDIR);
> > > }
> > >
> > > static inline int vfs_mkdir(mnt, ...)
> > > {
> > >         int error = __vfs_mkdir_nonotify(...);
> > >         if (!error)
> > >                 fsnotify_mkdir(mnt, dir, dentry);
> > > }
> > >
> >
> > I've done something similar to that. I think it's a bit cleaner,
> > but we can debate on the details later.
> > Pushed POC to branch fsnotify_path_hooks.
> 
> FYI, I tried your suggested approach above for fsnotify_xattr(),
> but I think I prefer to use an explicit flavor fsnotify_xattr_mnt()
> and a wrapper fsnotify_xattr().
> Pushed WIP to fsnotify_path_hooks branch. It also contains
> some unstashed "fix" patches to tidy up the previous hooks.

What's in fsnotify_path_hooks branch looks good to me wrt xattr hooks. What
I somewhat dislike about e.g. the fsnotify_create() approach you took is
that there are separate hooks fsnotify_create() and fsnotify_create_path()
which expose what is IMO an internal fsnotify detail of what are different
event types. I'd say it is more natural (from VFS POV) to have just a
single hook and fill in as much information as available... Also from
outside view, it is unclear that e.g. vfs_create() will generate some types
of fsnotify events but not all while e.g. do_mknodat() will generate all
fsnotify events. That's why I'm not sure whether a helper like vfs_create()
in your tree is the right abstraction since generating one type of fsnotify
event while not generating another type should be a very conscious decision
of the implementor - basically if you have no other option.

That all being said, this is just an internal API so we are free to tweak
it in the future if we get things wrong. So I'm not pushing hard for my
proposal but I wanted to raise my concerns. Also I think Al Viro might have
his opinion on this so you should probably CC him when posting the series...

> I ran into another hurdle with fsnotify_xattr() -
> vfs_setxattr() is too large to duplicate a _nonotify() variant IMO.
> OTOH, I cannot lift fsnotify_xattr() up to callers without moving
> the fsnotify hook outside the inode lock.
> 
> This was not a problem with the directory entry path hooks.
> This is also not going to be a problem with fsnotify_change(),
> because notify_change() is called with inode locked.
> 
> Do you think that calling fsnotify_xattr() under inode lock is important?
> Should I refactor a helper vfs_setxattr_notify() that takes a boolean
> arg for optionally calling fsnotify_xattr()?
> Do you have another idea how to deal with that hook?

I think having the event generated outside of i_rwsem is fine. The only
reason why I think it could possibly matter is due to reordering of events
on the same inode but that order is uncertain anyway.

> With notify_change() I have a different silly problem with using the
> refactoring method - the name notify_change_nonotify() is unacceptable.
> We may consider __ATTR_NONOTIFY ia_valid flag as the method to
> use instead of refactoring in this case, just because we can and
> because it creates less clutter.
> 
> What do you think?

Hmm, notify_change() is an inconsistent name anyway (for historical
reasons). Consistent name would be vfs_setattr(). And
vfs_setattr_nonotify() would be a fine name as well. What do you think?

								Honza
-- 
Jan Kara <jack@suse.com>
SUSE Labs, CR

  reply	other threads:[~2021-04-08 12:53 UTC|newest]

Thread overview: 61+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-03-28 15:56 [RFC][PATCH] fanotify: allow setting FAN_CREATE in mount mark mask Amir Goldstein
2021-03-30  7:31 ` Christian Brauner
2021-03-30  9:31   ` Amir Goldstein
2021-03-30 16:24     ` Amir Goldstein
2021-03-31 10:08       ` Christian Brauner
2021-03-31 10:57         ` Amir Goldstein
2021-04-08 11:44         ` open_by_handle_at() in userns Amir Goldstein
2021-04-08 12:55           ` Christian Brauner
2021-04-08 14:15             ` J. Bruce Fields
2021-04-08 15:54               ` Amir Goldstein
2021-04-08 16:08                 ` J. Bruce Fields
2021-04-08 16:48                   ` Frank Filz
2021-04-08 15:34             ` Amir Goldstein
2021-04-08 15:41               ` Christian Brauner
2021-03-30 12:12 ` [RFC][PATCH] fanotify: allow setting FAN_CREATE in mount mark mask Christian Brauner
2021-03-30 12:33   ` Amir Goldstein
2021-03-30 12:53     ` Christian Brauner
2021-03-30 12:55       ` Christian Brauner
2021-03-30 13:54       ` Amir Goldstein
2021-03-30 14:17         ` Christian Brauner
2021-03-30 14:56           ` Amir Goldstein
2021-03-31  9:46             ` Christian Brauner
2021-03-31 11:29               ` Amir Goldstein
2021-03-31 12:17                 ` Christian Brauner
2021-03-31 12:59                   ` Amir Goldstein
2021-03-31 12:54                 ` Jan Kara
2021-03-31 14:06                   ` Amir Goldstein
2021-03-31 20:59                     ` fsnotify path hooks Amir Goldstein
2021-04-01 10:29                       ` Jan Kara
2021-04-01 14:18                         ` Amir Goldstein
2021-04-02  8:20                           ` Amir Goldstein
2021-04-04 10:27                             ` LSM and setxattr helpers Amir Goldstein
2021-04-05 12:23                               ` Christian Brauner
2021-04-05 14:47                               ` Mimi Zohar
2021-04-06 15:43                                 ` Amir Goldstein
2021-04-05 16:18                               ` Casey Schaufler
2021-04-06  8:35                           ` fsnotify path hooks Jan Kara
2021-04-06 18:49                           ` Amir Goldstein
2021-04-08 12:52                             ` Jan Kara [this message]
2021-04-08 15:11                               ` Amir Goldstein
2021-04-09 10:08                                 ` Jan Kara
2021-04-09 10:45                                   ` Christian Brauner
2021-04-20  6:01                                     ` Amir Goldstein
2021-04-20 11:41                                       ` Christian Brauner
2021-04-20 11:58                                         ` Amir Goldstein
2021-04-20 13:38                                         ` Christian Brauner
2021-04-09 13:22                                   ` Amir Goldstein
2021-04-09 14:30                                     ` Al Viro
2021-04-09 14:39                                       ` Christian Brauner
2021-04-09 14:46                                         ` Al Viro
2021-04-09 15:20                                           ` Christian Brauner
2021-04-09 16:06                                       ` Amir Goldstein
2021-04-09 16:09                                         ` Amir Goldstein
2021-04-18 18:51                                   ` Amir Goldstein
2021-04-19  8:08                                     ` Amir Goldstein
2021-04-19 16:41                                 ` Amir Goldstein
2021-04-19 17:02                                   ` Al Viro
2021-04-19 22:04                                     ` Amir Goldstein
2021-04-20  7:53                                       ` Amir Goldstein
2021-03-31 13:06                 ` [RFC][PATCH] fanotify: allow setting FAN_CREATE in mount mark mask J. Bruce Fields
2021-03-30 12:20 ` Amir Goldstein

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20210408125258.GB3271@quack2.suse.cz \
    --to=jack@suse.cz \
    --cc=amir73il@gmail.com \
    --cc=bfields@fieldses.org \
    --cc=christian.brauner@ubuntu.com \
    --cc=linux-fsdevel@vger.kernel.org \
    --cc=miklos@szeredi.hu \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).