linux-fsdevel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-07-08 04:12:36 to 2020-07-09 18:09:04 UTC [more...]

decruft the early init / initrd / initramfs code v2
 2020-07-09 18:08 UTC  (20+ messages)
` [PATCH 01/17] init: remove the bstat helper
` [PATCH 02/17] md: move the early init autodetect code to drivers/md/
` [PATCH 03/17] md: replace the RAID_AUTORUN ioctl with a direct function call
` [PATCH 04/17] md: remove the autoscan partition re-read
` [PATCH 05/17] md: remove the kernel version of md_u.h
` [PATCH 06/17] md: simplify md_setup_drive
` [PATCH 07/17] md: rewrite md_setup_drive to avoid ioctls
` [PATCH 08/17] initrd: remove support for multiple floppies
` [PATCH 09/17] initrd: remove the BLKFLSBUF call in handle_initrd
` [PATCH 10/17] initrd: switch initrd loading to struct file based APIs
` [PATCH 11/17] initrd: mark init_linuxrc as __init
` [PATCH 12/17] initrd: mark initrd support as deprecated
` [PATCH 13/17] initramfs: remove the populate_initrd_image and clean_rootfs stubs
` [PATCH 14/17] initramfs: simplify clean_rootfs
` [PATCH 15/17] initramfs: switch initramfs unpacking to struct file based APIs
` [PATCH 16/17] init: open code setting up stdin/stdout/stderr
` [PATCH 17/17] fs: remove ksys_open

[PATCH 00/20] Prep work for fanotify named events
 2020-07-09 17:56 UTC  (6+ messages)
` [PATCH 01/20] fsnotify: Rearrange fast path to minimise overhead when there is no watcher
        ` fsnotify: minimise overhead when there are no marks with ignore mask

[PATCH v19 00/12] Landlock LSM
 2020-07-09 17:47 UTC  (17+ messages)
` [PATCH v19 07/12] landlock: Support filesystem access-control
` [PATCH v19 08/12] landlock: Add syscall implementation
` [PATCH v19 09/12] arch: Wire up landlock() syscall

[PATCH 0/6 v10] btrfs direct-io using iomap
 2020-07-09 17:10 UTC  (15+ messages)
` [PATCH 2/6] iomap: IOMAP_DIO_RWF_NO_STALE_PAGECACHE return if page invalidation fails
  ` always fall back to buffered I/O after invalidation failures, was: "
                ` [Cluster-devel] "

[PATCH v3 0/4] zone-append support in io-uring and aio
 2020-07-09 14:05 UTC  (7+ messages)
  ` [PATCH v3 4/4] io_uring: add support for zone-append

[PATCH 0/2] Remove kiocb ki_complete
 2020-07-09 13:59 UTC  (21+ messages)
` [PATCH 1/2] fs: Abstract calling the kiocb completion function
` [PATCH 2/2] fs: Remove kiocb->ki_complete

[ANNOUNCE] util-linux v2.36-rc2
 2020-07-09 13:49 UTC 

[PATCH v6 0/7] Add seccomp notifier ioctl that enables adding fds
 2020-07-09 13:08 UTC  (21+ messages)
` [PATCH v6 1/7] net/scm: Regularize compat handling of scm_detach_fds()
` [PATCH v6 3/7] fs: Add receive_fd() wrapper for __receive_fd()
` [PATCH v6 4/7] pidfd: Replace open-coded partial receive_fd()
` [PATCH v6 5/7] fs: Expand __receive_fd() to accept existing fd
` [PATCH v6 6/7] seccomp: Introduce addfd ioctl to seccomp user notifier
    ` [PATCH v6.1 "

[PATCH] io_uring: fix a use after free in io_async_task_func()
 2020-07-09  9:47 UTC  (7+ messages)

[PATCH v3 01/20] fsnotify: Rearrange fast path to minimise overhead when there is no watcher
 2020-07-09  9:03 UTC  (23+ messages)
` [PATCH v3 02/20] fsnotify: fold fsnotify() call into fsnotify_parent()
` [PATCH v3 03/20] fsnotify: return non const from fsnotify_data_inode()
` [PATCH v3 04/20] nfsd: use fsnotify_data_inode() to get the unlinked inode
` [PATCH v3 05/20] kernfs: do not call fsnotify() with name without a parent
` [PATCH v3 06/20] inotify: do not use objectid when comparing events
` [PATCH v3 07/20] fanotify: create overflow event type
` [PATCH v3 08/20] fanotify: break up fanotify_alloc_event()
` [PATCH v3 09/20] fsnotify: pass dir argument to handle_event() callback
` [PATCH v3 10/20] fanotify: generalize the handling of extra event flags
` [PATCH v3 11/20] fanotify: generalize merge logic of events on dir
` [PATCH v3 12/20] fanotify: distinguish between fid encode error and null fid
` [PATCH v3 13/20] fanotify: generalize test for FAN_REPORT_FID
` [PATCH v3 14/20] fanotify: mask out special event flags from ignored mask
` [PATCH v3 15/20] fanotify: prepare for implicit event flags in mark mask
` [PATCH v3 16/20] fanotify: use FAN_EVENT_ON_CHILD as implicit flag on sb/mount/non-dir marks
` [PATCH v3 17/20] fanotify: remove event FAN_DIR_MODIFY
` [PATCH v3 18/20] fsnotify: add object type "child" to object type iterator
` [PATCH v3 19/20] fanotify: use struct fanotify_info to parcel the variable size buffer
` [PATCH v3 20/20] fanotify: no external fh buffer in fanotify_name_event
` [PATCH v3 00/20] Prep work for fanotify events with name info

[PATCH 0/2] f2fs: zns zone-capacity support
 2020-07-09  7:11 UTC  (10+ messages)
` [PATCH 1/2] f2fs: support zone capacity less than zone size

mmotm 2020-07-08-19-28 uploaded
 2020-07-09  3:56 UTC  (3+ messages)
  ` mmotm 2020-07-08-19-28 uploaded (mm/migrate.c)

[PATCH RESEND] 9p: Fix memory leak in v9fs_mount
 2020-07-09  2:04 UTC  (3+ messages)

[PATCH 0/4] Fix misused kernel_read_file() enums
 2020-07-09  2:00 UTC  (11+ messages)
` [PATCH 4/4] module: Add hook for security_kernel_post_read_file()

remove leftovers of the old ->media_changed method
 2020-07-08 22:16 UTC  (14+ messages)
` [PATCH 1/6] md: switch to ->check_events for media change notifications
` [PATCH 2/6] cdrom: remove the unused cdrom_media_changed function
` [PATCH 3/6] block: remove flush_disk
` [PATCH 4/6] isofs: remove a stale comment
` [PATCH 5/6] xtensa/simdisk: remove the call to check_disk_change
` [PATCH 6/6] mmc: "

[PATCH v6 0/2] sched/uclamp: new sysctl for default RT boost value
 2020-07-08 21:45 UTC  (9+ messages)
` [PATCH v6 1/2] sched/uclamp: Add a new sysctl to control RT default "

[PATCH 0/6 v11] btrfs direct-io using iomap
 2020-07-08 21:19 UTC  (7+ messages)
` [PATCH 1/6] iomap: Convert wait_for_completion to flags
` [PATCH 2/6] iomap: IOMAP_DIO_RWF_NO_STALE_PAGECACHE return if page invalidation fails
` [PATCH 3/6] btrfs: switch to iomap_dio_rw() for dio
` [PATCH 4/6] fs: remove dio_end_io()
` [PATCH 5/6] btrfs: remove BTRFS_INODE_READDIO_NEED_LOCK
` [PATCH 6/6] btrfs: split btrfs_direct_IO to read and write part

[PATCH] Replace HTTP links with HTTPS ones: UNICODE SUBSYSTEM
 2020-07-08 18:08 UTC  (2+ messages)

[PATCH v4 0/4] Inline Encryption Support for fscrypt
 2020-07-08 17:34 UTC  (8+ messages)
` [PATCH v4 1/4] fs: introduce SB_INLINECRYPT
` [PATCH v4 2/4] fscrypt: add inline encryption support
` [PATCH v4 4/4] ext4: "

[PATCH v3 4/4] io_uring: add support for zone-append
 2020-07-08 17:13 UTC  (22+ messages)

[PATCH v12 0/4] Prepare for upcoming Casefolding/Encryption patches
 2020-07-08 17:08 UTC  (7+ messages)
` [PATCH v12 1/4] unicode: Add utf8_casefold_hash
` [PATCH v12 2/4] fs: Add standard casefolding support
` [PATCH v12 3/4] f2fs: Use generic "
` [PATCH v12 4/4] ext4: "

[PATCH AUTOSEL 5.7 07/30] exfat: Set the unused characters of FileName field to the value 0000h
 2020-07-08 15:40 UTC  (2+ messages)
` [PATCH AUTOSEL 5.7 08/30] exfat: call sync_filesystem for read-only remount

[PATCH -next] vfs: Make _anon_inode_getfile() static
 2020-07-08 15:28 UTC 

[PATCH] fput: Allow calling __fput_sync() from !PF_KTHREAD thread
 2020-07-08 14:24 UTC 

[PATCH v3 00/16] Make the user mode driver code a better citizen
 2020-07-08 13:32 UTC  (6+ messages)
` [PATCH v3 10/16] exec: Remove do_execve_file

memory leak in inotify_update_watch
 2020-07-08 12:03 UTC  (7+ messages)

[PATCH] exfat: retain 'VolumeFlags' properly
 2020-07-08  9:57 UTC 

[PATCH] exfat: fix wrong size update of stream entry by typo
 2020-07-08  9:52 UTC 

[PATCH v11 0/4] Prepare for upcoming Casefolding/Encryption patches
 2020-07-08  8:36 UTC  (4+ messages)
` [PATCH v11 2/4] fs: Add standard casefolding support

[PATCH] afs: Fix interruption of operations
 2020-07-08  8:27 UTC 

decruft the early init / initrd / initramfs code
 2020-07-08  6:38 UTC  (6+ messages)
` [PATCH 01/16] init: remove the bstat helper

stop using ->read and ->write for kernel access v3
 2020-07-08  6:07 UTC  (3+ messages)

[RFC][PATCH] net/bpfilter: Remove this broken and apparently unmantained
 2020-07-08  5:20 UTC  (19+ messages)
        ` [PATCH 00/14] Make the user mode driver code a better citizen
            ` [PATCH v2 00/15] "

[RFC] stop using ->read and ->write for kernel access
 2020-07-08  5:14 UTC  (8+ messages)
` [PATCH 03/11] fs: add new read_uptr and write_uptr file operations

[PATCH v10 0/9] firmware: add request_partial_firmware_into_buf
 2020-07-08  4:51 UTC  (9+ messages)
` [PATCH v10 2/9] fs: introduce kernel_pread_file* support
  ` [PATCH v10 7/9] misc: bcm-vk: add Broadcom VK driver


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).