linux-fsdevel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-11-14 03:55:23 to 2020-11-16 15:06:06 UTC [more...]

cleanup updating the size of block devices v3
 2020-11-16 15:05 UTC  (80+ messages)
` [PATCH 01/78] block: remove the call to __invalidate_device in check_disk_size_change
` [PATCH 02/78] loop: let set_capacity_revalidate_and_notify update the bdev size
` [PATCH 03/78] nvme: "
` [PATCH 04/78] sd: update the bdev size in sd_revalidate_disk
` [PATCH 05/78] block: remove the update_bdev parameter to set_capacity_revalidate_and_notify
` [PATCH 06/78] nbd: remove the call to set_blocksize
` [PATCH 07/78] nbd: move the task_recv check into nbd_size_update
` [PATCH 08/78] nbd: refactor size updates
` [PATCH 09/78] nbd: validate the block size in nbd_set_size
` [PATCH 10/78] nbd: use set_capacity_and_notify
` [PATCH 11/78] aoe: don't call set_capacity from irq context
` [PATCH 12/78] dm: use set_capacity_and_notify
` [PATCH 13/78] pktcdvd: "
` [PATCH 14/78] nvme: use set_capacity_and_notify in nvme_set_queue_dying
` [PATCH 15/78] drbd: use set_capacity_and_notify
` [PATCH 16/78] rbd: "
` [PATCH 17/78] rnbd: "
` [PATCH 18/78] zram: "
` [PATCH 19/78] dm-raid: "
` [PATCH 20/78] md: "
` [PATCH 21/78] md: remove a spurious call to revalidate_disk_size in update_size
` [PATCH 22/78] virtio-blk: remove a spurious call to revalidate_disk_size
` [PATCH 23/78] block: unexport revalidate_disk_size
` [PATCH 24/78] mtd_blkdevs: don't override BLKFLSBUF
` [PATCH 25/78] block: don't call into the driver for BLKFLSBUF
` [PATCH 26/78] block: add a new set_read_only method
` [PATCH 27/78] rbd: implement ->set_read_only to hook into BLKROSET processing
` [PATCH 28/78] md: "
` [PATCH 29/78] dasd: "
` [PATCH 30/78] block: don't call into the driver for BLKROSET
` [PATCH 31/78] loop: use set_disk_ro
` [PATCH 32/78] block: remove set_device_ro
` [PATCH 33/78] block: remove __blkdev_driver_ioctl
` [PATCH 34/78] block: propagate BLKROSET to all partitions
` [PATCH 35/78] block: cleanup del_gendisk a bit
` [PATCH 36/78] block: open code kobj_map into in block/genhd.c
` [PATCH 37/78] block: split block_class_lock
` [PATCH 38/78] block: rework requesting modules for unclaimed devices
` [PATCH 39/78] block: add an optional probe callback to major_names
` [PATCH 40/78] ide: remove ide_{,un}register_region
` [PATCH 41/78] swim: don't call blk_register_region
` [PATCH 42/78] sd: use __register_blkdev to avoid a modprobe for an unregistered dev_t
` [PATCH 43/78] brd: use __register_blkdev to allocate devices on demand
` [PATCH 44/78] loop: "
` [PATCH 45/78] md: "
` [PATCH 46/78] ide: switch to __register_blkdev for command set probing
` [PATCH 47/78] floppy: use a separate gendisk for each media format
` [PATCH 48/78] amiflop: use separate gendisks for Amiga vs MS-DOS mode
` [PATCH 49/78] ataflop: use a separate gendisk for each media format
` [PATCH 50/78] z2ram: reindent
` [PATCH 51/78] z2ram: use separate gendisk for the different modes
` [PATCH 52/78] block: switch gendisk lookup to a simple xarray
` [PATCH 53/78] blk-cgroup: fix a hd_struct leak in blkcg_fill_root_iostats
` [PATCH 54/78] block: remove a duplicate __disk_get_part prototype
` [PATCH 55/78] block: change the hash used for looking up block devices
` [PATCH 56/78] init: refactor name_to_dev_t
` [PATCH 57/78] init: refactor devt_from_partuuid
` [PATCH 58/78] init: cleanup match_dev_by_uuid and match_dev_by_label
` [PATCH 59/78] mtip32xx: remove the call to fsync_bdev on removal
` [PATCH 60/78] zram: remove the claim mechanism
` [PATCH 61/78] zram: do not call set_blocksize
` [PATCH 62/78] loop: "
` [PATCH 63/78] bcache: remove a superflous lookup_bdev all
` [PATCH 64/78] dm: simplify flush_bio initialization in __send_empty_flush
` [PATCH 65/78] dm: remove the block_device reference in struct mapped_device
` [PATCH 66/78] block: keep a block_device reference for each hd_struct
` [PATCH 67/78] block: simplify the block device claiming interface
` [PATCH 68/78] block: remove ->bd_contains
` [PATCH 69/78] block: remove the nr_sects field in struct hd_struct
` [PATCH 70/78] block: replace bd_mutex with a per-gendisk mutex
` [PATCH 71/78] block: add a bdev_kobj helper
` [PATCH 72/78] block: use disk_part_iter_exit in disk_part_iter_next
` [PATCH 73/78] block: use put_device in put_disk
` [PATCH 74/78] block: merge struct block_device and struct hd_struct
` [PATCH 75/78] block: stop using bdget_disk for partition 0
` [PATCH 76/78] filemap: use ->f_mapping over ->i_mapping consistently
` [PATCH 77/78] fs: simplify the get_super_thawed interface
` [PATCH 78/78] block: remove i_bdev

[RFC PATCH 1/3] fs: Add s_instance_id field to superblock for unique identification
 2020-11-16 14:45 UTC  (11+ messages)
` [RFC PATCH 2/3] overlay: Add ovl_do_getxattr helper
` [RFC PATCH 3/3] overlay: Add the ability to remount volatile directories when safe

Garbage data while reading via usermode driver?
 2020-11-16 14:15 UTC  (4+ messages)

[PATCH v2] binfmt_elf_fdpic: return corresponding errcode if create_elf_fdpic_tables() fail
 2020-11-16 14:06 UTC 

[PATCH v4 00/21] Free some vmemmap pages of hugetlb page
 2020-11-16 13:52 UTC  (7+ messages)
` [PATCH v4 01/21] mm/memory_hotplug: Move bootmem info registration API to bootmem_info.c
` [PATCH v4 02/21] mm/memory_hotplug: Move {get,put}_page_bootmem() "
` [PATCH v4 04/21] mm/hugetlb: Introduce nr_free_vmemmap_pages in the struct hstate

[ANNOUNCE] stable util-linux v2.36.1
 2020-11-16 13:46 UTC 

[PATCH v4 00/16] Overhaul multi-page lookups for THP
 2020-11-16 10:34 UTC  (34+ messages)
` [PATCH v4 01/16] mm: Make pagecache tagged lookups return only head pages
` [PATCH v4 02/16] mm/shmem: Use pagevec_lookup in shmem_unlock_mapping
` [PATCH v4 03/16] mm/swap: Optimise get_shadow_from_swap_cache
` [PATCH v4 04/16] mm: Add FGP_ENTRY
` [PATCH v4 05/16] mm/filemap: Rename find_get_entry to mapping_get_entry
` [PATCH v4 06/16] mm/filemap: Add helper for finding pages
` [PATCH v4 07/16] mm/filemap: Add mapping_seek_hole_data
` [PATCH v4 08/16] iomap: Use mapping_seek_hole_data
` [PATCH v4 09/16] mm: Add and use find_lock_entries
` [PATCH v4 10/16] mm: Add an 'end' parameter to find_get_entries
` [PATCH v4 11/16] mm: Add an 'end' parameter to pagevec_lookup_entries
` [PATCH v4 12/16] mm: Remove nr_entries parameter from pagevec_lookup_entries
` [PATCH v4 13/16] mm: Pass pvec directly to find_get_entries
` [PATCH v4 14/16] mm: Remove pagevec_lookup_entries
` [PATCH v4 16/16] mm/filemap: Return only head pages from find_get_entries

[PATCH v4 00/27]Fix several bad kernel-doc markups
 2020-11-16 10:18 UTC  (2+ messages)
` [PATCH v4 11/27] fs: fix "

INFO: task can't die in io_sq_thread_stop
 2020-11-16  9:32 UTC  (2+ messages)

[RESEND][PATCH] ima: Set and clear FMODE_CAN_READ in ima_calc_file_hash()
 2020-11-16  8:52 UTC  (2+ messages)

[PATCH 0/2] io_uring: add mkdirat support
 2020-11-16  4:45 UTC  (3+ messages)
` [PATCH 1/2] fs: make do_mkdirat() take struct filename
` [PATCH 2/2] io_uring: add support for IORING_OP_MKDIRAT

support splice reads on seq_file based procfs files v2
 2020-11-16  3:29 UTC  (26+ messages)
` [PATCH 1/6] seq_file: add seq_read_iter

WARNING: suspicious RCU usage in unmap_page_range
 2020-11-15 19:30 UTC 

Corporate and Personal Loan *
 2020-11-15 16:43 UTC 

[PATCH v2 00/39] fs: idmapped mounts
 2020-11-15 12:31 UTC  (41+ messages)
` [PATCH v2 01/39] namespace: take lock_mount_hash() directly when changing flags
` [PATCH v2 02/39] mount: make {lock,unlock}_mount_hash() static
` [PATCH v2 03/39] namespace: only take read lock in do_reconfigure_mnt()
` [PATCH v2 04/39] fs: add mount_setattr()
` [PATCH v2 05/39] tests: add mount_setattr() selftests
` [PATCH v2 06/39] fs: add id translation helpers
` [PATCH v2 07/39] mount: attach mappings to mounts
` [PATCH v2 08/39] capability: handle idmapped mounts
` [PATCH v2 09/39] namei: add idmapped mount aware permission helpers
` [PATCH v2 10/39] inode: add idmapped mount aware init and "
` [PATCH v2 11/39] attr: handle idmapped mounts
` [PATCH v2 12/39] acl: "
` [PATCH v2 13/39] xattr: "
` [PATCH v2 14/39] commoncap: "
` [PATCH v2 15/39] stat: "
` [PATCH v2 16/39] namei: handle idmapped mounts in may_*() helpers
` [PATCH v2 17/39] namei: introduce struct renamedata
` [PATCH v2 18/39] namei: prepare for idmapped mounts
` [PATCH v2 19/39] open: handle idmapped mounts in do_truncate()
` [PATCH v2 20/39] open: handle idmapped mounts
` [PATCH v2 21/39] af_unix: "
` [PATCH v2 22/39] utimes: "
` [PATCH v2 23/39] fcntl: "
` [PATCH v2 24/39] notify: "
` [PATCH v2 25/39] init: "
` [PATCH v2 26/39] ioctl: "
` [PATCH v2 27/39] would_dump: "
` [PATCH v2 28/39] exec: "
` [PATCH v2 29/39] fs: add helpers for idmap mounts
` [PATCH v2 30/39] apparmor: handle idmapped mounts
` [PATCH v2 31/39] audit: "
` [PATCH v2 32/39] ima: "
` [PATCH v2 33/39] fat: "
` [PATCH v2 34/39] ext4: support "
` [PATCH v2 35/39] ecryptfs: do not mount on top of "
` [PATCH v2 36/39] overlayfs: "
` [PATCH v2 37/39] fs: introduce MOUNT_ATTR_IDMAP
` [PATCH v2 38/39] selftests: add idmapped mounts xattr selftest
` [PATCH v2 39/39] tests: add vfs/idmapped mounts test suite

[PATCH v8 0/9] mm: introduce memfd_secret system call to create "secret" memory areas
 2020-11-15  9:17 UTC  (12+ messages)
` [PATCH v8 4/9] "
` [PATCH v8 6/9] secretmem: add memcg accounting
` [PATCH v8 8/9] arch, mm: wire up memfd_secret system call were relevant

[PATCH v8 2/9] mmap: make mlock_future_check() global
 2020-11-15  8:26 UTC  (3+ messages)

[PATCH] afs: Fix afs_write_end() when called with copied == 0 [ver #2]
 2020-11-14 19:46 UTC  (4+ messages)

[PATCH] afs: Fix afs_write_end() when called with copied == 0 [ver #3]
 2020-11-14 17:27 UTC 

[PATCH] afs: Fix afs_write_end() when called with copied == 0
 2020-11-14 17:26 UTC  (2+ messages)

Corporate and Personal Loan/
 2020-11-10 14:09 UTC 

[PATCH v2 00/13] arch, mm: deprecate DISCONTIGMEM
 2020-11-14 12:15 UTC  (3+ messages)
` [PATCH v2 09/13] arm, arm64: move free_unused_memmap() to generic mm

[PATCH v3] libfs: fix error cast of negative value in simple_attr_write()
 2020-11-14  8:09 UTC 


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).