linux-fsdevel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-11-27 17:26:59 to 2020-11-30 13:16:22 UTC [more...]

[PATCH v10 00/41] btrfs: zoned block device support
 2020-11-30 13:15 UTC  (15+ messages)
` [PATCH v10 04/41] btrfs: get zone information of zoned block devices
` [PATCH v10 05/41] btrfs: check and enable ZONED mode
` [PATCH v10 06/41] btrfs: introduce max_zone_append_size

possible deadlock in f_getown
 2020-11-30 12:39 UTC  (2+ messages)

merge struct block_device and struct hd_struct v4
 2020-11-30 11:26 UTC  (90+ messages)
` [PATCH 01/45] blk-cgroup: fix a hd_struct leak in blkcg_fill_root_iostats
` [PATCH 02/45] filemap: consistently use ->f_mapping over ->i_mapping
` [PATCH 03/45] fs: remove get_super_thawed and get_super_exclusive_thawed
` [PATCH 04/45] fs: simplify freeze_bdev/thaw_bdev
` [PATCH 05/45] mtip32xx: remove the call to fsync_bdev on removal
` [PATCH 06/45] zram: do not call set_blocksize
` [PATCH 07/45] loop: "
` [PATCH 08/45] dm: simplify flush_bio initialization in __send_empty_flush
` [PATCH 09/45] dm: remove the block_device reference in struct mapped_device
` [PATCH 10/45] block: remove a duplicate __disk_get_part prototype
` [PATCH 11/45] block: remove a superflous check in blkpg_do_ioctl
` [PATCH 12/45] block: add a bdev_kobj helper
` [PATCH 13/45] block: use disk_part_iter_exit in disk_part_iter_next
` [PATCH 14/45] block: use put_device in put_disk
` [PATCH 15/45] block: change the hash used for looking up block devices
` [PATCH 16/45] block: switch bdgrab to use igrab
` [PATCH 17/45] init: refactor name_to_dev_t
` [PATCH 18/45] init: refactor devt_from_partuuid
` [PATCH 19/45] init: cleanup match_dev_by_uuid and match_dev_by_label
` [PATCH 20/45] block: refactor __blkdev_put
` [PATCH 21/45] block: refactor blkdev_get
` [PATCH 22/45] block: move bdput() to the callers of __blkdev_get
` [PATCH 23/45] block: opencode devcgroup_inode_permission
` [PATCH 24/45] block: remove i_bdev
` [PATCH 25/45] block: simplify bdev/disk lookup in blkdev_get
` [PATCH 26/45] block: remove ->bd_contains
` [PATCH 27/45] block: simplify the block device claiming interface
` [PATCH 28/45] block: simplify part_to_disk
` [PATCH 29/45] block: initialize struct block_device in bdev_alloc
` [PATCH 30/45] block: remove the nr_sects field in struct hd_struct
` [PATCH 31/45] block: move disk stat accounting to struct block_device
` [PATCH 32/45] block: move the start_sect field "
` [PATCH 33/45] block: move the partition_meta_info "
` [PATCH 34/45] block: move holder_dir "
` [PATCH 35/45] block: move make_it_fail "
` [PATCH 36/45] block: move the policy field "
` [PATCH 37/45] block: allocate struct hd_struct as part of struct bdev_inode
` [PATCH 38/45] block: switch partition lookup to use struct block_device
` [PATCH 39/45] block: remove the partno field from struct hd_struct
` [PATCH 40/45] block: pass a block_device to blk_alloc_devt
` [PATCH 41/45] block: pass a block_device to invalidate_partition
` [PATCH 42/45] block: switch disk_part_iter_* to use a struct block_device
` [PATCH 43/45] f2fs: remove a few bd_part checks
` [PATCH 44/45] block: merge struct block_device and struct hd_struct
` [PATCH 45/45] block: stop using bdget_disk for partition 0

[PATCH V10 0/5] fuse: Add support for passthrough read/write
 2020-11-30 11:08 UTC  (7+ messages)
` [PATCH V10 2/5] fuse: Passthrough initialization and release

[PATCH v12 00/10] NTFS read-write driver GPL implementation by Paragon Software
 2020-11-30  9:45 UTC  (3+ messages)

[PATCH] fs: iomap: Replace bio_add_page with __bio_add_page in iomap_add_to_ioend
 2020-11-30  7:28 UTC 

[PATCH] overlay: Plumb through flush method
 2020-11-30  3:00 UTC 

[PATCH kernel] fs/io_ring: Fix lockdep warnings
 2020-11-30  2:00 UTC 

[PATCH RESEND v2] fs/select.c: batch user writes in do_sys_poll
 2020-11-30  0:43 UTC  (3+ messages)
` [fs/select.c] c191bb1b91: will-it-scale.per_thread_ops -2.3% regression

[RFC PATCH v2 0/6] fsdax: introduce fs query to support reflink
 2020-11-29 22:47 UTC  (2+ messages)

[PATCH] locks: remove trailing semicolon in macro definition
 2020-11-29 22:31 UTC  (6+ messages)

[PATCH v12 00/10] mm: introduce memfd_secret system call to create "secret" memory areas
 2020-11-29 17:26 UTC  (4+ messages)
` [PATCH v12 07/10] secretmem: add memcg accounting

[RFC PATCH 1/3] fs: dax.c: move fs hole signifier from DAX_ZERO_PAGE to XA_ZERO_ENTRY
 2020-11-29  4:36 UTC 

[RFC PATCH 2/3] fs: dax.c: move down bit DAX_EMPTY
 2020-11-29  4:36 UTC 

[RFC PATCH 3/3] fs: dax.c: correct terminology used in DAX bit definitions
 2020-11-29  4:36 UTC 

[PATCH 0/3] Migrate zero page DAX bit from DAX_ZERO_PAGE to XA_ZERO_ENTRY
 2020-11-29  4:36 UTC 

[RFC PATCH 00/13] fs/userfaultfd: support iouring and polling
 2020-11-29  0:45 UTC  (14+ messages)
` [RFC PATCH 01/13] fs/userfaultfd: fix wrong error code on WP & !VM_MAYWRITE
` [RFC PATCH 02/13] fs/userfaultfd: fix wrong file usage with iouring
` [RFC PATCH 03/13] selftests/vm/userfaultfd: wake after copy failure
` [RFC PATCH 04/13] fs/userfaultfd: simplify locks in userfaultfd_ctx_read
` [RFC PATCH 05/13] fs/userfaultfd: introduce UFFD_FEATURE_POLL
` [RFC PATCH 06/13] iov_iter: support atomic copy_page_from_iter_iovec()
` [RFC PATCH 07/13] fs/userfaultfd: support read_iter to use io_uring
` [RFC PATCH 08/13] fs/userfaultfd: complete reads asynchronously
` [RFC PATCH 09/13] fs/userfaultfd: use iov_iter for copy/zero
` [RFC PATCH 10/13] fs/userfaultfd: add write_iter() interface
` [RFC PATCH 11/13] fs/userfaultfd: complete write asynchronously
` [RFC PATCH 12/13] fs/userfaultfd: kmem-cache for wait-queue objects
` [RFC PATCH 13/13] selftests/vm/userfaultfd: iouring and polling tests

Lockdep warning on io_file_data_ref_zero() with 5.10-rc5
 2020-11-29  0:21 UTC  (3+ messages)

[PATCH v3 00/38] idmapped mounts
 2020-11-28 22:54 UTC  (42+ messages)
` [PATCH v3 01/38] namespace: take lock_mount_hash() directly when changing flags
` [PATCH v3 02/38] mount: make {lock,unlock}_mount_hash() static
` [PATCH v3 03/38] namespace: only take read lock in do_reconfigure_mnt()
` [PATCH v3 04/38] fs: add mount_setattr()
` [PATCH v3 05/38] tests: add mount_setattr() selftests
` [PATCH v3 06/38] fs: add id translation helpers
` [PATCH v3 07/38] mount: attach mappings to mounts
` [PATCH v3 08/38] capability: handle idmapped mounts
` [PATCH v3 09/38] namei: add idmapped mount aware permission helpers
` [PATCH v3 10/38] inode: add idmapped mount aware init and "
` [PATCH v3 11/38] attr: handle idmapped mounts
` [PATCH v3 12/38] acl: "
` [PATCH v3 13/38] xattr: "
` [PATCH v3 14/38] commoncap: "
` [PATCH v3 15/38] stat: "
` [PATCH v3 16/38] namei: handle idmapped mounts in may_*() helpers
` [PATCH v3 17/38] namei: introduce struct renamedata
` [PATCH v3 18/38] namei: prepare for idmapped mounts
` [PATCH v3 19/38] open: handle idmapped mounts in do_truncate()
` [PATCH v3 20/38] open: handle idmapped mounts
` [PATCH v3 21/38] af_unix: "
` [PATCH v3 22/38] utimes: "
` [PATCH v3 23/38] fcntl: "
` [PATCH v3 24/38] notify: "
` [PATCH v3 25/38] init: "
` [PATCH v3 26/38] ioctl: "
` [PATCH v3 27/38] would_dump: "
` [PATCH v3 28/38] exec: "
` [PATCH v3 29/38] fs: add helpers for idmap mounts
` [PATCH v3 30/38] apparmor: handle idmapped mounts
` [PATCH v3 31/38] ima: "
` [PATCH v3 32/38] fat: "
` [PATCH v3 33/38] ext4: support "
` [PATCH v3 34/38] ecryptfs: do not mount on top of "
` [PATCH v3 35/38] overlayfs: "
` [PATCH v3 36/38] fs: introduce MOUNT_ATTR_IDMAP
` [PATCH v3 37/38] tests: extend mount_setattr tests
` [PATCH v3 38/38] generic/618: add fstests for idmapped mounts

[GIT PULL] Writeback fis for 5.10-rc6
 2020-11-27 19:19 UTC  (2+ messages)

[PATCH] proc: add locking checks in proc_inode_is_dead
 2020-11-28 19:01 UTC  (2+ messages)

KASAN: use-after-free Read in idr_for_each (2)
 2020-11-28 17:19 UTC  (2+ messages)

[PATCH v2 0/4] Make overlayfs volatile mounts reusable
 2020-11-28 12:04 UTC  (12+ messages)
` [PATCH v2 2/4] overlay: Document current outstanding shortcoming of volatile

[PATCH v2 00/39] fs: idmapped mounts
 2020-11-28 18:12 UTC  (3+ messages)
` [PATCH v2 10/39] inode: add idmapped mount aware init and permission helpers

[PATCH v2 02/24] exec: Simplify unshare_files
 2020-11-28  5:12 UTC  (10+ messages)
` [PATCH v2 00/24] exec: Move unshare_files and guarantee files_struct.count is correct

WARNING in try_to_wake_up
 2020-11-28  1:44 UTC  (2+ messages)

[PATCH] fanotify: Fix fanotify_mark() on 32-bit x86
 2020-11-28  0:36 UTC  (4+ messages)

merge struct block_device and struct hd_struct v3
 2020-11-27 17:30 UTC  (11+ messages)
` [PATCH 37/44] block: switch partition lookup to use struct block_device
` [PATCH 41/44] block: switch disk_part_iter_* to use a "


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).