linux-gpio.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Maxime Ripard <maxime@cerno.tech>
To: wens <wens@csie.org>, 李扬韬 <frank@allwinnertech.com>,
	"linus.walleij" <linus.walleij@linaro.org>
Cc: robh+dt <robh+dt@kernel.org>,
	mturquette <mturquette@baylibre.com>, sboyd <sboyd@kernel.org>,
	"p.zabel" <p.zabel@pengutronix.de>,
	黄烁生 <huangshuosheng@allwinnertech.com>,
	"tiny.windzz" <tiny.windzz@gmail.com>,
	linux-arm-kernel <linux-arm-kernel@lists.infradead.org>,
	devicetree <devicetree@vger.kernel.org>,
	linux-kernel <linux-kernel@vger.kernel.org>,
	linux-clk <linux-clk@vger.kernel.org>,
	linux-gpio <linux-gpio@vger.kernel.org>
Subject: Re: 回复:[PATCH 2/4] pinctrl: sunxi: add support for the Allwinner A100 pin controller
Date: Fri, 5 Jun 2020 17:13:06 +0200	[thread overview]
Message-ID: <20200605151306.kqmyj673kux4sbaa@gilmour.lan> (raw)
In-Reply-To: <8c7a8eeb-f4ea-4df7-b381-5aeab6dd170a.frank@allwinnertech.com>

[-- Attachment #1: Type: text/plain, Size: 2618 bytes --]

Hi Frank,

On Wed, Jun 03, 2020 at 05:44:36PM +0800, 李扬韬 wrote:
> >> + SUNXI_PIN(SUNXI_PINCTRL_PIN(F, 0),
> >> +  SUNXI_FUNCTION(0x0, "gpio_in"),
> >> +  SUNXI_FUNCTION(0x1, "gpio_out"),
> >> +  SUNXI_FUNCTION(0x2, "mmc0"),  /* D1 */
> >> +  SUNXI_FUNCTION(0x3, "jtag"),  /* MS1 */
> >> +  SUNXI_FUNCTION(0x4, "jtag"),  /* MS_GPU */
> >
> >We should use another name here, since the code will just pick the first one and
> >ignore the second. What about jtag-gpu?
> 
> The underscores are used in front, so changing it to jtag_gpu may be more consistent.

Yep, that makes sense

> >> + SUNXI_PIN(SUNXI_PINCTRL_PIN(B, 7),
> >> +  SUNXI_FUNCTION(0x0, "gpio_in"),
> >> +  SUNXI_FUNCTION(0x1, "gpio_out"),
> >> +  SUNXI_FUNCTION(0x2, "spdif"),  /* DIN */
> >> +  SUNXI_FUNCTION(0x3, "i2s0"),  /* DOUT0 */
> >> +  SUNXI_FUNCTION(0x4, "i2s0"),  /* DIN1 */
> >
> >I guess the second one would be i2s1?
> 
> No, each i2s may have many inputs and outputs. 
> 
>  SUNXI_PIN(SUNXI_PINCTRL_PIN(H, 19),
>      SUNXI_FUNCTION(0x0, "gpio_in"),
>               SUNXI_FUNCTION(0x1, "gpio_out"),
>               SUNXI_FUNCTION(0x2, "cir0"),          /* IN */
>               SUNXI_FUNCTION(0x3, "i2s3_dout3"),       /* DOUT3 */
>               SUNXI_FUNCTION(0x4, "i2s3_din3"),       /* DIN3 */
>               SUNXI_FUNCTION(0x5, "ledc"),
>               SUNXI_FUNCTION_IRQ_BANK(0x6, 6, 19)),
> 
> Considering that the same pin has multiple same functions, 
> so add a suffix, like i2s3_dout3 and i2s3_din3?   
> 
> Or specify muxsel in the device tree may be another solution.

Having muxsel is not really an option. We have two sets of bindings to
maintain already, adding a third one would make it fairly hard to
maintain. And the second binding we support is the generic pinctrl
binding, so I'm not really sure why we would want to move away from
that.

And I'm not really fond of having a suffix either. It kind of breaks the
consistency we had so far, and ideally I'd like to keep that.

Chen-Yu, Linus? Any input on that one?

> >> + SUNXI_PIN(SUNXI_PINCTRL_PIN(H, 2),
> >> +  SUNXI_FUNCTION(0x0, "gpio_in"),
> >> +  SUNXI_FUNCTION(0x1, "gpio_out"),
> >> +  SUNXI_FUNCTION(0x2, "i2c1"),  /* SCK */
> >> +  SUNXI_FUNCTION(0x3, "cpu"),  /* CUR_W */
> >
> >What is "cpu" supposed to be?
> 
> As far as I know, this is a function that has never been used.
> The hardware guy said that it can be used to control the CPU to reduce the current.

Ok. Do we really need to add it right now if we don't really know what
it's going to be used for?

Thanks!
Maxime

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 228 bytes --]

  reply	other threads:[~2020-06-05 15:13 UTC|newest]

Thread overview: 15+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-05-22  3:07 [PATCH 0/4] Allwinner A100 Initial support Frank Lee
2020-05-22  3:07 ` [PATCH 1/4] clk: sunxi-ng: add support for the Allwinner A100 CCU Frank Lee
2020-05-22 15:14   ` Maxime Ripard
2020-06-03  9:42     ` 回复:[PATCH " 李扬韬
2020-06-03  9:48       ` [PATCH " Chen-Yu Tsai
2020-05-22  3:07 ` [PATCH 2/4] pinctrl: sunxi: add support for the Allwinner A100 pin controller Frank Lee
2020-05-22 15:28   ` Maxime Ripard
2020-06-03  9:44     ` 回复:[PATCH " 李扬韬
2020-06-05 15:13       ` Maxime Ripard [this message]
2020-06-16  9:26         ` Frank Lee
2020-06-20 21:27           ` Linus Walleij
2020-05-22  3:07 ` [PATCH 3/4] arm64: allwinner: A100: add the basical Allwinner A100 DTSI file Frank Lee
2020-05-22  3:07 ` [PATCH 4/4] arm64: allwinner: A100: add support for Allwinner Perf1 board Frank Lee
2020-05-22 15:31   ` Maxime Ripard
2020-05-22 15:02 ` [PATCH 0/4] Allwinner A100 Initial support Maxime Ripard

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200605151306.kqmyj673kux4sbaa@gilmour.lan \
    --to=maxime@cerno.tech \
    --cc=devicetree@vger.kernel.org \
    --cc=frank@allwinnertech.com \
    --cc=huangshuosheng@allwinnertech.com \
    --cc=linus.walleij@linaro.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-clk@vger.kernel.org \
    --cc=linux-gpio@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mturquette@baylibre.com \
    --cc=p.zabel@pengutronix.de \
    --cc=robh+dt@kernel.org \
    --cc=sboyd@kernel.org \
    --cc=tiny.windzz@gmail.com \
    --cc=wens@csie.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).