linux-gpio.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2021-01-11 13:35:19 to 2021-01-18 07:42:12 UTC [more...]

[PATCH v4 0/2] pinctrl: single: support #pinctrl-cells = 2
 2021-01-18  7:41 UTC  (5+ messages)
` [PATCH v4 2/2] ARM: dts: am33xx-l4: change #pinctrl-cells from 1 to 2

[PATCH v2 0/7] Introduce intel_skl_int3472 driver
 2021-01-18  7:37 UTC  (12+ messages)
` [PATCH v2 1/7] acpi: utils: move acpi_lpss_dep() to utils
` [PATCH v2 2/7] acpi: utils: Add function to fetch dependent acpi_devices
` [PATCH v2 3/7] i2c: i2c-core-base: Use format macro in i2c_dev_set_name()
` [PATCH v2 4/7] i2c: i2c-core-acpi: Add i2c_acpi_dev_name()
` [PATCH v2 5/7] gpio: gpiolib-acpi: Export acpi_get_gpiod()
` [PATCH v2 6/7] platform: x86: Add intel_skl_int3472 driver
` [PATCH v2 7/7] mfd: Remove tps68470 MFD driver

[PATCH v3 03/21] dt-bindings: pinctrl: Add Allwinner H616 compatible strings
 2021-01-18  2:08 UTC  (3+ messages)
` [PATCH v3 04/21] pinctrl: sunxi: Add support for the Allwinner H616 pin controller
` [PATCH v3 05/21] pinctrl: sunxi: Add support for the Allwinner H616-R "

[PATCH v13 02/17] pinctrl: Add RISC-V Canaan Kendryte K210 FPIOA driver
 2021-01-18  2:02 UTC 

[libgpiod][PATCH v2 0/7] treewide: remove more cruft and add some improvements
 2021-01-18  1:01 UTC  (11+ messages)
` [libgpiod][PATCH v2 1/7] treewide: remove helpers for opening chips by name & number
` [libgpiod][PATCH v2 2/7] treewide: simplify the active-low line property
` [libgpiod][PATCH v2 3/7] treewide: rename BIAS_AS_IS to BIAS_UNKNOWN
` [libgpiod][PATCH v2 4/7] treewide: rename BIAS_DISABLE to BIAS_DISABLED
` [libgpiod][PATCH v2 5/7] treewide: make drive settings an enum
` [libgpiod][PATCH v2 6/7] bindings: cxx: line: reorder bias mapping entries
` [libgpiod][PATCH v2 7/7] core: add the kernel uapi header to the repository

[PATCH v2 0/7] selftests: gpio: rework and port to GPIO uAPI v2
 2021-01-17 23:54 UTC  (16+ messages)
` [PATCH v2 1/7] selftests: gpio: rework and simplify test implementation
` [PATCH v2 2/7] selftests: gpio: remove obsolete gpio-mockup-chardev.c
` [PATCH v2 3/7] selftests: remove obsolete build restriction for gpio
` [PATCH v2 4/7] selftests: remove obsolete gpio references from kselftest_deps.sh
` [PATCH v2 5/7] tools: gpio: remove uAPI v1 code no longer used by selftests
` [PATCH v2 6/7] selftests: gpio: port to GPIO uAPI v2
` [PATCH v2 7/7] selftests: gpio: add CONFIG_GPIO_CDEV to config

[PATCH v2 1/2] pwm: pwm-gpio: New driver
 2021-01-17 21:06 UTC  (4+ messages)

[PATCH v4 0/5] gpio: mvebu: pwm fixes and improvements
 2021-01-17 13:17 UTC  (6+ messages)
` [PATCH v4 1/5] gpio: mvebu: fix pwm .get_state period calculation
` [PATCH v4 2/5] gpio: mvebu: improve pwm period calculation accuracy
` [PATCH v4 3/5] gpio: mvebu: make pwm .get_state closer to idempotent
` [PATCH v4 4/5] gpio: mvebu: don't limit pwm period/duty_cycle to UINT_MAX
` [PATCH v4 5/5] gpio: mvebu: improve handling of pwm zero on/off values

[PATCH v2] gpiolib: Bind gpio_device to a driver to enable fw_devlink=on by default
 2021-01-17 12:02 UTC  (3+ messages)

[PATCH v1] gpiolib: Bind gpio_device to a driver to enable fw_devlink=on by default
 2021-01-16 20:35 UTC  (3+ messages)

[PATCH] dt-bindings: pinctrl: pinctrl-microchip-sgpio: Fix indentation
 2021-01-16  1:53 UTC 

[PATCH v5 1/4] pinctrl: qcom: Allow SoCs to specify a GPIO function that's not 0
 2021-01-16  1:04 UTC  (21+ messages)
` [PATCH v5 2/4] pinctrl: qcom: No need to read-modify-write the interrupt status
` [PATCH v5 3/4] pinctrl: qcom: Properly clear "intr_ack_high" interrupts when unmasking
` [PATCH v5 4/4] pinctrl: qcom: Don't clear pending interrupts when enabling

[PATCH] drivers/pinctrl/bcm: Simplify bool comparison
 2021-01-15 18:24 UTC  (2+ messages)

[PATCH v2] gpiolib: Disallow identical line names in the same chip
 2021-01-15 17:31 UTC  (11+ messages)
        ` R: "

[PATCH] pinctrl: qcom-pmic-gpio: Add support for pm8019
 2021-01-15 17:11 UTC  (2+ messages)
` [PATCH] pinctrl: qcom: spmi-mpp: Add PM8019 compatible

[PATCH v2 0/3] gpio: pca953x: Add support for pca9506
 2021-01-15 16:46 UTC  (4+ messages)
` [PATCH v2 1/3] "
` [PATCH v2 2/3] dt-bindings: gpio: pca953x: Document new supported chip pca9506
` [PATCH v2 3/3] dt-bindings: gpio: pca953x: Increase allowed length for gpio-line-names

[PATCH 1/2] gpio: pca953x: Add support for pca9506
 2021-01-15 16:12 UTC  (4+ messages)
` [PATCH 2/2] dt-bindings: gpio: pca953x: increase allowed length for gpio-line-names

[PATCH v12 02/17] pinctrl: Add RISC-V Canaan Kendryte K210 FPIOA driver
 2021-01-15 14:03 UTC 

[PATCH v2 1/2] kconfig.h: Add IF_ENABLED() macro
 2021-01-15 11:47 UTC  (4+ messages)

[PATCH v4 0/4] configfs: implement committable items and add sample code
 2021-01-15 11:15 UTC  (6+ messages)
` [PATCH v4 1/4] configfs: increase the item name length
` [PATCH v4 2/4] configfs: use (1UL << bit) for internal flags
` [PATCH v4 3/4] configfs: implement committable items
` [PATCH v4 4/4] samples: configfs: add a committable group

[PATCH v3 0/5] gpio: mvebu: pwm fixes and improvements
 2021-01-15 10:53 UTC  (9+ messages)
` [PATCH v3 1/5] gpio: mvebu: fix pwm .get_state period calculation
` [PATCH v3 2/5] gpio: mvebu: improve pwm period calculation accuracy
` [PATCH v3 3/5] gpio: mvebu: make pwm .get_state closer to idempotent
` [PATCH v3 4/5] gpio: mvebu: don't limit pwm period/duty_cycle to UINT_MAX
` [PATCH v3 5/5] gpio: mvebu: document zero pwm duty cycle limitation

[GIT PULL] pinctrl: sh-pfc: Updates for v5.12
 2021-01-15  9:53 UTC 

[PATCH v7 1/4] pinctrl: qcom: Allow SoCs to specify a GPIO function that's not 0
 2021-01-15  3:19 UTC  (5+ messages)
` [PATCH v7 2/4] pinctrl: qcom: No need to read-modify-write the interrupt status
` [PATCH v7 3/4] pinctrl: qcom: Properly clear "intr_ack_high" interrupts when unmasking
` [PATCH v7 4/4] pinctrl: qcom: Don't clear pending interrupts when enabling

[PATCH v6 1/4] pinctrl: qcom: Allow SoCs to specify a GPIO function that's not 0
 2021-01-15  2:08 UTC  (5+ messages)
` [PATCH v6 2/4] pinctrl: qcom: No need to read-modify-write the interrupt status
` [PATCH v6 3/4] pinctrl: qcom: Properly clear "intr_ack_high" interrupts when unmasking
` [PATCH v6 4/4] pinctrl: qcom: Don't clear pending interrupts when enabling

[PATCH v2 1/2] pinctrl: Add driver for Awinic AW9523/B I2C GPIO Expander
 2021-01-14 22:42 UTC  (6+ messages)
` [PATCH v2 2/2] dt-bindings: pinctrl: Add bindings for Awinic AW9523/AW9523B

[PATCH v6 00/11] Raspberry Pi PoE HAT fan support
 2021-01-14 18:44 UTC  (6+ messages)
` [PATCH v6 11/11] pwm: Add Raspberry Pi Firmware based PWM bus

[PATCH v9 00/12] treewide: bd9571mwv: Add support for BD9574MWF
 2021-01-14 13:08 UTC  (14+ messages)
` [PATCH v9 01/12] mfd: bd9571mwv: Use devm_mfd_add_devices()
` [PATCH v9 02/12] dt-bindings: mfd: bd9571mwv: Document BD9574MWF
` [PATCH v9 03/12] mfd: rohm-generic: Add BD9571 and BD9574
` [PATCH v9 04/12] regulator: bd9571mwv: rid of using struct bd9571mwv
` [PATCH v9 05/12] regulator: bd9571mwv: Add BD9574MWF support
` [PATCH v9 06/12] gpio: bd9571mwv: Use the SPDX license identifier
` [PATCH v9 07/12] gpio: bd9571mwv: rid of using struct bd9571mwv
` [PATCH v9 08/12] gpio: bd9571mwv: Add BD9574MWF support
` [PATCH v9 09/12] mfd: bd9571mwv: Use the SPDX license identifier
` [PATCH v9 10/12] mfd: bd9571mwv: Use devm_regmap_add_irq_chip()
` [PATCH v9 11/12] mfd: bd9571mwv: Make the driver more generic
` [PATCH v9 12/12] mfd: bd9571mwv: Add support for BD9574MWF
` [GIT PULL] Immutable branch between MFD, GPIO and Regulator due for the v5.12 merge window

[PATCH v2 02/21] dt-bindings: pinctrl: Add Allwinner H616 compatible strings
 2021-01-14 11:57 UTC  (4+ messages)

[PATCH net-next 0/2] dsa: add MT7530 GPIO support
 2021-01-14  9:36 UTC  (2+ messages)

[PATCH v2] pinctrl: sprd: Simplify bool comparison
 2021-01-14  4:53 UTC  (2+ messages)

[PATCH, v1 0/1] gpio: aspeed: Add gpio base address reading
 2021-01-14  0:27 UTC  (3+ messages)
` [PATCH, v1 1/1] "

[PATCH v4 1/2] pinctrl: Add driver for Awinic AW9523/B I2C GPIO Expander
 2021-01-13 18:40 UTC  (2+ messages)
` [PATCH v4 2/2] dt-bindings: pinctrl: Add bindings for Awinic AW9523/AW9523B

[PATCH 00/15] Support ROHM BD71815 PMIC
 2021-01-13 15:47 UTC  (10+ messages)
` [PATCH 05/15] dt_bindings: mfd: Add "
` [PATCH 06/15] dt_bindings: regulator: Add ROHM BD71815 PMIC regulators

[PATCH v2 0/5] gpio: mvebu: pwm fixes and improvements
 2021-01-13  9:42 UTC  (8+ messages)
` [PATCH v2 1/5] gpio: mvebu: fix pwm .get_state period calculation
` [PATCH v2 2/5] gpio: mvebu: improve pwm period calculation accuracy
` [PATCH v2 3/5] gpio: mvebu: make pwm .get_state closer to idempotent
` [PATCH v2 4/5] gpio: mvebu: don't limit pwm period/duty_cycle to UINT_MAX
` [PATCH v2 5/5] gpio: mvebu: document zero pwm duty cycle limitation

[PATCH v2 0/4] Allwinner H6 RSB support
 2021-01-13  9:16 UTC  (7+ messages)
` [PATCH v2 4/4] arm64: dts: allwinner: h6: Use RSB for AXP805 PMIC connection
          ` [linux-sunxi] "

[PATCH 0/5] gpio: mvebu: pwm fixes and improvements
 2021-01-13  8:17 UTC  (14+ messages)
` [PATCH 1/5] gpio: mvebu: fix pwm get_state period calculation
` [PATCH 2/5] gpio: mvebu: improve pwm period calculation accuracy
` [PATCH 3/5] gpio: mvebu: make pwm apply/get_state closer to idempotent
` [PATCH 4/5] gpio: mvebu: don't limit pwm period/duty_cycle to UINT_MAX
` [PATCH 5/5] gpio: mvebu: document zero pwm duty cycle limitation

[PATCH v4 0/2] pinctrl: qcom: Add SM8350 pinctrl support
 2021-01-13  2:56 UTC  (4+ messages)
` [PATCH v4 1/2] dt-bindings: pinctrl: qcom: Add SM8350 pinctrl bindings

[PATCH] pinctrl: sprd: style: Simplify bool comparison
 2021-01-13  1:55 UTC  (2+ messages)

[PATCH v3 1/2] pinctrl: Add driver for Awinic AW9523/B I2C GPIO Expander
 2021-01-12 23:12 UTC  (2+ messages)
` [PATCH v3 2/2] dt-bindings: pinctrl: Add bindings for Awinic AW9523/AW9523B

[PATCH v1 1/2] gpio: tegra: Fix wake interrupt
 2021-01-12 13:30 UTC  (2+ messages)
` [PATCH v1 2/2] gpio: tegra: Add dependency on GPIOLIB_IRQCHIP

[PATCH v7 0/3] gpio: mvebu: Armada 8K/7K PWM support
 2021-01-12 10:36 UTC  (4+ messages)
` [PATCH v7 3/3] dt-bindings: ap806: document gpio marvell,pwm-offset property

[PATCH v6 00/12] treewide: bd9571mwv: Add support for BD9574MWF
 2021-01-12  4:43 UTC  (4+ messages)
` [PATCH v6 08/12] gpio: bd9571mwv: Add BD9574MWF support

[PATCH v11 00/10] RISC-V Kendryte K210 support improvements
 2021-01-12  1:07 UTC 

[PATCH v11 02/10] pinctrl: Add RISC-V Canaan Kendryte K210 FPIOA driver
 2021-01-12  1:03 UTC 

[PATCH] pinctrl: ti :iodelay: Fixed inconsistent indenting
 2021-01-11 19:49 UTC 

[PATCH 0/2] Add Awinic AW9523(B) I2C GPIO Expander driver
 2021-01-11 17:54 UTC  (8+ messages)
` [PATCH 1/2] pinctrl: Add driver for Awinic AW9523/B I2C GPIO Expander

[PATCH v2] pinctrl: renesas: checker: Restrict checks to Renesas platforms
 2021-01-11 16:50 UTC 

[libgpiod][PATCH 0/6] treewide: remove more cruft and
 2021-01-11 15:15 UTC  (13+ messages)
` [libgpiod][PATCH 2/6] treewide: simplify the active-low line property
` [libgpiod][PATCH 3/6] treewide: rename BIAS_AS_IS to BIAS_NONE
` [libgpiod][PATCH 4/6] treewide: make drive settings an enum
` [libgpiod][PATCH 5/6] bindings: cxx: line: reorder bias mapping entries
` [libgpiod][PATCH 6/6] core: add the kernel uapi header to the repository

[PATCH] pinctrl: renesas: checker: Restrict checks to Renesas platforms
 2021-01-11 14:36 UTC  (2+ messages)


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).