linux-hardening.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2021-09-02 16:25:58 to 2021-09-19 08:27:37 UTC [more...]

[PATCH] net: mana: Prefer struct_size over open coded arithmetic
 2021-09-19  8:27 UTC  (7+ messages)

[PATCH v1 0/6] kunit: build kunit tests without structleak plugin
 2021-09-18 15:58 UTC  (18+ messages)
` [PATCH v1 1/6] gcc-plugins/structleak: add makefile var for disabling structleak
` [PATCH v1 2/6] iio/test-format: build kunit tests without structleak plugin
` [PATCH v1 3/6] device property: "
` [PATCH v1 4/6] thunderbolt: "
` [PATCH v1 5/6] mmc: sdhci-of-aspeed: "
` [PATCH v1 6/6] bitfield: "

[PATCH] platform/x86: thinkpad_acpi: Prefer struct_size over open coded arithmetic
 2021-09-18 15:05 UTC 

[PATCH] KVM: PPC: Replace zero-length array with flexible array member
 2021-09-18 14:21 UTC 

[PATCH] scsi: advansys: Prefer struct_size over open coded arithmetic
 2021-09-18 11:18 UTC 

[PATCH] dmaengine: pxa_dma: Prefer struct_size over open coded arithmetic
 2021-09-18 10:40 UTC 

[PATCH v6] EDAC/mc: Prefer strscpy or scnprintf over strcpy
 2021-09-18  9:17 UTC  (8+ messages)
` [PATCH] EDAC/mc: Prefer strscpy or scnprintf over strcpy, sprintf and snprintf

[PATCH v2] docs: deprecated.rst: Clarify open-coded arithmetic with literals
 2021-09-18  9:10 UTC  (3+ messages)

[PATCH v2] binfmt_elf: Reintroduce using MAP_FIXED_NOREPLACE
 2021-09-16 21:59 UTC 

bug scrub
 2021-09-16 15:36 UTC 

[PATCH] brcmfmac: Replace zero-length array with flexible array member
 2021-09-16 15:17 UTC  (3+ messages)

[PATCH v6 0/4] Use per-CPU temporary mappings for patching on Radix MMU
 2021-09-16  2:04 UTC  (13+ messages)
` [PATCH v6 1/4] powerpc/64s: Introduce temporary mm for "
` [PATCH v6 2/4] powerpc: Rework and improve STRICT_KERNEL_RWX patching
` [PATCH v6 3/4] powerpc: Use WARN_ON and fix check in poking_init
` [PATCH v6 4/4] powerpc/64s: Initialize and use a temporary mm for patching on Radix

[PATCH] [RFC] Add additional include path for gcc plugins
 2021-09-15 10:00 UTC  (2+ messages)

[PATCH v2] hardening: Avoid harmless Clang option under CONFIG_INIT_STACK_ALL_ZERO
 2021-09-15  7:50 UTC  (2+ messages)

[PATCH v3 00/16] x86: Add support for Clang CFI
 2021-09-15  6:24 UTC  (34+ messages)
` [PATCH v3 01/16] objtool: Add CONFIG_CFI_CLANG support
` [PATCH v3 02/16] objtool: Add ASM_STACK_FRAME_NON_STANDARD
` [PATCH v3 03/16] linkage: Add DECLARE_ASM_FUNC_SYMBOL
` [PATCH v3 04/16] cfi: Add DEFINE_CFI_IMMEDIATE_RETURN_STUB
` [PATCH v3 05/16] tracepoint: Exclude tp_stub_func from CFI checking
` [PATCH v3 06/16] ftrace: Use an opaque type for functions not callable from C
` [PATCH v3 07/16] lkdtm: Disable UNSET_SMEP with CFI
` [PATCH v3 08/16] lkdtm: Use an opaque type for lkdtm_rodata_do_nothing
` [PATCH v3 09/16] x86: Use an opaque type for functions not callable from C
` [PATCH v3 10/16] x86/extable: Mark handlers __cficanonical
` [PATCH v3 11/16] x86/purgatory: Disable CFI
` [PATCH v3 12/16] x86, relocs: Ignore __typeid__ relocations
` [PATCH v3 13/16] x86, module: "
` [PATCH v3 14/16] x86, cpu: Use LTO for cpu.c with CFI
` [PATCH v3 15/16] x86, kprobes: Fix optprobe_template_func type mismatch
` [PATCH v3 16/16] x86, build: Allow CONFIG_CFI_CLANG to be selected

[PATCH] Input: omap-keypad - prefer struct_size over open coded arithmetic
 2021-09-14 21:49 UTC  (2+ messages)

[PATCH][next] ath11k: Replace one-element array with flexible-array member
 2021-09-14 17:36 UTC  (4+ messages)

[GIT PULL] Enable -Wimplicit-fallthrough for Clang for 5.15-rc2
 2021-09-14 16:41 UTC 

[PATCH] memstick: jmb38x_ms: Prefer struct_size over open coded arithmetic
 2021-09-14 11:23 UTC  (2+ messages)

[PATCH] ath11k: Replace one-element array with flexible-array member
 2021-09-14  5:53 UTC  (4+ messages)

[PATCH] i3c/master/mipi-i3c-hci: Prefer struct_size over open coded arithmetic
 2021-09-13 17:39 UTC  (3+ messages)

[PATCH] i3c/master/mipi-i3c-hci: Prefer kcalloc over open coded arithmetic
 2021-09-13 17:39 UTC  (3+ messages)

[PATCH] landlock: Drop "const" argument qualifier to avoid GCC 4.9 warnings
 2021-09-13 16:16 UTC  (3+ messages)

[PATCH] nfp: Prefer struct_size over open coded arithmetic
 2021-09-13  8:31 UTC  (3+ messages)

[PATCH] ice: Prefer kcalloc over open coded arithmetic
 2021-09-12 20:41 UTC  (2+ messages)
` [Intel-wired-lan] "

[Clarification] writes to kernel addresses that came from userspace
 2021-09-12 18:47 UTC 

[PATCH] usb: ohci: Prefer struct_size over open coded arithmetic
 2021-09-11 15:46 UTC  (2+ messages)

[PATCH] samples/seccomp: Avoid alias warning
 2021-09-10 22:34 UTC 

[PATCH] x86/asm: Fix setz size enqcmds() build failure
 2021-09-10 22:33 UTC 

[PATCH v2] Compiler Attributes: Check GCC version for __alloc_size attribute
 2021-09-10 21:16 UTC  (2+ messages)

[PATCH] Compiler Attributes: Check GCC version for __alloc_size attribute
 2021-09-10 20:06 UTC  (4+ messages)

[GIT PULL v3] overflow updates for v5.15-rc1-take3
 2021-09-10 17:08 UTC 

[PATCH] lkdtm: Use init_uts_ns.name instead of macros
 2021-09-10 15:10 UTC  (6+ messages)

[PATCH v6 kspp-next 00/22] Function Granular KASLR
 2021-09-10 12:29 UTC  (8+ messages)
` [PATCH v6 kspp-next 16/22] livepatch: only match unique symbols when using fgkaslr

[PATCH] rapidio: Avoid bogus __alloc_size warning
 2021-09-10  6:29 UTC  (9+ messages)

[GIT PULL v2] overflow updates for v5.15-rc1-take2
 2021-09-10  4:51 UTC 

[PATCH v2 00/63] Introduce strict memcpy() bounds checking
 2021-09-09  6:14 UTC  (3+ messages)
` [PATCH v2 60/63] net/af_iucv: Use struct_group() to zero struct iucv_sock region

[PATCH] RDMA/bnxt_re: Prefer kcalloc over open coded arithmetic
 2021-09-08 11:44 UTC  (4+ messages)

[PATCH] drm/kmb: Avoid warnings on impossible plane_id
 2021-09-07 18:11 UTC  (4+ messages)

[PATCH] drm/radeon: Prefer kcalloc over open coded arithmetic
 2021-09-07 17:00 UTC  (2+ messages)

[PATCH] scsi: elx: libefc: Prefer kcalloc over open coded arithmetic
 2021-09-07 16:55 UTC  (2+ messages)

[GIT PULL] overflow updates for v5.15-rc1
 2021-09-06 17:19 UTC  (10+ messages)

[PATCH] cpufreq: powernow: Prefer kcalloc over open coded arithmetic
 2021-09-06 17:05 UTC  (2+ messages)

[GIT PULL][take 2] overflow updates for v5.15-rc1
 2021-09-05 21:40 UTC 

[PATCH] serial: 8250_pci: Prefer struct_size over open coded arithmetic
 2021-09-05 16:13 UTC  (2+ messages)

[PATCH] tifm: Prefer struct_size over open coded arithmetic
 2021-09-05 15:37 UTC 

Introduction: I am a Linux and open source software enthusiast
 2021-09-05  9:48 UTC 

[PATCH] x86/unwind/orc: Handle kretprobes_trampoline
 2021-09-05  7:57 UTC  (3+ messages)

[PATCH] net/mlx5: DR, Prefer kcalloc over open coded arithmetic
 2021-09-05  7:49 UTC 

[PATCH] dmaengine: milbeaut-hdmac: Prefer kcalloc over open coded arithmetic
 2021-09-04 14:58 UTC 

[PATCH 0/4] Fix ro_after_init vs static_call
 2021-09-04 14:40 UTC  (11+ messages)
` [PATCH 1/4] vmlinux.lds.h: Use regular *RODATA and *RO_AFTER_INIT_DATA suffixes
` [PATCH 2/4] vmlinux.lds.h: Split .static_call_sites from .static_call_tramp_key
` [PATCH 3/4] module: Use a list of strings for ro_after_init sections

[PATCH] clk: ti: composite: Prefer kcalloc over open coded arithmetic
 2021-09-04 13:17 UTC 

[PATCH v5] EDAC/mc: Prefer strscpy or scnprintf over strcpy
 2021-09-03 14:21 UTC  (3+ messages)

memset() in crypto code
 2021-09-03  6:15 UTC  (2+ messages)

C vs crypto
 2021-09-03  2:32 UTC 

[PATCH 0/2]: ARM: Enable THREAD_INFO_IN_TASK
 2021-09-02 17:37 UTC  (4+ messages)

Landlock news #1
 2021-09-02 16:13 UTC 


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).