> > -int of_i2c_get_board_info(struct device_node *node, struct i2c_board_info *info) > > +static void of_i2c_decode_board_info(struct device_node *node, u32 addr, > > + bool first_addr, struct i2c_board_info *info) > > While I confirm the patch looks generally OK, let me add the name of > this function is not quite self-explaining. The difference between "get" > and "decode" has nothing to do with the different actions these > functions do, i.e. the new function gets (or: decodes) info about a > single address that is passed, the old "get" function gets the info for > the first address. > > I'd suggest the new function be named of_i2c_get_board_info_one_addr or > similar. Not super nice, a bit long, but self-explanatory. I view them a bit differently, I think. of_i2c_decode_board_info() is a helper function to retrieve "some" addr. It is used by of_i2c_get_board_info() which has the special case of getting the first address. of_i2c_register_device() is the other user with the case of getting each address specified. So, I wouldn't put this helper function on the same level as the users of this helper. Yet, no strong opinion here, I will think about it...