linux-i3c.lists.infradead.org archive mirror
 help / color / mirror / Atom feed
From: Kieran Bingham <kieran.bingham+renesas@ideasonboard.com>
To: Wolfram Sang <wsa+renesas@sang-engineering.com>,
	linux-i2c@vger.kernel.org
Cc: "Jacopo Mondi" <jacopo@jmondi.org>,
	"Geert Uytterhoeven" <geert+renesas@glider.be>,
	linux-kernel@vger.kernel.org, "Vladimir Zapolskiy" <vz@mleia.com>,
	linux-renesas-soc@vger.kernel.org,
	"Luca Ceresoli" <luca@lucaceresoli.net>,
	"Laurent Pinchart" <laurent.pinchart@ideasonboard.com>,
	"Niklas Söderlund" <niklas.soderlund@ragnatech.se>,
	linux-i3c@lists.infradead.org
Subject: Re: [RFC PATCH v2 4/6] i2c: of: error message unification
Date: Wed, 15 Apr 2020 09:50:12 +0100	[thread overview]
Message-ID: <4a63e7f5-8a0c-a9f1-640b-2f33c0076160@ideasonboard.com> (raw)
In-Reply-To: <7014c94a-bb89-b282-52ee-49b42ab5aac1@bingham.xyz>

Hi Wolfram,

On 15/04/2020 09:17, Kieran Bingham wrote:
> Hi Wolfram,
> 
> On 18/03/2020 15:00, Wolfram Sang wrote:
>> - don't prefix the device if %pOF is provided. That information is
>>   enough.
>> - move the prefix to pr_fmt
>> - change prefix from "of_i2c" to "i2c_of" because the code was moved
>>   out of the of-domain long ago
>> - drop error string for callers of of_i2c_register_device because it
>>   already reports enough (thanks to Tang Bin for the report!)
>>
>> Signed-off-by: Wolfram Sang <wsa+renesas@sang-engineering.com>
>> Reviewed-by: Geert Uytterhoeven <geert+renesas@glider.be>
> 
> Reviewed-by: Kieran Bingham <kieran.bingham+renesas@ideasonboard.com>
> 
>> ---
>>  drivers/i2c/i2c-core-of.c | 18 +++++++-----------
>>  1 file changed, 7 insertions(+), 11 deletions(-)
>>
>> diff --git a/drivers/i2c/i2c-core-of.c b/drivers/i2c/i2c-core-of.c
>> index 710704cd583e..f2d09ea0d336 100644
>> --- a/drivers/i2c/i2c-core-of.c
>> +++ b/drivers/i2c/i2c-core-of.c
>> @@ -8,6 +8,8 @@
>>   * Copyright (C) 2013, 2018 Wolfram Sang <wsa@the-dreams.de>
>>   */
>>  
>> +#define pr_fmt(fmt) "i2c_of: " fmt
>> +
>>  #include <dt-bindings/i2c/i2c.h>
>>  #include <linux/device.h>
>>  #include <linux/err.h>
>> @@ -28,7 +30,7 @@ int of_i2c_get_board_info(struct device_node *node, struct i2c_board_info *info)


Perhaps not directly needed by this patch but,

at some point will you rename of_i2c_* to i2c_of_* ?


>>  
>>  	ret = of_property_read_u32(node, "reg", &addr);
>>  	if (ret) {
>> -		pr_err("of_i2c: invalid reg on %pOF\n", node);
>> +		pr_err("invalid reg on %pOF\n", node);
>>  		return ret;
>>  	}
>>  
>> @@ -66,7 +68,7 @@ static struct i2c_client *of_i2c_register_device(struct i2c_adapter *adap,
>>  	struct i2c_board_info info;
>>  	int ret;
>>  
>> -	dev_dbg(&adap->dev, "of_i2c: register %pOF\n", node);
>> +	pr_debug("register %pOF\n", node);
>>  
>>  	ret = of_i2c_get_board_info(node, &info);
>>  	if (ret)
>> @@ -74,7 +76,7 @@ static struct i2c_client *of_i2c_register_device(struct i2c_adapter *adap,
>>  
>>  	client = i2c_new_client_device(adap, &info);
>>  	if (IS_ERR(client))
>> -		dev_err(&adap->dev, "of_i2c: Failure registering %pOF\n", node);
>> +		pr_err("failure registering %pOF (%ld)\n", node, PTR_ERR(client));
>>  
>>  	return client;
>>  }
>> @@ -88,7 +90,7 @@ void of_i2c_register_devices(struct i2c_adapter *adap)
>>  	if (!adap->dev.of_node)
>>  		return;
>>  
>> -	dev_dbg(&adap->dev, "of_i2c: walking child nodes\n");
>> +	dev_dbg(&adap->dev, "walking child nodes\n");
>>  
>>  	bus = of_get_child_by_name(adap->dev.of_node, "i2c-bus");
>>  	if (!bus)
>> @@ -99,12 +101,8 @@ void of_i2c_register_devices(struct i2c_adapter *adap)
>>  			continue;
>>  
>>  		client = of_i2c_register_device(adap, node);
>> -		if (IS_ERR(client)) {
>> -			dev_err(&adap->dev,
>> -				 "Failed to create I2C device for %pOF\n",
>> -				 node);
>> +		if (IS_ERR(client))
>>  			of_node_clear_flag(node, OF_POPULATED);
>> -		}
>>  	}
>>  
>>  	of_node_put(bus);
>> @@ -243,8 +241,6 @@ static int of_i2c_notify(struct notifier_block *nb, unsigned long action,
>>  
>>  		client = of_i2c_register_device(adap, rd->dn);
>>  		if (IS_ERR(client)) {
>> -			dev_err(&adap->dev, "failed to create client for '%pOF'\n",
>> -				 rd->dn);
>>  			put_device(&adap->dev);
>>  			of_node_clear_flag(rd->dn, OF_POPULATED);
>>  			return notifier_from_errno(PTR_ERR(client));
>>
> 


_______________________________________________
linux-i3c mailing list
linux-i3c@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-i3c

  reply	other threads:[~2020-04-15  8:50 UTC|newest]

Thread overview: 29+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-03-18 15:00 [RFC PATCH v2 0/6] i2c: of: reserve unknown and ancillary addresses Wolfram Sang
2020-03-18 15:00 ` [RFC PATCH v2 1/6] i2c: use DEFINE for the dummy driver name Wolfram Sang
2020-04-15  8:09   ` Kieran Bingham
2020-03-18 15:00 ` [RFC PATCH v2 2/6] i2c: allow DT nodes without 'compatible' Wolfram Sang
2020-04-10 13:49   ` Luca Ceresoli
2020-04-15  7:59     ` Wolfram Sang
2020-04-15  8:07       ` Kieran Bingham
2020-04-15  8:16         ` Wolfram Sang
2020-04-15  8:38           ` Kieran Bingham
2020-04-16 14:53       ` Luca Ceresoli
2020-04-15  8:48   ` Kieran Bingham
2020-04-15  9:46     ` Wolfram Sang
2020-03-18 15:00 ` [RFC PATCH v2 3/6] i2c: of: remove superfluous parameter from exported function Wolfram Sang
2020-03-19 12:41   ` Boris Brezillon
2020-04-15  8:13   ` Kieran Bingham
2020-03-18 15:00 ` [RFC PATCH v2 4/6] i2c: of: error message unification Wolfram Sang
2020-04-10 17:02   ` Luca Ceresoli
2020-04-15  8:17   ` Kieran Bingham
2020-04-15  8:50     ` Kieran Bingham [this message]
2020-03-18 15:00 ` [RFC PATCH v2 5/6] i2c: of: mark a whole array of regs as reserved Wolfram Sang
2020-04-10 17:05   ` Luca Ceresoli
2020-04-13  9:55   ` Luca Ceresoli
2020-04-15  8:10     ` Wolfram Sang
2020-04-15 10:07   ` Luca Ceresoli
2020-03-18 15:00 ` [RFC PATCH v2 6/6] i2c: core: hand over reserved devices when requesting ancillary addresses Wolfram Sang
2020-04-15 10:07   ` Luca Ceresoli
2020-03-28  3:50 ` [RFC PATCH v2 0/6] i2c: of: reserve unknown and " Wolfram Sang
2020-04-15  8:27 ` Wolfram Sang
2020-04-15  8:35   ` Kieran Bingham

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=4a63e7f5-8a0c-a9f1-640b-2f33c0076160@ideasonboard.com \
    --to=kieran.bingham+renesas@ideasonboard.com \
    --cc=geert+renesas@glider.be \
    --cc=jacopo@jmondi.org \
    --cc=laurent.pinchart@ideasonboard.com \
    --cc=linux-i2c@vger.kernel.org \
    --cc=linux-i3c@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-renesas-soc@vger.kernel.org \
    --cc=luca@lucaceresoli.net \
    --cc=niklas.soderlund@ragnatech.se \
    --cc=vz@mleia.com \
    --cc=wsa+renesas@sang-engineering.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).