linux-input.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Dmitry Torokhov <dmitry.torokhov@gmail.com>
To: Jiada Wang <jiada_wang@mentor.com>
Cc: nick@shmanahar.org, jikos@kernel.org,
	benjamin.tissoires@redhat.com, bsz@semihalf.com,
	linux-input@vger.kernel.org, linux-kernel@vger.kernel.org,
	erosca@de.adit-jv.com, Andrew_Gabbasov@mentor.com
Subject: Re: [PATCH v11 00/56] atmel_mxt_ts misc
Date: Tue, 26 May 2020 23:43:07 -0700	[thread overview]
Message-ID: <20200527064307.GK89269@dtor-ws> (raw)
In-Reply-To: <20200508055656.96389-1-jiada_wang@mentor.com>

Hi Jiada,

On Thu, May 07, 2020 at 10:56:00PM -0700, Jiada Wang wrote:
> This patch-set forward ports Nick Dyer's work in ndyer/linux github
> repository as long as some other features and fixes

Sorry for ignoring the series for quite a while. I guess my biggest
issue with the series is that quite a bit of patches are trying to
handle the fallout from a very unfortunate design decision in the
driver: the fact that it attempts to automatically upload firmware and
config on every boot/probe. This design was done at my urging because I
did not have access to the technical documentation and did not realize
that the controller has non-volatile memory for both firmware and
configuration. We should only attempt to automatically load firmware
where device does not have non-volatile memory and is unable function
otherwise, in all other cases we better leave it to userspace to decide
whether to execute firmware update and when. The kernel should only
provide facilities so that userspace can initiate firmware update. This
design has worked well for Chrome OS for many years (it used Atmel
controllers in several products), and I would like to bring it to the
mainline.

Thanks.

-- 
Dmitry

  parent reply	other threads:[~2020-05-27  6:43 UTC|newest]

Thread overview: 80+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-05-08  5:56 [PATCH v11 00/56] atmel_mxt_ts misc Jiada Wang
2020-05-08  5:56 ` [PATCH v11 01/56] Input: introduce input_mt_report_slot_inactive Jiada Wang
2020-05-08  5:56 ` [PATCH v11 02/56] Input: atmel_mxt_ts - rework sysfs init/remove Jiada Wang
2020-05-08  5:56 ` [PATCH v11 03/56] Input: atmel_mxt_ts - only read messages in mxt_acquire_irq() when necessary Jiada Wang
2020-05-08  5:56 ` [PATCH v11 04/56] Input: atmel_mxt_ts - split large i2c transfers into blocks Jiada Wang
2020-05-11 22:19   ` Dmitry Torokhov
2020-06-30 14:33     ` Wang, Jiada
2020-05-08  5:56 ` [PATCH v11 05/56] Input: atmel_mxt_ts - output status from T48 Noise Supression Jiada Wang
2020-05-11 22:23   ` Dmitry Torokhov
2020-06-30 14:34     ` Wang, Jiada
2020-05-08  5:56 ` [PATCH v11 06/56] Input: atmel_mxt_ts - output status from T42 Touch Suppression Jiada Wang
2020-05-08  5:56 ` [PATCH v11 07/56] Input: atmel_mxt_ts - implement T9 vector/orientation support Jiada Wang
2020-05-11 22:53   ` Dmitry Torokhov
2020-06-30 14:35     ` Wang, Jiada
2020-05-08  5:56 ` [PATCH v11 08/56] Input: atmel_mxt_ts - implement T15 Key Array support Jiada Wang
2020-05-12  2:35   ` Dmitry Torokhov
2020-05-08  5:56 ` [PATCH v11 09/56] Input: atmel_mxt_ts - handle reports from T47 Stylus object Jiada Wang
2020-05-08  5:56 ` [PATCH v11 10/56] Input: atmel_mxt_ts - implement support for T107 active stylus Jiada Wang
2020-05-08  5:56 ` [PATCH v11 11/56] Input: atmel_mxt_ts - add debug for T92 gesture and T93 touch seq msgs Jiada Wang
2020-05-08  5:56 ` [PATCH v11 12/56] Input: atmel_mxt_ts - release touch state during suspend Jiada Wang
2020-05-08  5:56 ` [PATCH v11 13/56] dt-bindings: input: atmel: add suspend mode support Jiada Wang
2020-05-08  5:56 ` [PATCH v11 14/56] Input: atmel_mxt_ts - add regulator control support Jiada Wang
2020-05-08  5:56 ` [PATCH v11 15/56] Input: atmel_mxt_ts - report failures in suspend/resume Jiada Wang
2020-05-08  5:56 ` [PATCH v11 16/56] Input: atmel_mxt_ts - allow specification of firmware file name Jiada Wang
2020-05-08  5:56 ` [PATCH v11 17/56] Input: atmel_mxt_ts: Rename mxt_fw_version_show to fw_version_show Jiada Wang
2020-05-08  5:56 ` [PATCH v11 18/56] Input: atmel_mxt_ts: Rename mxt_hw_version_show to hw_version_show Jiada Wang
2020-05-08  5:56 ` [PATCH v11 19/56] Input: atmel_mxt_ts: rename mxt_update_fw_store to update_fw_store Jiada Wang
2020-05-08  5:56 ` [PATCH v11 20/56] Input: atmel_mxt_ts - handle cfg filename via pdata/sysfs Jiada Wang
2020-05-08  5:56 ` [PATCH v11 21/56] Input: atmel_mxt_ts - check data->input_dev is not null in mxt_input_sync() Jiada Wang
2020-05-08  5:56 ` [PATCH v11 22/56] dt-bindings: input: atmel: provide name of configuration file Jiada Wang
2020-05-08  5:56 ` [PATCH v11 23/56] Input: atmel_mxt_ts - allow input name to be specified in platform data Jiada Wang
2020-05-08  5:56 ` [PATCH v11 24/56] dt-bindings: input: atmel: support to specify input name Jiada Wang
2020-05-08  5:56 ` [PATCH v11 25/56] Input: atmel_mxt_ts - add config checksum attribute to sysfs Jiada Wang
2020-05-08  5:56 ` [PATCH v11 26/56] Input: atmel_mxt_ts - rename mxt_object_show to object_show Jiada Wang
2020-05-08  5:56 ` [PATCH v11 27/56] Input: atmel_mxt_ts - refactor firmware flash to extract context into struct Jiada Wang
2020-05-08  5:56 ` [PATCH v11 28/56] Input: atmel_mxt_ts - refactor code to enter bootloader into separate func Jiada Wang
2020-05-08  5:56 ` [PATCH v11 29/56] Input: atmel_mxt_ts - combine bootloader version query with probe Jiada Wang
2020-05-08  5:56 ` [PATCH v11 30/56] Input: atmel_mxt_ts - improve bootloader state machine handling Jiada Wang
2020-05-08  5:56 ` [PATCH v11 31/56] Input: atmel_mxt_ts - rename bl_completion to chg_completion Jiada Wang
2020-05-08  5:56 ` [PATCH v11 32/56] Input: atmel_mxt_ts - make bootloader interrupt driven Jiada Wang
2020-05-08  5:56 ` [PATCH v11 33/56] Input: atmel_mxt_ts - delay enabling IRQ when not using regulators Jiada Wang
2020-05-11  1:05   ` Dmitry Osipenko
2020-05-11  2:05     ` Wang, Jiada
2020-05-11 23:13       ` Dmitry Osipenko
2020-05-13  5:07         ` Wang, Jiada
2020-05-14  4:53           ` Dmitry Osipenko
2020-05-17  3:32             ` Wang, Jiada
2020-05-17 13:08               ` Dmitry Osipenko
2020-05-17 13:26                 ` Dmitry Osipenko
2020-05-25 14:51                   ` Wang, Jiada
2020-05-26 17:36                     ` Dmitry Osipenko
2020-05-08  5:56 ` [PATCH v11 34/56] Input: atmel_mxt_ts - implement I2C retries Jiada Wang
2020-05-08  5:56 ` [PATCH v11 35/56] Input: atmel_mxt_ts - orientation is not present in hover Jiada Wang
2020-05-08  5:56 ` [PATCH v11 36/56] Input: atmel_mxt_ts - implement debug output for messages Jiada Wang
2020-05-08  5:56 ` [PATCH v11 37/56] Input: atmel_mxt_ts - implement improved debug message interface Jiada Wang
2020-05-08  5:56 ` [PATCH v11 38/56] Input: atmel_mxt_ts - eliminate data->raw_info_block Jiada Wang
2020-05-08  5:56 ` [PATCH v11 39/56] Input: atmel_mxt_ts - Change call-points of mxt_free_* functions Jiada Wang
2020-05-08  5:56 ` [PATCH v11 40/56] Input: atmel_mxt_ts - rely on calculated_crc rather than file config_crc Jiada Wang
2020-05-08  5:56 ` [PATCH v11 41/56] input: atmel_mxt_ts: export GPIO reset line via sysfs Jiada Wang
2020-05-08  5:56 ` [PATCH v11 42/56] input: atmel_mxt_ts: Add Missing Delay for reset handling of Atmel touch panel controller in detachable displays Jiada Wang
2020-05-08  5:56 ` [PATCH v11 43/56] Input: atmel_mxt_ts: Add support for run self-test routine Jiada Wang
2020-05-08  5:56 ` [PATCH v11 44/56] Input: atmel_mxt_ts: Limit the max bytes transferred in an i2c transaction Jiada Wang
2020-05-08  5:56 ` [PATCH v11 45/56] Input: atmel_mxt_ts: return error from mxt_process_messages_until_invalid() Jiada Wang
2020-05-08  5:56 ` [PATCH v11 46/56] Input: Atmel: improve error handling in mxt_start() Jiada Wang
2020-05-08  5:56 ` [PATCH v11 47/56] Input: Atmel: improve error handling in mxt_initialize() Jiada Wang
2020-05-08  5:56 ` [PATCH v11 48/56] Input: Atmel: improve error handling in mxt_update_cfg() Jiada Wang
2020-05-08  5:56 ` [PATCH v11 49/56] Input: Atmel: Improve error handling in mxt_initialize_input_device() Jiada Wang
2020-05-08  5:56 ` [PATCH v11 50/56] Input: Atmel: handle ReportID "0x00" while processing T5 messages Jiada Wang
2020-05-08  5:56 ` [PATCH v11 51/56] Input: Atmel: use T44 object to process " Jiada Wang
2020-05-08  5:56 ` [PATCH v11 52/56] Input: atmel_mxt_ts: use gpiod_set_value_cansleep for reset pin Jiada Wang
2020-05-08  5:56 ` [PATCH v11 53/56] input: touchscreen: atmel_mxt_ts: Added sysfs entry for touchscreen status Jiada Wang
2020-05-08  5:56 ` [PATCH v11 54/56] input: atmel_mxt_ts: added sysfs interface to update atmel T38 data Jiada Wang
2020-05-10 12:03   ` kbuild test robot
2020-05-08  5:56 ` [PATCH v11 55/56] input: atmel_mxt_ts: don't disable IRQ before remove of mxt_fw_attr_group Jiada Wang
2020-05-08  5:56 ` [PATCH v11 56/56] Input: atmel_mxt_ts - Fix compilation warning Jiada Wang
2020-05-24 21:28 ` [PATCH v11 00/56] atmel_mxt_ts misc Pavel Machek
2020-05-27  6:43 ` Dmitry Torokhov [this message]
2020-06-25 13:50   ` Wang, Jiada
2020-07-08 13:05     ` Wang, Jiada
2020-07-17  7:21       ` Wang, Jiada

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200527064307.GK89269@dtor-ws \
    --to=dmitry.torokhov@gmail.com \
    --cc=Andrew_Gabbasov@mentor.com \
    --cc=benjamin.tissoires@redhat.com \
    --cc=bsz@semihalf.com \
    --cc=erosca@de.adit-jv.com \
    --cc=jiada_wang@mentor.com \
    --cc=jikos@kernel.org \
    --cc=linux-input@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=nick@shmanahar.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).