linux-input.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Dmitry Torokhov <dmitry.torokhov@gmail.com>
To: Lee Jones <lee.jones@linaro.org>
Cc: linux-kernel@vger.kernel.org, Sangwon Jee <jeesw@melfas.com>,
	Henrik Rydberg <rydberg@bitmath.org>,
	linux-input@vger.kernel.org
Subject: Re: [PATCH 06/15] input: touchscreen: melfas_mip4: Remove a bunch of unused variables
Date: Thu, 19 Nov 2020 19:09:01 -0800	[thread overview]
Message-ID: <20201120030901.GJ2034289@dtor-ws> (raw)
In-Reply-To: <20201113075525.GH2787115@dell>

On Fri, Nov 13, 2020 at 07:55:25AM +0000, Lee Jones wrote:
> On Thu, 12 Nov 2020, Dmitry Torokhov wrote:
> 
> > On Thu, Nov 12, 2020 at 11:01:55AM +0000, Lee Jones wrote:
> > > Fixes the following W=1 kernel build warning(s):
> > > 
> > >  drivers/input/touchscreen/melfas_mip4.c: In function ‘mip4_report_touch’:
> > >  drivers/input/touchscreen/melfas_mip4.c:474:5: warning: variable ‘size’ set but not used [-Wunused-but-set-variable]
> > >  drivers/input/touchscreen/melfas_mip4.c:472:5: warning: variable ‘pressure_stage’ set but not used [-Wunused-but-set-variable]
> > >  drivers/input/touchscreen/melfas_mip4.c:469:7: warning: variable ‘palm’ set but not used [-Wunused-but-set-variable]
> > >  drivers/input/touchscreen/melfas_mip4.c:468:7: warning: variable ‘hover’ set but not used [-Wunused-but-set-variable]
> > > 
> > > Cc: Sangwon Jee <jeesw@melfas.com>
> > > Cc: Dmitry Torokhov <dmitry.torokhov@gmail.com>
> > > Cc: Henrik Rydberg <rydberg@bitmath.org>
> > > Cc: linux-input@vger.kernel.org
> > > Signed-off-by: Lee Jones <lee.jones@linaro.org>
> > > ---
> > >  drivers/input/touchscreen/melfas_mip4.c | 11 -----------
> > >  1 file changed, 11 deletions(-)
> > > 
> > > diff --git a/drivers/input/touchscreen/melfas_mip4.c b/drivers/input/touchscreen/melfas_mip4.c
> > > index f67efdd040b24..9c98759098c7a 100644
> > > --- a/drivers/input/touchscreen/melfas_mip4.c
> > > +++ b/drivers/input/touchscreen/melfas_mip4.c
> > > @@ -465,13 +465,9 @@ static void mip4_report_keys(struct mip4_ts *ts, u8 *packet)
> > >  static void mip4_report_touch(struct mip4_ts *ts, u8 *packet)
> > >  {
> > >  	int id;
> > > -	bool hover;
> > > -	bool palm;
> > >  	bool state;
> > >  	u16 x, y;
> > > -	u8 pressure_stage = 0;
> > >  	u8 pressure;
> > > -	u8 size;
> > >  	u8 touch_major;
> > >  	u8 touch_minor;
> > >  
> > > @@ -480,14 +476,11 @@ static void mip4_report_touch(struct mip4_ts *ts, u8 *packet)
> > >  	case 1:
> > >  		/* Touch only */
> > >  		state = packet[0] & BIT(7);
> > > -		hover = packet[0] & BIT(5);
> > > -		palm = packet[0] & BIT(4);
> > 
> > No really happy that we'd be losing information about protocol. Is there
> > a better way to suppress the warning while keeping this info?
> 
> Yes.  We can either convert the information to comments, or mark the
> variables as __always_unused.

If __always unused suppresses this warning that would be my preference.

Thanks!

-- 
Dmitry

  reply	other threads:[~2020-11-20  3:09 UTC|newest]

Thread overview: 42+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-11-12 11:01 [PATCH 00/15] [Set 2/2] Rid W=1 issues from Input Lee Jones
2020-11-12 11:01 ` [PATCH 01/15] input: joystick: xpad: Demote non-conformant kernel-doc header Lee Jones
2020-11-20  3:16   ` Dmitry Torokhov
2020-11-12 11:01 ` [PATCH 02/15] input: keyboard: samsung-keypad: Remove set but unused variable 'var' Lee Jones
2020-11-13  7:37   ` Dmitry Torokhov
2020-11-12 11:01 ` [PATCH 03/15] input: misc: mc13783-pwrbutton: File headers are not good candidates for kernel-doc Lee Jones
2020-11-20  3:16   ` Dmitry Torokhov
2020-11-12 11:01 ` [PATCH 04/15] input: touchscreen: goodix: Provide some missing function parameter descriptions Lee Jones
2020-11-20  3:16   ` Dmitry Torokhov
2020-11-12 11:01 ` [PATCH 05/15] input: touchscreen: imx6ul_tsc: Remove set but unused variable 'value' Lee Jones
2020-11-12 12:20   ` Bough Chen
2020-11-13  7:37   ` Dmitry Torokhov
2020-11-19  9:12     ` Lee Jones
2020-11-12 11:01 ` [PATCH 06/15] input: touchscreen: melfas_mip4: Remove a bunch of unused variables Lee Jones
2020-11-13  7:42   ` Dmitry Torokhov
2020-11-13  7:55     ` Lee Jones
2020-11-20  3:09       ` Dmitry Torokhov [this message]
2020-11-20  7:45         ` Lee Jones
2020-11-12 11:01 ` [PATCH 07/15] input: touchscreen: usbtouchscreen: Remove unused variable 'ret' Lee Jones
2020-11-13  7:36   ` Dmitry Torokhov
2020-11-13  7:56     ` Lee Jones
2020-11-20  3:09       ` Dmitry Torokhov
2020-11-12 11:01 ` [PATCH 08/15] input: touchscreen: surface3_spi: Remove set but unused variable 'timestamp' Lee Jones
2020-11-13  7:40   ` Dmitry Torokhov
2020-11-13  7:42     ` Benjamin Tissoires
2020-11-15 22:02       ` Peter Hutterer
2020-11-12 11:01 ` [PATCH 09/15] input: misc: wm831x-on: Source file headers are not good candidates for kernel-doc Lee Jones
2020-11-12 11:20   ` Richard Fitzgerald
2020-11-20  3:17   ` Dmitry Torokhov
2020-11-12 11:01 ` [PATCH 10/15] input: touchscreen: surface3_spi: Fix naming issue with 'surface3_spi_get_gpio_config's header Lee Jones
2020-11-20  3:16   ` Dmitry Torokhov
2020-11-12 11:02 ` [PATCH 11/15] input: touchscreen: wm97xx-core: Provide missing description for 'status' Lee Jones
2020-11-12 11:22   ` Richard Fitzgerald
2020-11-20  3:17   ` Dmitry Torokhov
2020-11-12 11:02 ` [PATCH 12/15] input: mouse: synaptics: Demote non-conformant kernel-doc header Lee Jones
2020-11-20  3:18   ` Dmitry Torokhov
2020-11-12 11:02 ` [PATCH 13/15] input: touchscreen: goodix: Fix misspelling of 'ctx' Lee Jones
2020-11-20  3:20   ` Dmitry Torokhov
2020-11-12 11:02 ` [PATCH 14/15] input: keyboard: applespi: Provide missing struct 'message' descriptions Lee Jones
2020-11-20  3:21   ` Dmitry Torokhov
2020-11-12 11:02 ` [PATCH 15/15] input: mouse: vmmouse: Demote obvious abuse of kernel-doc header Lee Jones
2020-11-20  3:21   ` Dmitry Torokhov

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20201120030901.GJ2034289@dtor-ws \
    --to=dmitry.torokhov@gmail.com \
    --cc=jeesw@melfas.com \
    --cc=lee.jones@linaro.org \
    --cc=linux-input@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=rydberg@bitmath.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).