linux-input.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Jiri Slaby <jirislaby@gmail.com>
To: Mauro Carvalho Chehab <mchehab@redhat.com>
Cc: Jiri Kosina <jkosina@suse.cz>, Antti Palosaari <crope@iki.fi>,
	mchehab@infradead.org, linux-kernel@vger.kernel.org,
	linux-media@vger.kernel.org, Pekka Sarnila <sarnila@adit.fi>,
	linux-input@vger.kernel.org
Subject: Re: [PATCH 1/1] media: dvb-usb/af9015, fix disconnection crashes
Date: Thu, 04 Feb 2010 13:53:07 +0100	[thread overview]
Message-ID: <4B6AC333.6030308@gmail.com> (raw)
In-Reply-To: <4B6AB7E9.40607@redhat.com>

On 02/04/2010 01:04 PM, Mauro Carvalho Chehab wrote:
>> I have 2 dvb-t receivers and both of them need fullspeed quirk. Further
>> disable_rc_polling (a dvb_usb module parameter) must be set to not get
>> doubled characters now. And then, it works like a charm.
> 
> Module parameters always bothers me. They should be used as last resort alternatives
> when there's no other possible way to make it work properly.
> 
> If we know for sure that the RC polling should be disabled by an specific device, 
> just add this logic at the driver.

Yes, this is planned and written below:

>> Note that, it's just some kind of proof of concept. A migration of
>> af9015 devices from dvb-usb-remote needs to be done first.
>>
>> Ideas, comments?
> 
> Please next time, send the patch inlined. As you're using Thunderbird, you'll likely need
> Asalted-patches[1] to avoid thunderbird to destroy your patches.

I must disagree for two reasons: (a) it was not patch intended for merge
and (b) it was a plain-text attachment which is fine even for
submission. However I don't like patches as attachments so if I decide
to submit it for a merge later, you will not see it as an attachment
then :).

> +config HID_DVB
> +	tristate "DVB remotes support" if EMBEDDED
> +	depends on USB_HID
> +	default !EMBEDDED
> +	---help---
> +	Say Y here if you have DVB remote controllers.
> +
> 
> I think the better would be to use a more generic name, like HID_RC (for Remote Controller).
> I suspect we may need in the future other hacks for other similar devices.

Seconded. I would only go for some other abbreviation other than RC or
not abbreviate that at all.

> +static int dvb_event(struct hid_device *hdev, struct hid_field *field,
> +		struct hid_usage *usage, __s32 value)
> +{
> +	/* we won't get a "key up" event */
> +	if (value) {
> +		input_event(field->hidinput->input, usage->type, usage->code, 1);
> +		input_event(field->hidinput->input, usage->type, usage->code, 0);
> +	}
> +	return 1;
> +}
> 
> Several V4L/DVB IR's have keyup/keydown events. So I think the name here is also wrong:
> it is better to name the function as dvb_nokeyup_event() and eventually add an specific
> quirk to indicate devices that only have key up events.

If such appear later, it can be rewritten. I don't plan to add such
functionality now until somebody comes with device IDs which should be
handled that way and tests it, because I guess I will definitely do it
wrong otherwise. Do you know/have such a device?

There are many of quirks needed for various devices. I already wrote
about af9005 which sends key repeat aside from key down etc. But the
same as above, I can't test it (and don't want to introduce
regressions). So again, if somebody can test it, I'll be happy to code it.

thanks for the input,
-- 
js

  reply	other threads:[~2010-02-04 12:53 UTC|newest]

Thread overview: 19+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
     [not found] <1264007972-6261-1-git-send-email-jslaby@suse.cz>
     [not found] ` <4B5CDB53.6030009@iki.fi>
     [not found]   ` <4B5D6098.7010700@gmail.com>
     [not found]     ` <4B5DDDFB.5020907@iki.fi>
     [not found]       ` <alpine.LRH.2.00.1001261406010.15694@twin.jikos.cz>
2010-02-04 10:31         ` [PATCH 1/1] media: dvb-usb/af9015, fix disconnection crashes Jiri Slaby
2010-02-04 12:04           ` Mauro Carvalho Chehab
2010-02-04 12:53             ` Jiri Slaby [this message]
2010-02-04 13:41               ` Mauro Carvalho Chehab
2010-02-04 13:51                 ` Jiri Slaby
2010-02-04 14:05                   ` Mauro Carvalho Chehab
2010-02-05 14:02                 ` Jarod Wilson
2010-02-04 14:26                   ` Mauro Carvalho Chehab
2010-02-04 13:23           ` Pekka Sarnila
2010-02-04 13:27             ` Jiri Kosina
2010-02-04 14:07               ` Pekka Sarnila
2010-02-08  4:13                 ` Greg KH
2010-02-04 14:04             ` Mauro Carvalho Chehab
2010-02-04 15:05               ` Pekka Sarnila
2010-02-04 17:13                 ` Mauro Carvalho Chehab
2010-02-05 14:31                   ` Pekka Sarnila
2010-02-04 18:14           ` Dmitry Torokhov
2010-02-04 18:33             ` Jiri Slaby
2010-02-04 18:41               ` Dmitry Torokhov

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=4B6AC333.6030308@gmail.com \
    --to=jirislaby@gmail.com \
    --cc=crope@iki.fi \
    --cc=jkosina@suse.cz \
    --cc=linux-input@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-media@vger.kernel.org \
    --cc=mchehab@infradead.org \
    --cc=mchehab@redhat.com \
    --cc=sarnila@adit.fi \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).