iommu.lists.linux-foundation.org archive mirror
 help / color / mirror / Atom feed
From: Robin Murphy <robin.murphy@arm.com>
To: Catalin Marinas <catalin.marinas@arm.com>,
	Linus Torvalds <torvalds@linux-foundation.org>,
	Christoph Hellwig <hch@lst.de>
Cc: Arnd Bergmann <arnd@arndb.de>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	Will Deacon <will@kernel.org>, Marc Zyngier <maz@kernel.org>,
	Andrew Morton <akpm@linux-foundation.org>,
	Herbert Xu <herbert@gondor.apana.org.au>,
	Ard Biesheuvel <ardb@kernel.org>,
	Isaac Manjarres <isaacmanjarres@google.com>,
	Saravana Kannan <saravanak@google.com>,
	Alasdair Kergon <agk@redhat.com>, Daniel Vetter <daniel@ffwll.ch>,
	Joerg Roedel <joro@8bytes.org>, Mark Brown <broonie@kernel.org>,
	Mike Snitzer <snitzer@kernel.org>,
	"Rafael J. Wysocki" <rafael@kernel.org>,
	Jonathan Cameron <jic23@kernel.org>,
	linux-mm@kvack.org, iommu@lists.linux.dev,
	linux-arm-kernel@lists.infradead.org
Subject: Re: [PATCH v6 15/17] iommu/dma: Force bouncing if the size is not cacheline-aligned
Date: Fri, 9 Jun 2023 12:52:27 +0100	[thread overview]
Message-ID: <5438a21b-fcd8-0175-1fdd-ce6afbf84d86@arm.com> (raw)
In-Reply-To: <20230531154836.1366225-16-catalin.marinas@arm.com>

On 2023-05-31 16:48, Catalin Marinas wrote:
[...]
> diff --git a/include/linux/scatterlist.h b/include/linux/scatterlist.h
> index 2f06178996ba..69d87e312263 100644
> --- a/include/linux/scatterlist.h
> +++ b/include/linux/scatterlist.h
> @@ -251,11 +251,13 @@ static inline void sg_unmark_end(struct scatterlist *sg)
>   /*
>    * One 64-bit architectures there is a 4-byte padding in struct scatterlist
>    * (assuming also CONFIG_NEED_SG_DMA_LENGTH is set). Use this padding for DMA
> - * flags bits to indicate when a specific dma address is a bus address.
> + * flags bits to indicate when a specific dma address is a bus address or the
> + * buffer may have been bounced via SWIOTLB.
>    */
>   #ifdef CONFIG_NEED_SG_DMA_FLAGS
>   
> -#define SG_DMA_BUS_ADDRESS (1 << 0)
> +#define SG_DMA_BUS_ADDRESS	(1 << 0)
> +#define SG_DMA_SWIOTLB		(1 << 1)
>   
>   /**
>    * sg_dma_is_bus_address - Return whether a given segment was marked
> @@ -298,6 +300,34 @@ static inline void sg_dma_unmark_bus_address(struct scatterlist *sg)
>   	sg->dma_flags &= ~SG_DMA_BUS_ADDRESS;
>   }
>   
> +/**
> + * sg_dma_use_swiotlb - Return whether the scatterlist was marked for SWIOTLB
> + *			bouncing
> + * @sg:		SG entry
> + *
> + * Description:
> + *   Returns true if the scatterlist was marked for SWIOTLB bouncing. Not all
> + *   elements may have been bounced, so the caller would have to check
> + *   individual SG entries with is_swiotlb_buffer().
> + */
> +static inline bool sg_dma_use_swiotlb(struct scatterlist *sg)

Nit: since you tweaked the flag name again, we could happily go back to 
the pattern with s/use/is/ for this one now too.

> +{
> +	return sg->dma_flags & SG_DMA_SWIOTLB;
> +}
> +
> +/**
> + * sg_dma_use_swiotlb - Mark the scatterlist for SWIOTLB bouncing

Oops - s/use/mark/

Feel free to fix those up when applying if there's no other reason for a v7.

Thanks,
Robin.

> + * @sg:		SG entry
> + *
> + * Description:
> + *   Marks a a scatterlist for SWIOTLB bounce. Not all SG entries may be
> + *   bounced.
> + */
> +static inline void sg_dma_mark_swiotlb(struct scatterlist *sg)
> +{
> +	sg->dma_flags |= SG_DMA_SWIOTLB;
> +}
> +
>   #else
>   
>   static inline bool sg_dma_is_bus_address(struct scatterlist *sg)
> @@ -310,6 +340,13 @@ static inline void sg_dma_mark_bus_address(struct scatterlist *sg)
>   static inline void sg_dma_unmark_bus_address(struct scatterlist *sg)
>   {
>   }
> +static inline bool sg_dma_use_swiotlb(struct scatterlist *sg)
> +{
> +	return false;
> +}
> +static inline void sg_dma_mark_swiotlb(struct scatterlist *sg)
> +{
> +}
>   
>   #endif	/* CONFIG_NEED_SG_DMA_FLAGS */
>   

  reply	other threads:[~2023-06-09 11:52 UTC|newest]

Thread overview: 34+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2023-05-31 15:48 [PATCH v6 00/17] mm, dma, arm64: Reduce ARCH_KMALLOC_MINALIGN to 8 Catalin Marinas
2023-05-31 15:48 ` [PATCH v6 01/17] mm/slab: Decouple ARCH_KMALLOC_MINALIGN from ARCH_DMA_MINALIGN Catalin Marinas
2023-06-09 12:32   ` Vlastimil Babka
2023-06-09 13:44     ` Catalin Marinas
2023-06-09 13:57       ` Catalin Marinas
2023-06-09 14:13         ` Vlastimil Babka
2023-05-31 15:48 ` [PATCH v6 02/17] dma: Allow dma_get_cache_alignment() to be overridden by the arch code Catalin Marinas
2023-05-31 15:48 ` [PATCH v6 03/17] mm/slab: Simplify create_kmalloc_cache() args and make it static Catalin Marinas
2023-06-09 13:03   ` Vlastimil Babka
2023-05-31 15:48 ` [PATCH v6 04/17] mm/slab: Limit kmalloc() minimum alignment to dma_get_cache_alignment() Catalin Marinas
2023-06-09 14:33   ` Vlastimil Babka
2023-05-31 15:48 ` [PATCH v6 05/17] drivers/base: Use ARCH_DMA_MINALIGN instead of ARCH_KMALLOC_MINALIGN Catalin Marinas
2023-05-31 15:48 ` [PATCH v6 06/17] drivers/gpu: " Catalin Marinas
2023-05-31 15:48 ` [PATCH v6 07/17] drivers/usb: " Catalin Marinas
2023-05-31 15:48 ` [PATCH v6 08/17] drivers/spi: " Catalin Marinas
2023-05-31 15:48 ` [PATCH v6 09/17] dm-crypt: " Catalin Marinas
2023-05-31 15:48 ` [PATCH v6 10/17] iio: core: " Catalin Marinas
2023-06-02 11:19   ` Jonathan Cameron
2023-05-31 15:48 ` [PATCH v6 11/17] arm64: Allow kmalloc() caches aligned to the smaller cache_line_size() Catalin Marinas
2023-05-31 15:48 ` [PATCH v6 12/17] scatterlist: Add dedicated config for DMA flags Catalin Marinas
2023-05-31 15:48 ` [PATCH v6 13/17] dma-mapping: Name SG DMA flag helpers consistently Catalin Marinas
2023-05-31 15:48 ` [PATCH v6 14/17] dma-mapping: Force bouncing if the kmalloc() size is not cache-line-aligned Catalin Marinas
2023-05-31 15:48 ` [PATCH v6 15/17] iommu/dma: Force bouncing if the size is not cacheline-aligned Catalin Marinas
2023-06-09 11:52   ` Robin Murphy [this message]
2023-05-31 15:48 ` [PATCH v6 16/17] mm: slab: Reduce the kmalloc() minimum alignment if DMA bouncing possible Catalin Marinas
2023-06-09 14:39   ` Vlastimil Babka
2023-05-31 15:48 ` [PATCH v6 17/17] arm64: Enable ARCH_WANT_KMALLOC_DMA_BOUNCE for arm64 Catalin Marinas
2023-06-08  5:45 ` [PATCH v6 00/17] mm, dma, arm64: Reduce ARCH_KMALLOC_MINALIGN to 8 Isaac Manjarres
2023-06-08  8:05   ` Ard Biesheuvel
2023-06-08 21:29     ` Isaac Manjarres
2023-06-09  8:11       ` Petr Tesařík
2023-06-12  7:44         ` Tomonori Fujita
2023-06-12  7:47           ` Christoph Hellwig
2023-06-14 23:55             ` Isaac Manjarres

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=5438a21b-fcd8-0175-1fdd-ce6afbf84d86@arm.com \
    --to=robin.murphy@arm.com \
    --cc=agk@redhat.com \
    --cc=akpm@linux-foundation.org \
    --cc=ardb@kernel.org \
    --cc=arnd@arndb.de \
    --cc=broonie@kernel.org \
    --cc=catalin.marinas@arm.com \
    --cc=daniel@ffwll.ch \
    --cc=gregkh@linuxfoundation.org \
    --cc=hch@lst.de \
    --cc=herbert@gondor.apana.org.au \
    --cc=iommu@lists.linux.dev \
    --cc=isaacmanjarres@google.com \
    --cc=jic23@kernel.org \
    --cc=joro@8bytes.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-mm@kvack.org \
    --cc=maz@kernel.org \
    --cc=rafael@kernel.org \
    --cc=saravanak@google.com \
    --cc=snitzer@kernel.org \
    --cc=torvalds@linux-foundation.org \
    --cc=will@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).