linux-kbuild.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2018-11-27 19:29:46 to 2018-12-13 09:21:35 UTC [more...]

[PATCH] kbuild, x86: revert macros in extended asm workarounds
 2018-12-13  9:17 UTC 

[PATCH] deb-pkg: generate correct build dependencies
 2018-12-13  8:07 UTC 

[PATCH v13 00/25] kasan: add software tag-based mode for arm64
 2018-12-12 15:04 UTC  (35+ messages)
` [PATCH v13 01/25] kasan, mm: change hooks signatures
` [PATCH v13 02/25] kasan, slub: handle pointer tags in early_kmem_cache_node_alloc
` [PATCH v13 03/25] kasan: move common generic and tag-based code to common.c
` [PATCH v13 04/25] kasan: rename source files to reflect the new naming scheme
` [PATCH v13 05/25] kasan: add CONFIG_KASAN_GENERIC and CONFIG_KASAN_SW_TAGS
` [PATCH v13 06/25] kasan, arm64: adjust shadow size for tag-based mode
` [PATCH v13 07/25] kasan: rename kasan_zero_page to kasan_early_shadow_page
` [PATCH v13 08/25] kasan: initialize shadow to 0xff for tag-based mode
` [PATCH v13 09/25] arm64: move untagged_addr macro from uaccess.h to memory.h
` [PATCH v13 10/25] kasan: add tag related helper functions
` [PATCH v13 11/25] kasan, arm64: untag address in _virt_addr_is_linear
` [PATCH v13 12/25] kasan: preassign tags to objects with ctors or SLAB_TYPESAFE_BY_RCU
` [PATCH v13 13/25] kasan, arm64: fix up fault handling logic
` [PATCH v13 14/25] kasan, arm64: enable top byte ignore for the kernel
` [PATCH v13 15/25] kasan, mm: perform untagged pointers comparison in krealloc
` [PATCH v13 16/25] kasan: split out generic_report.c from report.c
` [PATCH v13 17/25] kasan: add bug reporting routines for tag-based mode
` [PATCH v13 18/25] mm: move obj_to_index to include/linux/slab_def.h
` [PATCH v13 19/25] kasan: add hooks implementation for tag-based mode
` [PATCH v13 20/25] kasan, arm64: add brk handler for inline instrumentation
` [PATCH v13 21/25] kasan, mm, arm64: tag non slab memory allocated via pagealloc
` [PATCH v13 22/25] kasan: add __must_check annotations to kasan hooks
` [PATCH v13 23/25] kasan, arm64: select HAVE_ARCH_KASAN_SW_TAGS
` [PATCH v13 24/25] kasan: update documentation
` [PATCH v13 25/25] kasan: add SPDX-License-Identifier mark to source files

[PATCH 0/7] microblaze: fix various problems in building boot images
 2018-12-12 14:21 UTC  (33+ messages)
` [PATCH 1/7] microblaze: fix cleaning of "
` [PATCH 2/7] microblaze: adjust the help to the real behavior
` [PATCH 3/7] microblaze: move "... is ready" message to arch/microblaze/Makefile
` [PATCH 4/7] microblaze: fix multiple bugs in arch/microblaze/boot/Makefile
` [PATCH 5/7] microblaze: add linux.bin* and simpleImage.* to PHONY
` [PATCH 6/7] microblaze: fix race condition in building boot images
` [PATCH 7/7] microblaze: remove the unneeded code just in case file copy fails

Lets Work Together
 2018-12-12 13:52 UTC 

[PATCH 00/27] kconfig: remove all reduce/shift conflicts, refactor lexer, fix various issues
 2018-12-12  8:28 UTC  (32+ messages)
` [PATCH 01/27] kconfig: fix file name and line number of warn_ignored_character()
` [PATCH 02/27] kconfig: fix memory leak when EOF is encountered in quotation
` [PATCH 03/27] kconfig: require T_EOL to reduce visible statement
` [PATCH 04/27] kconfig: remove unneeded pattern matching to whitespaces
` [PATCH 05/27] kconfig: refactor pattern matching in STRING state
` [PATCH 06/27] kconfig: fix ambiguous grammar in terms of new lines
` [PATCH 07/27] kconfig: clean up EOF handling in the lexer
` [PATCH 08/27] kconfig: warn no new line at end of file
` [PATCH 09/27] kconfig: remove grammatically ambiguous "unexpected option" diagnostic
` [PATCH 10/27] kconfig: remove grammatically ambiguous option_error
` [PATCH 11/27] kconfig: remove redundant if_block rule
` [PATCH 12/27] kconfig: remove redundant menu_block rule
` [PATCH 13/27] kconfig: loosen the order of "visible" and "depends on" in menu entry
` [PATCH 14/27] kconfig: rename depends_list to comment_option_list
` [PATCH 15/27] kconfig: remove redundant token defines
` [PATCH 16/27] kconfig: use distinct tokens for type and default properties
` [PATCH 17/27] kconfig: refactor scanning and parsing "option" properties
` [PATCH 18/27] kconfig: use specific tokens instead of T_ASSIGN for assignments
` [PATCH 19/27] kconfig: use T_WORD instead of T_VARIABLE for variables
` [PATCH 20/27] microblaze: surround string default in Kconfig with double quotes
` [PATCH 21/27] treewide: surround file paths in Kconfig files "
` [PATCH 22/27] kconfig: ban the use of '.' and '/' in unquoted words
` [PATCH 23/27] kconfig: refactor end token rules
` [PATCH 24/27] kconfig: stop associating kconf_id with yylval
` [PATCH 25/27] kconfig: switch to ASSIGN_VAL state in the second lexer
` [PATCH 26/27] kconfig: update current_pos "
` [PATCH 27/27] kconfig: remove keyword lookup table entirely

[PATCH v4] kbuild: Add support for DT binding schema checks
 2018-12-12  3:05 UTC  (2+ messages)

[PATCH v3] kbuild: Add support for DT binding schema checks
 2018-12-12  3:04 UTC  (6+ messages)

[PATCH 1/3] kbuild: refactor Makefile.asm-generic
 2018-12-11 16:29 UTC  (7+ messages)
` [PATCH 2/3] kbuild: generate asm-generic wrappers if mandatory headers are missing

[PATCH 1/4] kbuild: remove redundant quiet_modtag for $(obj-m)
 2018-12-11 12:01 UTC  (4+ messages)
` [PATCH 2/4] kbuild: refactor quiet_modtag
` [PATCH 3/4] kbuild: refactor part-of-module
` [PATCH 4/4] kbuild: handle part-of-module correctly for *.ll and *.symtypes

[PATCH v2 01/34] kbuild: Add support for DT binding schema checks
 2018-12-10 15:55 UTC  (3+ messages)

[PATCH 001/123] kconfig/conf.c: Added optional colorization of output
 2018-12-10  8:27 UTC  (2+ messages)
` [PATCH 1/1] "

[PATCH 1/5] kconfig: remove unneeded setsym label in conf_read_simple()
 2018-12-08  6:55 UTC  (6+ messages)
` [PATCH 2/5] kconfig: rename conf_split_config() to conf_touch_deps()
` [PATCH 3/5] kconfig: split out code touching a file to conf_touch_dep()
` [PATCH 4/5] kconfig: remove S_OTHER symbol type and correct dependency tracking
` [PATCH 5/5] kconfig: remove k_invalid from expr_parse_string() return type

[PATCH] kbuild: move .SECONDARY special target to Kbuild.include
 2018-12-08  6:54 UTC  (2+ messages)

[RFC] ARM: dts: Introduce wilddt function instead of listing imx boards
 2018-12-07 18:35 UTC 

Urgently need money? We can help you!
 2018-12-07 14:13 UTC 

[PATCH] scripts: add a tool to produce a compile_commands.json file
 2018-12-06 22:23 UTC 

[PATCH v12 00/25] kasan: add software tag-based mode for arm64
 2018-12-06 12:25 UTC  (34+ messages)
` [PATCH v12 01/25] kasan, mm: change hooks signatures
` [PATCH v12 02/25] kasan, slub: handle pointer tags in early_kmem_cache_node_alloc
` [PATCH v12 03/25] kasan: move common generic and tag-based code to common.c
` [PATCH v12 04/25] kasan: rename source files to reflect the new naming scheme
` [PATCH v12 05/25] kasan: add CONFIG_KASAN_GENERIC and CONFIG_KASAN_SW_TAGS
` [PATCH v12 06/25] kasan, arm64: adjust shadow size for tag-based mode
` [PATCH v12 07/25] kasan: rename kasan_zero_page to kasan_early_shadow_page
` [PATCH v12 08/25] kasan: initialize shadow to 0xff for tag-based mode
` [PATCH v12 09/25] arm64: move untagged_addr macro from uaccess.h to memory.h
` [PATCH v12 10/25] kasan: add tag related helper functions
` [PATCH v12 11/25] kasan, arm64: untag address in _virt_addr_is_linear
` [PATCH v12 12/25] kasan: preassign tags to objects with ctors or SLAB_TYPESAFE_BY_RCU
` [PATCH v12 13/25] kasan, arm64: fix up fault handling logic
` [PATCH v12 14/25] kasan, arm64: enable top byte ignore for the kernel
` [PATCH v12 15/25] kasan, mm: perform untagged pointers comparison in krealloc
` [PATCH v12 16/25] kasan: split out generic_report.c from report.c
` [PATCH v12 17/25] kasan: add bug reporting routines for tag-based mode
` [PATCH v12 18/25] mm: move obj_to_index to include/linux/slab_def.h
` [PATCH v12 19/25] kasan: add hooks implementation for tag-based mode
` [PATCH v12 20/25] kasan, arm64: add brk handler for inline instrumentation
` [PATCH v12 21/25] kasan, mm, arm64: tag non slab memory allocated via pagealloc
` [PATCH v12 22/25] kasan: add __must_check annotations to kasan hooks
` [PATCH v12 23/25] kasan, arm64: select HAVE_ARCH_KASAN_SW_TAGS
` [PATCH v12 24/25] kasan: update documentation
` [PATCH v12 25/25] kasan: add SPDX-License-Identifier mark to source files

[PATCH] kbuild: exploit parallel building for CONFIG_HEADERS_CHECK
 2018-12-05  7:38 UTC 

[PATCH] kbuild: remove a special handling for *.agh in Makefile.headersinst
 2018-12-05  7:37 UTC 

[kbuild:kbuild 29/29] make[2]: *** No rule to make target 'arch/sh/boot/dts/.dtb.o', needed by 'arch/sh/boot/dts/built-in.a'
 2018-12-02  4:42 UTC  (2+ messages)

[PATCH v2 1/2] kbuild: make 'archprepare' depend on 'scripts'
 2018-12-01 14:56 UTC  (4+ messages)
` [PATCH v2 2/2] kbuild: descend into scripts/gcc-plugins/ via scripts/Makefile

[PATCH] pcmcia: remove per-arch PCMCIA config entry
 2018-12-01 14:55 UTC  (3+ messages)

[PATCH 1/3] modpost: refactor seen flag clearing in add_depends()
 2018-12-01 14:54 UTC  (2+ messages)

[PATCH] kbuild: fix UML build error with CONFIG_GCC_PLUGINS
 2018-12-01 14:51 UTC  (2+ messages)

[PATCH 0/2] x86: Asm macros fixes
 2018-12-01  6:29 UTC  (15+ messages)
` [PATCH 1/2] Makefile: Fix distcc compilation with x86 macros

builddeb: Missing arch/x86/kernel/macros.s when building modules with dkms
 2018-11-30  9:53 UTC  (6+ messages)

[kbuild:kbuild 24/24] cc1: error: cannot load plugin ./scripts/gcc-plugins/randomize_layout_plugin.so
 2018-11-29  1:58 UTC  (2+ messages)

netfilter Kconfig question
 2018-11-28  1:11 UTC  (11+ messages)

[PATCH 1/2] kbuild: make 'scripts' depend on 'prepare0'
 2018-11-27 22:02 UTC  (3+ messages)
` [PATCH 2/2] kbuild: descend into scripts/gcc-plugins/ via scripts/Makefile

[PATCH v11 00/24] kasan: add software tag-based mode for arm64
 2018-11-27 16:12 UTC  (7+ messages)
` [PATCH v11 05/24] kasan: add CONFIG_KASAN_GENERIC and CONFIG_KASAN_SW_TAGS
` [PATCH v11 09/24] arm64: move untagged_addr macro from uaccess.h to memory.h

hidden string Kconfig ?
 2018-11-27 15:20 UTC  (11+ messages)


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).