linux-kbuild.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2021-08-19 09:10:19 to 2021-08-31 14:42:31 UTC [more...]

[PATCH v6 kspp-next 00/22] Function Granular KASLR
 2021-08-31 14:41 UTC  (10+ messages)
` [PATCH v6 kspp-next 01/22] kbuild: Fix TRIM_UNUSED_KSYMS with LTO_CLANG
` [PATCH v6 kspp-next 02/22] kbuild: merge vmlinux_link() between the ordinary link and Clang LTO
` [PATCH v6 kspp-next 03/22] kbuild: do not remove 'linux' link in scripts/link-vmlinux.sh
` [PATCH v6 kspp-next 05/22] x86: tools/relocs: Support >64K section headers
` [PATCH v6 kspp-next 06/22] x86/boot: Allow a "silent" kaslr random byte fetch
` [PATCH v6 kspp-next 07/22] x86: Makefile: Add build and config option for CONFIG_FG_KASLR
` [PATCH v6 kspp-next 08/22] Make sure ORC lookup covers the entire _etext - _stext
` [PATCH v6 kspp-next 09/22] x86/tools: Add relative relocs for randomized functions
` [PATCH v6 kspp-next 10/22] x86/boot/compressed: Avoid duplicate malloc() implementations

[PATCH v2 00/13] kbuild: second round of Clang LTO refactoring
 2021-08-31  7:40 UTC  (14+ messages)
` [PATCH v2 01/13] kbuild: move objtool_args back to scripts/Makefile.build
` [PATCH v2 02/13] kbuild: rename __objtool_obj to objtool
` [PATCH v2 03/13] kbuild: store the objtool command in *.cmd files
` [PATCH v2 04/13] kbuild: factor out OBJECT_FILES_NON_STANDARD check into a macro
` [PATCH v2 05/13] kbuild: detect objtool update without using .SECONDEXPANSION
` [PATCH v2 06/13] kbuild: reuse $(cmd_objtool) for cmd_cc_lto_link_modules
` [PATCH v2 07/13] kbuild: do not create built-in.a.symversions or lib.a.symversions
` [PATCH v2 08/13] kbuild: build modules in the same way with/without Clang LTO
` [PATCH v2 09/13] kbuild: add cmd_and_savecmd macro
` [PATCH v2 10/13] kbuild: rebuild modules when objtool is updated for CONFIG_LTO_CLANG
` [PATCH v2 11/13] kbuild: always postpone CRC links for module versioning
` [PATCH v2 12/13] kbuild: merge cmd_modversions_c and cmd_modversions_S
` [PATCH v2 13/13] kbuild: merge cmd_ar_builtin and cmd_ar_module

[PATCH v3 4/5] Makefile: Enable -Warray-bounds
 2021-08-31  4:31 UTC  (3+ messages)
` [PATCH v3 5/5] Makefile: Enable -Wzero-length-bounds

[PATCH 1/5] modpost: get the *.mod file path more simply
 2021-08-31  1:43 UTC  (8+ messages)
` [PATCH 2/5] kbuild: detect objtool changes correctly without .SECONDEXPANSION
` [PATCH 3/5] kbuild: clean up objtool_args slightly
` [PATCH 4/5] kbuild: merge objtool_args into objtool in scripts/Makefile.build
` [PATCH 5/5] kbuild: rebuild *.lto.o when objtool is changed

[GIT PULL] Kbuild updates for v5.15-rc1
 2021-08-31  1:33 UTC 

[PATCH V5 00/13] Introduce vfio_pci_core subsystem
 2021-08-30 15:40 UTC  (16+ messages)
` [PATCH V5 01/13] vfio/pci: Rename vfio_pci.c to vfio_pci_core.c
` [PATCH V5 02/13] vfio/pci: Rename vfio_pci_private.h to vfio_pci_core.h
` [PATCH V5 03/13] vfio/pci: Rename vfio_pci_device to vfio_pci_core_device
` [PATCH V5 04/13] vfio/pci: Rename ops functions to fit core namings
` [PATCH V5 05/13] vfio/pci: Include vfio header in vfio_pci_core.h
` [PATCH V5 06/13] vfio/pci: Split the pci_driver code out of vfio_pci_core.c
` [PATCH V5 07/13] vfio/pci: Move igd initialization to vfio_pci.c
` [PATCH V5 08/13] vfio/pci: Move module parameters "
` [PATCH V5 09/13] PCI: Add 'override_only' field to struct pci_device_id
` [PATCH V5 10/13] PCI / VFIO: Add 'override_only' support for VFIO PCI sub system
` [PATCH V5 11/13] vfio: Use select for eventfd
` [PATCH V5 12/13] vfio: Use kconfig if XX/endif blocks instead of repeating 'depends on'
` [PATCH V5 13/13] vfio/pci: Introduce vfio_pci_core.ko

[PATCH] kbuild: redo fake deps at include/ksym/*.h
 2021-08-30  8:20 UTC 

[PATCH 0/3] checkkconfigsymbols.py: Fix various bugs
 2021-08-29 23:41 UTC  (12+ messages)
` [PATCH 1/3] checkkconfigsymbols.py: Fix the '--ignore' option
` [PATCH 2/3] checkkconfigsymbols.py: Fix Kconfig parsing to find 'if' lines
` [PATCH 3/3] checkkconfigsymbols.py: Forbid passing 'HEAD' to --commit

[kbuild:testing15 44/46] Can't open perl script "scripts/merge-symvers.pl": No such file or directory
 2021-08-28 21:53 UTC 

[PATCH 00/13] kbuild: refactoring after Clang LTO
 2021-08-28 11:57 UTC  (5+ messages)
` [PATCH 09/13] kbuild: do not create built-in.a.symversions or lib.a.symversions

[PATCH] scripts: add generic install.sh
 2021-08-27 15:14 UTC  (3+ messages)

[PATCH 00/20] kbuild: unify the install.sh script usage
 2021-08-27 14:02 UTC  (4+ messages)
` [PATCH 18/20] kbuild: sh: remove unused install script

[PATCH] kconfig: forbid symbols that end with '_MODULE'
 2021-08-26 12:16 UTC  (7+ messages)

[PATCH V4 00/13] Introduce vfio_pci_core subsystem
 2021-08-26  9:36 UTC  (31+ messages)
` [PATCH V4 01/13] vfio/pci: Rename vfio_pci.c to vfio_pci_core.c
` [PATCH V4 02/13] vfio/pci: Rename vfio_pci_private.h to vfio_pci_core.h
` [PATCH V4 03/13] vfio/pci: Rename vfio_pci_device to vfio_pci_core_device
` [PATCH V4 04/13] vfio/pci: Rename ops functions to fit core namings
` [PATCH V4 05/13] vfio/pci: Include vfio header in vfio_pci_core.h
` [PATCH V4 06/13] vfio/pci: Split the pci_driver code out of vfio_pci_core.c
` [PATCH V4 07/13] vfio/pci: Move igd initialization to vfio_pci.c
` [PATCH V4 08/13] vfio/pci: Move module parameters "
` [PATCH V4 09/13] PCI: Add 'override_only' field to struct pci_device_id
` [PATCH V4 10/13] PCI / VFIO: Add 'override_only' support for VFIO PCI sub system
` [PATCH V4 11/13] vfio: Use select for eventfd
` [PATCH V4 12/13] vfio: Use kconfig if XX/endif blocks instead of repeating 'depends on'
` [PATCH V4 13/13] vfio/pci: Introduce vfio_pci_core.ko

[PATCH v2 4/5] Makefile: Enable -Warray-bounds
 2021-08-26  5:04 UTC  (2+ messages)
` [PATCH v2 5/5] Makefile: Enable -Wzero-length-bounds

[PATCH 0/2] Harden clang against unknown flag options
 2021-08-25 22:32 UTC  (7+ messages)
` [PATCH 1/2] x86: Do not add -falign flags unconditionally for clang
` [PATCH 2/2] kbuild: Add -Werror=ignored-optimization-argument to CLANG_FLAGS

[PATCH v2 0/7] Add __alloc_size() for better bounds checking
 2021-08-25 21:31 UTC  (9+ messages)
` [PATCH v2 4/7] slab: Add __alloc_size attributes "
` [PATCH v2 6/7] percpu: "

[PATCH 5/5] Makefile: Enable -Wzero-length-bounds
 2021-08-25 21:17 UTC  (2+ messages)

[PATCH] kbuild: Enable -Wimplicit-fallthrough for clang 14.0.0+
 2021-08-25 21:09 UTC  (8+ messages)

[PATCH 0/5] Add __alloc_size() for better bounds checking
 2021-08-25 16:34 UTC  (5+ messages)

[PATCH 0/7] kbuild: remove cc-option-yn
 2021-08-25  4:49 UTC  (19+ messages)
` [PATCH 2/7] s390: replace cc-option-yn uses with cc-option
` [PATCH 3/7] powerpc: "
` [PATCH 4/7] arc: "
` [PATCH 5/7] x86: remove cc-option-yn test for -mtune=
` [PATCH 6/7] Makefile: replace cc-option-yn uses with cc-option

[PATCH V3 00/13] Introduce vfio_pci_core subsystem
 2021-08-24 22:48 UTC  (19+ messages)
` [PATCH V3 01/13] vfio/pci: Rename vfio_pci.c to vfio_pci_core.c
` [PATCH V3 02/13] vfio/pci: Rename vfio_pci_private.h to vfio_pci_core.h
` [PATCH V3 03/13] vfio/pci: Rename vfio_pci_device to vfio_pci_core_device
` [PATCH V3 04/13] vfio/pci: Rename ops functions to fit core namings
` [PATCH V3 05/13] vfio/pci: Include vfio header in vfio_pci_core.h
` [PATCH V3 06/13] vfio/pci: Split the pci_driver code out of vfio_pci_core.c
` [PATCH V3 07/13] vfio/pci: Move igd initialization to vfio_pci.c
` [PATCH V3 08/13] vfio/pci: Move module parameters "
` [PATCH V3 09/13] PCI: Add 'override_only' field to struct pci_device_id
` [PATCH V3 10/13] PCI / VFIO: Add 'override_only' support for VFIO PCI sub system
` [PATCH V3 11/13] vfio: Use select for eventfd
` [PATCH V3 12/13] vfio: Use kconfig if XX/endif blocks instead of repeating 'depends on'
` [PATCH V3 13/13] vfio/pci: Introduce vfio_pci_core.ko

[PATCH v2 43/63] net: qede: Use memset_startat() for counters
 2021-08-24 16:51 UTC 

[PATCH v2 17/63] bnx2x: Use struct_group() for memcpy() region
 2021-08-24 13:51 UTC 

[PATCH 1/1] of: unittest: rename overlay source files from .dts to .dtso
 2021-08-24  9:20 UTC  (13+ messages)

[PATCH v2 00/63] Introduce strict memcpy() bounds checking
 2021-08-24  7:38 UTC  (35+ messages)
` [PATCH v2 18/63] drm/amd/pm: Use struct_group() for memcpy() region
` [PATCH v2 22/63] HID: cp2112: "
` [PATCH v2 45/63] ath11k: Use memset_startat() for clearing queue descriptors
` [PATCH v2 47/63] intel_th: msu: Use memset_startat() for clearing hw header
` [PATCH v2 55/63] HID: roccat: Use struct_group() to zero kone_mouse_event
` [PATCH v2 56/63] RDMA/mlx5: Use struct_group() to zero struct mlx5_ib_mr
` [PATCH v2 57/63] powerpc/signal32: Use struct_group() to zero spe regs

[PATCH] Makefile: use -Wno-main in the full kernel tree
 2021-08-21 23:26 UTC  (4+ messages)

What is the oldest perl version being used with the kernel ? update oldest supported to 5.14 ?
 2021-08-21  5:43 UTC  (4+ messages)

[PATCH V2 00/12] Introduce vfio_pci_core subsystem
 2021-08-19 22:36 UTC  (5+ messages)
` [PATCH V2 06/12] vfio/pci: Split the pci_driver code out of vfio_pci_core.c

[PATCH V2 09/12] PCI: Add 'override_only' bitmap to struct pci_device_id
 2021-08-19 22:19 UTC  (6+ messages)

[PATCH][RESEND] tools/thermal/tmon: simplify Makefile and fix cross build
 2021-08-19 10:02 UTC  (3+ messages)


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).