linux-kbuild.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2021-08-25 13:52:29 to 2021-09-08 16:13:52 UTC [more...]

[PATCH v2 00/13] kbuild: second round of Clang LTO refactoring
 2021-09-08 16:12 UTC  (41+ messages)
` [PATCH v2 01/13] kbuild: move objtool_args back to scripts/Makefile.build
` [PATCH v2 02/13] kbuild: rename __objtool_obj to objtool
` [PATCH v2 03/13] kbuild: store the objtool command in *.cmd files
` [PATCH v2 04/13] kbuild: factor out OBJECT_FILES_NON_STANDARD check into a macro
` [PATCH v2 05/13] kbuild: detect objtool update without using .SECONDEXPANSION
` [PATCH v2 06/13] kbuild: reuse $(cmd_objtool) for cmd_cc_lto_link_modules
` [PATCH v2 07/13] kbuild: do not create built-in.a.symversions or lib.a.symversions
` [PATCH v2 08/13] kbuild: build modules in the same way with/without Clang LTO
` [PATCH v2 09/13] kbuild: add cmd_and_savecmd macro
` [PATCH v2 10/13] kbuild: rebuild modules when objtool is updated for CONFIG_LTO_CLANG
` [PATCH v2 11/13] kbuild: always postpone CRC links for module versioning
` [PATCH v2 12/13] kbuild: merge cmd_modversions_c and cmd_modversions_S
` [PATCH v2 13/13] kbuild: merge cmd_ar_builtin and cmd_ar_module

[PATCH] Revert "Enable '-Werror' by default for all kernel builds"
 2021-09-08 16:12 UTC  (13+ messages)

[PATCH v2] gen_compile_commands: fix missing 'sys' package
 2021-09-08  3:28 UTC 

[GIT PULL v2] Kbuild updates for v5.15-rc1
 2021-09-08  3:09 UTC  (29+ messages)

[PATCH] Makefile: use -Wno-main in the full kernel tree
 2021-09-07 22:42 UTC  (4+ messages)

Module build problems with gmake 3.x
 2021-09-03 22:06 UTC 

[PATCH] kbuild: Enable DT schema checks for %.dtb targets
 2021-09-03 15:52 UTC 

[PATCH v6 kspp-next 00/22] Function Granular KASLR
 2021-09-03 11:19 UTC  (26+ messages)
` [PATCH v6 kspp-next 01/22] kbuild: Fix TRIM_UNUSED_KSYMS with LTO_CLANG
` [PATCH v6 kspp-next 02/22] kbuild: merge vmlinux_link() between the ordinary link and Clang LTO
` [PATCH v6 kspp-next 03/22] kbuild: do not remove 'linux' link in scripts/link-vmlinux.sh
` [PATCH v6 kspp-next 04/22] kbuild: merge vmlinux_link() between ARCH=um and other architectures
` [PATCH v6 kspp-next 05/22] x86: tools/relocs: Support >64K section headers
` [PATCH v6 kspp-next 06/22] x86/boot: Allow a "silent" kaslr random byte fetch
` [PATCH v6 kspp-next 07/22] x86: Makefile: Add build and config option for CONFIG_FG_KASLR
` [PATCH v6 kspp-next 08/22] Make sure ORC lookup covers the entire _etext - _stext
` [PATCH v6 kspp-next 09/22] x86/tools: Add relative relocs for randomized functions
` [PATCH v6 kspp-next 10/22] x86/boot/compressed: Avoid duplicate malloc() implementations
` [PATCH v6 kspp-next 11/22] x86: Add support for function granular KASLR
` [PATCH v6 kspp-next 12/22] linkage: add macros for putting ASM functions into own sections
` [PATCH v6 kspp-next 14/22] FG-KASLR: use a scripted approach to handle .text.* sections
` [PATCH v6 kspp-next 15/22] kallsyms: Hide layout
` [PATCH v6 kspp-next 16/22] livepatch: only match unique symbols when using fgkaslr
` [PATCH v6 kspp-next 17/22] x86/boot: allow FG-KASLR to be selected
` [PATCH v6 kspp-next 18/22] arm64/crypto: conditionally place ASM functions into separate sections
` [PATCH v6 kspp-next 19/22] module: Reorder functions
` [PATCH v6 kspp-next 20/22] module: use a scripted approach for FG-KASLR
` [PATCH v6 kspp-next 21/22] Documentation: add a documentation "
` [PATCH v6 kspp-next 22/22] maintainers: add MAINTAINERS entry "

[GIT PULL] Kbuild updates for v5.15-rc1
 2021-09-02 23:29 UTC  (3+ messages)

[PATCH] kconfig: Create links to main menu items in search
 2021-09-01 17:53 UTC 

[PATCH v2] checkkconfigsymbols.py: Remove skipping of help lines in parse_kconfig_file
 2021-09-01 16:49 UTC 

[PATCH 0/3] checkkconfigsymbols.py: Fix various bugs
 2021-09-01 15:17 UTC  (10+ messages)
` [PATCH 2/3] checkkconfigsymbols.py: Fix Kconfig parsing to find 'if' lines
` [PATCH 3/3] checkkconfigsymbols.py: Forbid passing 'HEAD' to --commit

[PATCH v2] checkkconfigsymbols.py: Forbid passing 'HEAD' to --commit
 2021-09-01 14:52 UTC 

[PATCH v2 00/63] Introduce strict memcpy() bounds checking
 2021-09-01 13:46 UTC  (3+ messages)
` [PATCH v2 07/63] skbuff: Switch structure bounds to struct_group()

[PATCH] kconfig: forbid symbols that end with '_MODULE'
 2021-09-01  7:07 UTC  (7+ messages)

[PATCH v3 4/5] Makefile: Enable -Warray-bounds
 2021-08-31 20:49 UTC  (7+ messages)
` [PATCH v3 5/5] Makefile: Enable -Wzero-length-bounds

[PATCH 1/5] modpost: get the *.mod file path more simply
 2021-08-31  1:43 UTC  (8+ messages)
` [PATCH 2/5] kbuild: detect objtool changes correctly without .SECONDEXPANSION
` [PATCH 3/5] kbuild: clean up objtool_args slightly
` [PATCH 4/5] kbuild: merge objtool_args into objtool in scripts/Makefile.build
` [PATCH 5/5] kbuild: rebuild *.lto.o when objtool is changed

[PATCH V5 00/13] Introduce vfio_pci_core subsystem
 2021-08-30 15:40 UTC  (16+ messages)
` [PATCH V5 01/13] vfio/pci: Rename vfio_pci.c to vfio_pci_core.c
` [PATCH V5 02/13] vfio/pci: Rename vfio_pci_private.h to vfio_pci_core.h
` [PATCH V5 03/13] vfio/pci: Rename vfio_pci_device to vfio_pci_core_device
` [PATCH V5 04/13] vfio/pci: Rename ops functions to fit core namings
` [PATCH V5 05/13] vfio/pci: Include vfio header in vfio_pci_core.h
` [PATCH V5 06/13] vfio/pci: Split the pci_driver code out of vfio_pci_core.c
` [PATCH V5 07/13] vfio/pci: Move igd initialization to vfio_pci.c
` [PATCH V5 08/13] vfio/pci: Move module parameters "
` [PATCH V5 09/13] PCI: Add 'override_only' field to struct pci_device_id
` [PATCH V5 10/13] PCI / VFIO: Add 'override_only' support for VFIO PCI sub system
` [PATCH V5 11/13] vfio: Use select for eventfd
` [PATCH V5 12/13] vfio: Use kconfig if XX/endif blocks instead of repeating 'depends on'
` [PATCH V5 13/13] vfio/pci: Introduce vfio_pci_core.ko

[PATCH] kbuild: redo fake deps at include/ksym/*.h
 2021-08-30  8:20 UTC 

[kbuild:testing15 44/46] Can't open perl script "scripts/merge-symvers.pl": No such file or directory
 2021-08-28 21:53 UTC 

[PATCH 00/13] kbuild: refactoring after Clang LTO
 2021-08-28 11:57 UTC  (4+ messages)
` [PATCH 09/13] kbuild: do not create built-in.a.symversions or lib.a.symversions

[PATCH] scripts: add generic install.sh
 2021-08-27 15:14 UTC  (3+ messages)

[PATCH 00/20] kbuild: unify the install.sh script usage
 2021-08-27 14:02 UTC  (4+ messages)
` [PATCH 18/20] kbuild: sh: remove unused install script

[PATCH V4 00/13] Introduce vfio_pci_core subsystem
 2021-08-26  9:36 UTC  (31+ messages)
` [PATCH V4 01/13] vfio/pci: Rename vfio_pci.c to vfio_pci_core.c
` [PATCH V4 02/13] vfio/pci: Rename vfio_pci_private.h to vfio_pci_core.h
` [PATCH V4 03/13] vfio/pci: Rename vfio_pci_device to vfio_pci_core_device
` [PATCH V4 04/13] vfio/pci: Rename ops functions to fit core namings
` [PATCH V4 05/13] vfio/pci: Include vfio header in vfio_pci_core.h
` [PATCH V4 06/13] vfio/pci: Split the pci_driver code out of vfio_pci_core.c
` [PATCH V4 07/13] vfio/pci: Move igd initialization to vfio_pci.c
` [PATCH V4 08/13] vfio/pci: Move module parameters "
` [PATCH V4 09/13] PCI: Add 'override_only' field to struct pci_device_id
` [PATCH V4 10/13] PCI / VFIO: Add 'override_only' support for VFIO PCI sub system
` [PATCH V4 11/13] vfio: Use select for eventfd
` [PATCH V4 12/13] vfio: Use kconfig if XX/endif blocks instead of repeating 'depends on'
` [PATCH V4 13/13] vfio/pci: Introduce vfio_pci_core.ko

[PATCH v2 4/5] Makefile: Enable -Warray-bounds
 2021-08-26  5:04 UTC  (2+ messages)
` [PATCH v2 5/5] Makefile: Enable -Wzero-length-bounds

[PATCH 0/2] Harden clang against unknown flag options
 2021-08-25 22:32 UTC  (5+ messages)
` [PATCH 1/2] x86: Do not add -falign flags unconditionally for clang
` [PATCH 2/2] kbuild: Add -Werror=ignored-optimization-argument to CLANG_FLAGS

[PATCH v2 0/7] Add __alloc_size() for better bounds checking
 2021-08-25 21:31 UTC  (3+ messages)
` [PATCH v2 4/7] slab: Add __alloc_size attributes "

[PATCH 5/5] Makefile: Enable -Wzero-length-bounds
 2021-08-25 21:17 UTC  (2+ messages)

[PATCH] kbuild: Enable -Wimplicit-fallthrough for clang 14.0.0+
 2021-08-25 21:09 UTC  (8+ messages)

[PATCH 0/5] Add __alloc_size() for better bounds checking
 2021-08-25 16:34 UTC  (5+ messages)


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).