linux-kselftest.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH 0/3] selftests: vdso: Add a selftest for vDSO getcpu()
@ 2020-05-05 17:47 Mark Brown
  2020-05-05 17:47 ` [PATCH 1/3] selftests: vdso: Rename vdso_test to vdso_test_gettimeofday Mark Brown
                   ` (3 more replies)
  0 siblings, 4 replies; 13+ messages in thread
From: Mark Brown @ 2020-05-05 17:47 UTC (permalink / raw)
  To: Shuah Khan; +Cc: linux-kernel, linux-kselftest, Mark Brown

This series does a bit of a cleanup of the existing tests for the vDSO
in kselftest and then adds a new test for getcpu().

Mark Brown (3):
  selftests: vdso: Rename vdso_test to vdso_test_gettimeofday
  selftests: vdso: Use a header file to prototype parse_vdso API
  selftests: vdso: Add a selftest for vDSO getcpu()

 tools/testing/selftests/vDSO/.gitignore       |  2 +
 tools/testing/selftests/vDSO/Makefile         |  5 +-
 tools/testing/selftests/vDSO/parse_vdso.c     | 24 +--------
 tools/testing/selftests/vDSO/parse_vdso.h     | 31 ++++++++++++
 .../selftests/vDSO/vdso_standalone_test_x86.c |  4 +-
 .../testing/selftests/vDSO/vdso_test_getcpu.c | 50 +++++++++++++++++++
 .../{vdso_test.c => vdso_test_gettimeofday.c} | 10 ++--
 7 files changed, 92 insertions(+), 34 deletions(-)
 create mode 100644 tools/testing/selftests/vDSO/parse_vdso.h
 create mode 100644 tools/testing/selftests/vDSO/vdso_test_getcpu.c
 rename tools/testing/selftests/vDSO/{vdso_test.c => vdso_test_gettimeofday.c} (84%)

-- 
2.20.1


^ permalink raw reply	[flat|nested] 13+ messages in thread

end of thread, other threads:[~2020-05-22 16:15 UTC | newest]

Thread overview: 13+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-05-05 17:47 [PATCH 0/3] selftests: vdso: Add a selftest for vDSO getcpu() Mark Brown
2020-05-05 17:47 ` [PATCH 1/3] selftests: vdso: Rename vdso_test to vdso_test_gettimeofday Mark Brown
2020-05-05 17:47 ` [PATCH 2/3] selftests: vdso: Use a header file to prototype parse_vdso API Mark Brown
2020-05-19 17:29   ` shuah
2020-05-19 17:42     ` Mark Brown
2020-05-05 17:47 ` [PATCH 3/3] selftests: vdso: Add a selftest for vDSO getcpu() Mark Brown
2020-05-19 17:11   ` shuah
2020-05-19 17:44     ` Mark Brown
2020-05-22 14:55       ` shuah
2020-05-22 15:12         ` Mark Brown
2020-05-22 15:15           ` shuah
2020-05-22 16:15             ` Mark Brown
2020-05-05 18:17 ` [PATCH 0/3] " shuah

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).